dev-python/libvirt-python: version bump to 6.2.0
authorMatthias Maier <tamiko@gentoo.org>
Sun, 5 Apr 2020 17:20:30 +0000 (12:20 -0500)
committerMatthias Maier <tamiko@gentoo.org>
Sun, 5 Apr 2020 17:20:30 +0000 (12:20 -0500)
Package-Manager: Portage-2.3.96, Repoman-2.3.22
Signed-off-by: Matthias Maier <tamiko@gentoo.org>
dev-python/libvirt-python/Manifest
dev-python/libvirt-python/libvirt-python-6.2.0.ebuild [new file with mode: 0644]

index 1aeb4bacccc897c7da21b0838d15b27af8871998..2eba7f4c24303beb0694b461bc16b45d0a7391f5 100644 (file)
@@ -1,2 +1,3 @@
 DIST libvirt-python-6.0.0.tar.gz 196791 BLAKE2B 8fa524d76277fc0278158205f25da8a4331c732a7cbdbe7d9ef9c697b8d5758d8f4182ac749212f4b7c147cde5648fa8cd245cbe0ae809e9079ef654def3c4a1 SHA512 1d64bdb430d099c6e72259e49d99aa985b9ba745c543d3a12ad614c48e1334a3607e093d93612c34e8ec3990e880f3d66fd33199605f2ec9a419193bbb839d58
 DIST libvirt-python-6.1.0.tar.gz 196848 BLAKE2B 352cd4da292ffbe41fa7d06e862204507c89f8e5a7a2951a1a6e22b66d8c27b6a7394071bcf6eb025b00b7dba40a655c02f56f4c38278ba4bb0848f174642881 SHA512 a7994e21cbd5aa9c16aa4baa0e314ab3d71b15692e50da8f243994aee7393cc4dd2a27b39def87599ecfc32764980c71069ce4c904edc379219bd76a6344ce1e
+DIST libvirt-python-6.2.0.tar.gz 196971 BLAKE2B e11c82bd98c62072c14992c485339337bcc3639bbd56154185834c145f76984ced9f09f7f05c302609ce6629a8d13db77debd6f3d85e8fdb00c818bbe51cc552 SHA512 91f6940f60670221c914ee7ffc8d89a74222bcacbbf1afd5f679479f1e1bcec563f297a8e8359d6f51a1eee29162e39e2a276f5277fcec551d50f112e304a947
diff --git a/dev-python/libvirt-python/libvirt-python-6.2.0.ebuild b/dev-python/libvirt-python/libvirt-python-6.2.0.ebuild
new file mode 100644 (file)
index 0000000..607c6f7
--- /dev/null
@@ -0,0 +1,47 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{3_6,3_7} )
+
+MY_P="${P/_rc/-rc}"
+
+inherit distutils-r1
+
+if [[ ${PV} = *9999* ]]; then
+       inherit git-r3
+       EGIT_REPO_URI="https://libvirt.org/git/libvirt-python.git"
+       SRC_URI=""
+       KEYWORDS=""
+       RDEPEND="app-emulation/libvirt:=[-python(-)]"
+else
+       SRC_URI="https://libvirt.org/sources/python/${MY_P}.tar.gz"
+       KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+       RDEPEND="app-emulation/libvirt:0/${PV}"
+fi
+S="${WORKDIR}/${P%_rc*}"
+
+DESCRIPTION="libvirt Python bindings"
+HOMEPAGE="https://www.libvirt.org"
+LICENSE="LGPL-2"
+SLOT="0"
+IUSE="examples test"
+RESTRICT="!test? ( test )"
+
+DEPEND="${RDEPEND}
+       virtual/pkgconfig
+       test? ( dev-python/lxml[${PYTHON_USEDEP}]
+               dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_test() {
+       esetup.py test
+}
+
+python_install_all() {
+       if use examples; then
+               dodoc -r examples
+               docompress -x /usr/share/doc/${PF}/examples
+       fi
+       distutils-r1_python_install_all
+}