dev-lang/gnat-gpl: Fix build withouy ustat
authorTupone Alfredo <tupone@gentoo.org>
Sat, 20 Apr 2019 06:50:30 +0000 (08:50 +0200)
committerTupone Alfredo <tupone@gentoo.org>
Sat, 20 Apr 2019 06:50:30 +0000 (08:50 +0200)
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Package-Manager: Portage-2.3.62, Repoman-2.3.11

dev-lang/gnat-gpl/files/gnat-gpl-2017-ustat.patch [new file with mode: 0644]
dev-lang/gnat-gpl/gnat-gpl-2017.ebuild

diff --git a/dev-lang/gnat-gpl/files/gnat-gpl-2017-ustat.patch b/dev-lang/gnat-gpl/files/gnat-gpl-2017-ustat.patch
new file mode 100644 (file)
index 0000000..505c23b
--- /dev/null
@@ -0,0 +1,31 @@
+--- a/gcc-6-gpl-2017-src/libsanitizer/sanitizer_common/sanitizer_platform_limits_posix.cc      2019-04-19 20:53:11.382114157 +0200
++++ b/gcc-6-gpl-2017-src/libsanitizer/sanitizer_common/sanitizer_platform_limits_posix.cc      2019-04-19 20:57:10.725037767 +0200
+@@ -150,7 +150,6 @@
+ # include <sys/procfs.h>
+ #endif
+ #include <sys/user.h>
+-#include <sys/ustat.h>
+ #include <linux/cyclades.h>
+ #include <linux/if_eql.h>
+ #include <linux/if_plip.h>
+@@ -243,7 +242,19 @@
+ #endif // SANITIZER_LINUX || SANITIZER_FREEBSD
+ #if SANITIZER_LINUX && !SANITIZER_ANDROID
+-  unsigned struct_ustat_sz = sizeof(struct ustat);
++  // Use pre-computed size of struct ustat to avoid <sys/ustat.h> which
++  // has been removed from glibc 2.28.
++#if defined(__aarch64__) || defined(__s390x__) || defined (__mips64) \
++  || defined(__powerpc64__) || defined(__arch64__) || defined(__sparcv9) \
++  || defined(__x86_64__)
++#define SIZEOF_STRUCT_USTAT 32
++#elif defined(__arm__) || defined(__i386__) || defined(__mips__) \
++  || defined(__powerpc__) || defined(__s390__)  || defined(__sparc__)
++#define SIZEOF_STRUCT_USTAT 20
++#else
++#error Unknown size of struct ustat
++#endif
++  unsigned struct_ustat_sz = SIZEOF_STRUCT_USTAT;
+   unsigned struct_rlimit64_sz = sizeof(struct rlimit64);
+   unsigned struct_statvfs64_sz = sizeof(struct statvfs64);
+ #endif // SANITIZER_LINUX && !SANITIZER_ANDROID
index bdcc9a45caf920885b7c18077e83e9d1fd345a76..92ca343650503a567a288f6f981f708738edaa9d 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI="5"
@@ -125,6 +125,9 @@ src_prepare() {
                -e 's:$(P) ::g' \
                gcc/ada/gcc-interface/Makefile.in \
                || die "sed failed"
+       # fix missing ustat.h
+       epatch "${FILESDIR}/${P}-ustat.patch"
+
        toolchain_src_prepare
 }