media-gfx/alembic: bump to version 1.7.11
authorBernd Waibel <waebbl@gmail.com>
Sat, 15 Jun 2019 16:14:40 +0000 (18:14 +0200)
committerAndreas Sturmlechner <asturm@gentoo.org>
Sun, 16 Jun 2019 21:50:54 +0000 (23:50 +0200)
Closes: https://bugs.gentoo.org/688114
Package-Manager: Portage-2.3.67, Repoman-2.3.14
Signed-off-by: Bernd Waibel <waebbl@gmail.com>
Closes: https://github.com/gentoo/gentoo/pull/12258
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
media-gfx/alembic/Manifest
media-gfx/alembic/alembic-1.7.11.ebuild [new file with mode: 0644]
media-gfx/alembic/files/alembic-1.7.11-0001-Fix-to-find-boost-with-cmake-3.11.patch [new file with mode: 0644]
media-gfx/alembic/files/alembic-1.7.11-0002-Find-IlmBase-by-setting-a-proper-ILMBASE_ROOT-value.patch [new file with mode: 0644]
media-gfx/alembic/files/alembic-1.7.11-0003-Fix-env-var-for-renderman.patch [new file with mode: 0644]
media-gfx/alembic/files/alembic-1.7.11-0004-Fix-a-compile-issue-with-const.patch [new file with mode: 0644]
media-gfx/alembic/files/alembic-1.7.11-0005-Fix-install-locations.patch [new file with mode: 0644]

index 86ce90b589963cb97119f4b76364bc7529d4b907..84ee0347aaa836d656ced519c9537f7aa66f02ca 100644 (file)
@@ -1 +1,2 @@
+DIST alembic-1.7.11.tar.gz 826833 BLAKE2B ea2ee92cefcc92d3658b8c71351ec0f72bd1fb5d5b6c771ceebe81b1db61a280420f480cd3612f44bc134cccb388954be89baba9dc6e5973e102bc55d65cd974 SHA512 94b9c218a2fe6e2e24205aff4a2f6bab784851c2aa15592fb60ea91f0e8038b0c0656a118f3a5cba0d3de8917dd90b74d0e2d1c4ac034b9ee3f5d0741d9f6b70
 DIST alembic-1.7.9.tar.gz 813379 BLAKE2B 599edeb5ad805656755b3e150fba56182d1d60673951b0c1702b3e3e82d9499ec4fcb938303103c27f84458f61ab8de4b872eaa322380ae7713e3b4cd3831af7 SHA512 8025c20525ffbd5bdc9dd5a33ad8238e49f063d244ab9d112e7d1ddb7ee7cf9b36ceb74cb45d658ce22d3033552c89bddf6b818cf466ea46aa1a70a41fdeddb2
diff --git a/media-gfx/alembic/alembic-1.7.11.ebuild b/media-gfx/alembic/alembic-1.7.11.ebuild
new file mode 100644 (file)
index 0000000..ac081bc
--- /dev/null
@@ -0,0 +1,107 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit cmake-utils multiprocessing python-single-r1
+
+DESCRIPTION="Open framework for storing and sharing scene data"
+HOMEPAGE="https://www.alembic.io/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="arnold +boost doc examples hdf5 maya prman python test zlib"
+
+# pyalembic python bindings need boost
+REQUIRED_USE="
+       ${PYTHON_REQUIRED_USE}
+       hdf5? ( zlib )
+       python? ( boost )
+"
+
+RDEPEND="
+       ${PYTHON_DEPS}
+       >=media-libs/openexr-2.3.0:=
+       boost? ( >=dev-libs/boost-1.65.0:=[python,${PYTHON_USEDEP}] )
+       hdf5? ( >=sci-libs/hdf5-1.10.2:=[zlib(+)] )
+       python? ( >=dev-python/pyilmbase-2.3.0[${PYTHON_USEDEP}] )
+       zlib? ( >=sys-libs/zlib-1.2.11-r1 )
+"
+DEPEND="
+       ${RDEPEND}
+       doc? ( >=app-doc/doxygen-1.8.14-r1 )
+"
+
+DOCS=( "ACKNOWLEDGEMENTS.txt" "FEEDBACK.txt" "NEWS.txt" "README.txt" )
+
+PATCHES=(
+       "${FILESDIR}/${P}-0001-Fix-to-find-boost-with-cmake-3.11.patch"
+       "${FILESDIR}/${P}-0002-Find-IlmBase-by-setting-a-proper-ILMBASE_ROOT-value.patch"
+       "${FILESDIR}/${P}-0003-Fix-env-var-for-renderman.patch"
+       "${FILESDIR}/${P}-0004-Fix-a-compile-issue-with-const.patch"
+       "${FILESDIR}/${P}-0005-Fix-install-locations.patch"
+)
+
+src_prepare() {
+       cmake-utils_src_prepare
+       if use doc; then
+               doxygen -u Doxyfile || die "Failed to update Doxyfile"
+               sed -i -e 's|DOT_NUM_THREADS[ \t]*= 0|DOT_NUM_THREADS = '$(makeopts_jobs)'|' Doxyfile || die "Failed to change dot threads"
+       fi
+}
+
+src_configure() {
+       local mycmakeargs=(
+               -DALEMBIC_SHARED_LIBS=ON
+               # The CMakeLists.txt file needs C++11 or C++-0x if none of them
+               # is defined
+               -DALEMBIC_LIB_USES_BOOST=$(usex boost)
+               -DALEMBIC_LIB_USES_TR1=$(usex !boost)
+               -DUSE_ARNOLD=$(usex arnold)
+               -DUSE_BINARIES=ON
+               -DUSE_EXAMPLES=$(usex examples)
+               -DUSE_HDF5=$(usex hdf5)
+               -DUSE_MAYA=$(usex maya)
+               -DUSE_PRMAN=$(usex prman)
+               -DUSE_PYALEMBIC=$(usex python)
+               -DUSE_TESTS=$(usex test)
+       )
+       cmake-utils_src_configure
+}
+
+src_compile() {
+       cmake-utils_src_compile
+       if use doc; then
+               doxygen Doxyfile || die "Failed to build documentation"
+       fi
+}
+
+src_install() {
+       use doc && local HTML_DOCS=( doc/html/. )
+       cmake-utils_src_install
+}
+
+pkg_postinst() {
+       if use arnold; then
+               einfo "NOTE: The arnold plugin is highly experimental and hasn't been"
+               einfo "tested, due to missing license. If you have trouble compiling"
+               einfo "or running it, please file a bug report for the package at"
+               einfo "Gentoo's bugzilla."
+       fi
+       if use maya; then
+               einfo "NOTE: The maya plugin is highly experimental and hasn't been"
+               einfo "tested, due to missing license. If you have trouble compiling"
+               einfo "or running it, please file a bug report for the package at"
+               einfo "Gentoo's bugzilla."
+       fi
+       if use prman; then
+               einfo "If you're looking for an ebuild for renderman, you may want to"
+               einfo "try the waebbl overlay: 'eselect repository enable waebbl'"
+               einfo "followed by 'emerge renderman'"
+       fi
+}
diff --git a/media-gfx/alembic/files/alembic-1.7.11-0001-Fix-to-find-boost-with-cmake-3.11.patch b/media-gfx/alembic/files/alembic-1.7.11-0001-Fix-to-find-boost-with-cmake-3.11.patch
new file mode 100644 (file)
index 0000000..d36e250
--- /dev/null
@@ -0,0 +1,60 @@
+From 2060f95c43685895f36269667c30acf7499b81b6 Mon Sep 17 00:00:00 2001
+From: Bernd Waibel <waebbl@gmail.com>
+Date: Sat, 15 Jun 2019 13:19:57 +0200
+Subject: [PATCH 1/5] Fix to find boost with >=cmake-3.11
+
+Cmake version 3.11 and later has a new syntax introduced, when
+looking for boost libraries.
+This patches adds this syntax if an appropriate cmake version is used.
+
+Signed-off-by: Bernd Waibel <waebbl@gmail.com>
+---
+ cmake/AlembicBoost.cmake        | 10 +++++++++-
+ python/PyAlembic/CMakeLists.txt |  8 ++++----
+ 2 files changed, 13 insertions(+), 5 deletions(-)
+
+diff --git a/cmake/AlembicBoost.cmake b/cmake/AlembicBoost.cmake
+index 21b3515..db59157 100644
+--- a/cmake/AlembicBoost.cmake
++++ b/cmake/AlembicBoost.cmake
+@@ -79,7 +79,15 @@ IF (USE_PYALEMBIC AND APPLE)
+ ENDIF()
+ IF (USE_PYALEMBIC)
+-    FIND_PACKAGE(Boost 1.42.0 COMPONENTS program_options python)
++    # cmake>=3.11 has a new syntax when searching for boost, which
++    # needs to add the python version.
++    # Hardcode the python version number, as PYTHON_VERSION_{MAJOR,MINOR}
++    # are not yet know in the configuration phase.
++    IF(CMAKE_MINOR_VERSION VERSION_GREATER 10)
++         FIND_PACKAGE(Boost 1.42.0 COMPONENTS program_options python27)
++    ELSE()
++         FIND_PACKAGE(Boost 1.42.0 COMPONENTS program_options python)
++    ENDIF()
+ ELSE()
+     FIND_PACKAGE(Boost 1.42.0 COMPONENTS program_options)
+ ENDIF()
+diff --git a/python/PyAlembic/CMakeLists.txt b/python/PyAlembic/CMakeLists.txt
+index a3fdb31..af8dcb5 100644
+--- a/python/PyAlembic/CMakeLists.txt
++++ b/python/PyAlembic/CMakeLists.txt
+@@ -33,12 +33,12 @@
+ ##
+ ##-*****************************************************************************
+-MESSAGE(STATUS "Boost_PYTHON_LIBRARY: ${Boost_PYTHON_LIBRARY}")
++MESSAGE(STATUS "Boost_PYTHON${PYTHON_VERSION_MAJOR}${PYTHON_VERSION_MINOR}_LIBRARY: ${Boost_PYTHON${PYTHON_VERSION_MAJOR}${PYTHON_VERSION_MINOR}_LIBRARY_RELEASE}")
+ # set core libs
+-IF (Boost_PYTHON_LIBRARY AND ALEMBIC_PYTHON_LIBRARY)
+-    MESSAGE(STATUS "Found libboost_python: ${Boost_PYTHON_LIBRARY}")
+-    SET(PLIBS ${ALEMBIC_PYTHON_LIBRARY} ${Boost_PYTHON_LIBRARY})
++IF (Boost_PYTHON${PYTHON_VERSION_MAJOR}${PYTHON_VERSION_MINOR}_LIBRARY_RELEASE AND ALEMBIC_PYTHON_LIBRARY)
++    MESSAGE(STATUS "Found libboost_python: ${Boost_PYTHON${PYTHON_VERSION_MAJOR}${PYTHON_VERSION_MINOR}_LIBRARY_RELEASE}")
++    SET(PLIBS ${ALEMBIC_PYTHON_LIBRARY} ${Boost_PYTHON${PYTHON_VERSION_MAJOR}${PYTHON_VERSION_MINOR}_LIBRARY_RELEASE})
+     # lots of warnings coming from unused local typedefs inside boost python
+     IF (NOT WINDOWS)
+-- 
+2.22.0
+
diff --git a/media-gfx/alembic/files/alembic-1.7.11-0002-Find-IlmBase-by-setting-a-proper-ILMBASE_ROOT-value.patch b/media-gfx/alembic/files/alembic-1.7.11-0002-Find-IlmBase-by-setting-a-proper-ILMBASE_ROOT-value.patch
new file mode 100644 (file)
index 0000000..c561e26
--- /dev/null
@@ -0,0 +1,72 @@
+From 60bbcde225f3c28a36d8643c451509d9deb09222 Mon Sep 17 00:00:00 2001
+From: Bernd Waibel <waebbl@gmail.com>
+Date: Sat, 15 Jun 2019 13:34:09 +0200
+Subject: [PATCH 2/5] Find IlmBase by setting a proper ILMBASE_ROOT value and
+ by using pkg-config to determine the installed ilmbase version, instead of
+ using the cmake STRINGS command.
+
+Signed-off-by: Bernd Waibel <waebbl@gmail.com>
+---
+ cmake/Modules/FindIlmBase.cmake   | 18 +++++++++++++++++-
+ cmake/Modules/FindPyIlmBase.cmake |  2 +-
+ 2 files changed, 18 insertions(+), 2 deletions(-)
+
+diff --git a/cmake/Modules/FindIlmBase.cmake b/cmake/Modules/FindIlmBase.cmake
+index 679a02f..0fe2b1a 100644
+--- a/cmake/Modules/FindIlmBase.cmake
++++ b/cmake/Modules/FindIlmBase.cmake
+@@ -52,7 +52,7 @@ IF(NOT DEFINED ILMBASE_ROOT)
+           SET( ALEMBIC_ILMBASE_ROOT NOTFOUND )
+         ELSE()
+           # TODO: set to default install path when shipping out
+-          SET( ALEMBIC_ILMBASE_ROOT "/usr/local/ilmbase-1.0.1/" )
++          SET( ALEMBIC_ILMBASE_ROOT "/usr" )
+         ENDIF()
+     ELSE()
+         IF ( ${WINDOWS} )
+@@ -87,6 +87,21 @@ SET(_ilmbase_SEARCH_DIRS
+     /usr/freeware
+ )
++# use pkg-config to determine the correct version
++include(FindPkgConfig)
++IF(PKG_CONFIG_FOUND)
++    PKG_CHECK_MODULES(PC_ILMBASE QUIET IlmBase)
++    IF(PC_ILMBASE_FOUND)
++        SET(ILMBASE_VERSION ${PC_ILMBASE_VERSION})
++        SET(ALEMBIC_ILMBASE_INCLUDE_DIRECTORY ${PC_ILMBASE_INCLUDE_DIRS})
++        STRING(REGEX MATCH "-lHalf" ALEMBIC_ILMBASE_HALF_LIB ${PC_ILMBASE_LDFLAGS})
++        STRING(REGEX MATCH "-lIex" ALEMBIC_ILMBASE_IEX_LIB ${PC_ILMBASE_LDFLAGS})
++        STRING(REGEX MATCH "-lIexMath" ALEMBIC_ILMBASE_IEXMATH_LIB ${PC_ILMBASE_LDFLAGS})
++        STRING(REGEX MATCH "-lIlmThread" ALEMBIC_ILMBASE_ILMTHREAD_LIB ${PC_ILMBASE_LDFLAGS})
++        String(REGEX MATCH "-lImath" ALEMBIC_ILMBASE_IMATH_LIB ${PC_ILMBASE_LDFLAGS})
++    ENDIF()
++ELSE(PKG_CONFIG_FOUND)
++
+ FIND_PATH(ILMBASE_INCLUDE_DIR
+   NAMES
+     IlmBaseConfig.h
+@@ -179,6 +194,7 @@ IF ( ${ALEMBIC_ILMBASE_INCLUDE_DIRECTORY} STREQUAL "ALEMBIC_ILMBASE_INCLUDE_DIRE
+   MESSAGE( FATAL_ERROR "ilmbase header files not found, required: ALEMBIC_ILMBASE_ROOT: ${ALEMBIC_ILMBASE_ROOT}" )
+ ENDIF()
++ENDIF(PKG_CONFIG_FOUND)
+ MESSAGE( STATUS "ILMBASE INCLUDE PATH: ${ALEMBIC_ILMBASE_INCLUDE_DIRECTORY}" )
+ MESSAGE( STATUS "HALF LIB: ${ALEMBIC_ILMBASE_HALF_LIB}" )
+diff --git a/cmake/Modules/FindPyIlmBase.cmake b/cmake/Modules/FindPyIlmBase.cmake
+index d55f8d3..b5f3cb5 100644
+--- a/cmake/Modules/FindPyIlmBase.cmake
++++ b/cmake/Modules/FindPyIlmBase.cmake
+@@ -44,7 +44,7 @@ ELSE()
+               SET(ALEMBIC_PYILMBASE_ROOT NOTFOUND)
+             ELSE()
+               # TODO: set to default install path when shipping out
+-              SET(ALEMBIC_PYILMBASE_ROOT "/usr/local/pyilmbase/")
++              SET(ALEMBIC_PYILMBASE_ROOT "/usr")
+             ENDIF()
+         ELSE()
+             IF (${WINDOWS})
+-- 
+2.22.0
+
diff --git a/media-gfx/alembic/files/alembic-1.7.11-0003-Fix-env-var-for-renderman.patch b/media-gfx/alembic/files/alembic-1.7.11-0003-Fix-env-var-for-renderman.patch
new file mode 100644 (file)
index 0000000..9777bad
--- /dev/null
@@ -0,0 +1,29 @@
+From 3ca71af0e83fce89df0bfb472b28abe3c4e08c57 Mon Sep 17 00:00:00 2001
+From: Bernd Waibel <waebbl@gmail.com>
+Date: Sat, 15 Jun 2019 15:13:03 +0200
+Subject: [PATCH 3/5] Fix env var for renderman. This is called RMANTREE on
+ linux.
+
+Signed-off-by: Bernd Waibel <waebbl@gmail.com>
+---
+ cmake/AlembicPRMan.cmake | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/cmake/AlembicPRMan.cmake b/cmake/AlembicPRMan.cmake
+index e02b237..fdbf26c 100644
+--- a/cmake/AlembicPRMan.cmake
++++ b/cmake/AlembicPRMan.cmake
+@@ -66,8 +66,8 @@ ELSE()
+ ENDIF()
+ # Prefer PRMAN_ROOT set from the environment over the CMakeCache'd variable
+-IF(NOT $ENV{PRMAN_ROOT}x STREQUAL "x")
+-  SET( ALEMBIC_PRMAN_ROOT $ENV{PRMAN_ROOT})
++IF(NOT $ENV{RMANTREE}x STREQUAL "x")
++  SET( ALEMBIC_PRMAN_ROOT $ENV{RMANTREE})
+ ENDIF()
+-- 
+2.22.0
+
diff --git a/media-gfx/alembic/files/alembic-1.7.11-0004-Fix-a-compile-issue-with-const.patch b/media-gfx/alembic/files/alembic-1.7.11-0004-Fix-a-compile-issue-with-const.patch
new file mode 100644 (file)
index 0000000..73e989b
--- /dev/null
@@ -0,0 +1,27 @@
+From d1895084e41970c8f91e9357fcb739ac29c47109 Mon Sep 17 00:00:00 2001
+From: Bernd Waibel <waebbl@gmail.com>
+Date: Sat, 15 Jun 2019 16:19:30 +0200
+Subject: [PATCH 4/5] WriteGeo.cpp: Fix a compile issue, where an invalid
+ conversion from char* to const char* took place.
+
+Signed-off-by: Bernd Waibel <waebbl@gmail.com>
+---
+ prman/Procedural/WriteGeo.cpp | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/prman/Procedural/WriteGeo.cpp b/prman/Procedural/WriteGeo.cpp
+index 95b4867..5ad0b71 100644
+--- a/prman/Procedural/WriteGeo.cpp
++++ b/prman/Procedural/WriteGeo.cpp
+@@ -898,7 +898,7 @@ void ProcessCurves( ICurves &curves, ProcArgs &args )
+ void WriteIdentifier( const ObjectHeader &ohead )
+ {
+     std::string name = ohead.getFullName();
+-    char* nameArray[] = { const_cast<char*>( name.c_str() ), RI_NULL };
++    const char* nameArray[] = { const_cast<char*>( name.c_str() ), RI_NULL };
+     RiAttribute(const_cast<char*>( "identifier" ), const_cast<char*>( "name" ),
+                 nameArray, RI_NULL );
+-- 
+2.22.0
+
diff --git a/media-gfx/alembic/files/alembic-1.7.11-0005-Fix-install-locations.patch b/media-gfx/alembic/files/alembic-1.7.11-0005-Fix-install-locations.patch
new file mode 100644 (file)
index 0000000..ec3c01d
--- /dev/null
@@ -0,0 +1,218 @@
+From a867fa646d7af98fe57c9d6c96a407e648fbca24 Mon Sep 17 00:00:00 2001
+From: Bernd Waibel <waebbl@gmail.com>
+Date: Sat, 15 Jun 2019 16:39:50 +0200
+Subject: [PATCH 5/5] Fix install locations
+
+Signed-off-by: Bernd Waibel <waebbl@gmail.com>
+---
+ CMakeLists.txt                   | 8 ++++----
+ arnold/Procedural/CMakeLists.txt | 2 +-
+ bin/AbcConvert/CMakeLists.txt    | 2 +-
+ bin/AbcDiff/CMakeLists.txt       | 2 +-
+ bin/AbcEcho/CMakeLists.txt       | 2 +-
+ bin/AbcLs/CMakeLists.txt         | 2 +-
+ bin/AbcStitcher/CMakeLists.txt   | 2 +-
+ bin/AbcTree/CMakeLists.txt       | 2 +-
+ lib/Alembic/CMakeLists.txt       | 4 ++--
+ maya/AbcExport/CMakeLists.txt    | 2 +-
+ maya/AbcImport/CMakeLists.txt    | 2 +-
+ prman/Procedural/CMakeLists.txt  | 4 ++--
+ python/PyAlembic/CMakeLists.txt  | 4 ++--
+ 13 files changed, 19 insertions(+), 19 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 51a95d7..0622613 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -80,12 +80,12 @@ OPTION(ALEMBIC_LIB_USES_TR1
+ # Set static/dynamic build options
+ SET(LIB_TYPE STATIC)
+-SET(RUNTIME_INSTALL_DIR lib)
+-SET(LIBRARY_INSTALL_DIR lib)
+-SET(ARCHIVE_INSTALL_DIR lib)
++SET(RUNTIME_INSTALL_DIR lib${LIB_SUFFIX})
++SET(LIBRARY_INSTALL_DIR lib${LIB_SUFFIX})
++SET(ARCHIVE_INSTALL_DIR lib${LIB_SUFFIX})
+ IF (ALEMBIC_SHARED_LIBS)
+     SET(LIB_TYPE SHARED)
+-    SET(ARCHIVE_INSTALL_DIR lib)
++    SET(ARCHIVE_INSTALL_DIR lib${LIB_SUFFIX})
+     IF (WIN32)
+         ADD_DEFINITIONS(-DALEMBIC_DLL)
+     ENDIF()
+diff --git a/arnold/Procedural/CMakeLists.txt b/arnold/Procedural/CMakeLists.txt
+index 69e00da..027e646 100644
+--- a/arnold/Procedural/CMakeLists.txt
++++ b/arnold/Procedural/CMakeLists.txt
+@@ -60,7 +60,7 @@ TARGET_LINK_LIBRARIES( AlembicArnoldProcedural Alembic::Alembic)
+ set_target_properties(AlembicArnoldProcedural PROPERTIES
+     INSTALL_RPATH_USE_LINK_PATH TRUE
+-    INSTALL_RPATH ${CMAKE_INSTALL_PREFIX}/lib)
++    INSTALL_RPATH ${CMAKE_INSTALL_PREFIX}/lib${LIB_SUFFIX})
+ INSTALL ( TARGETS
+   AlembicArnoldProcedural
+diff --git a/bin/AbcConvert/CMakeLists.txt b/bin/AbcConvert/CMakeLists.txt
+index 451409c..5b41a14 100644
+--- a/bin/AbcConvert/CMakeLists.txt
++++ b/bin/AbcConvert/CMakeLists.txt
+@@ -38,6 +38,6 @@ TARGET_LINK_LIBRARIES(abcconvert Alembic::Alembic)
+ set_target_properties(abcconvert PROPERTIES
+     INSTALL_RPATH_USE_LINK_PATH TRUE
+-    INSTALL_RPATH ${CMAKE_INSTALL_PREFIX}/lib)
++    INSTALL_RPATH ${CMAKE_INSTALL_PREFIX}/lib${LIB_SUFFIX})
+ INSTALL(TARGETS abcconvert DESTINATION bin)
+diff --git a/bin/AbcDiff/CMakeLists.txt b/bin/AbcDiff/CMakeLists.txt
+index 511864a..c9cf482 100644
+--- a/bin/AbcDiff/CMakeLists.txt
++++ b/bin/AbcDiff/CMakeLists.txt
+@@ -38,6 +38,6 @@ TARGET_LINK_LIBRARIES(abcdiff Alembic::Alembic)
+ set_target_properties(abcdiff PROPERTIES
+     INSTALL_RPATH_USE_LINK_PATH TRUE
+-    INSTALL_RPATH ${CMAKE_INSTALL_PREFIX}/lib)
++    INSTALL_RPATH ${CMAKE_INSTALL_PREFIX}/lib${LIB_SUFFIX})
+ INSTALL(TARGETS abcdiff DESTINATION bin)
+diff --git a/bin/AbcEcho/CMakeLists.txt b/bin/AbcEcho/CMakeLists.txt
+index be5f5c1..3020041 100644
+--- a/bin/AbcEcho/CMakeLists.txt
++++ b/bin/AbcEcho/CMakeLists.txt
+@@ -41,6 +41,6 @@ TARGET_LINK_LIBRARIES(abcechobounds Alembic::Alembic)
+ set_target_properties(abcecho abcechobounds PROPERTIES
+     INSTALL_RPATH_USE_LINK_PATH TRUE
+-    INSTALL_RPATH ${CMAKE_INSTALL_PREFIX}/lib)
++    INSTALL_RPATH ${CMAKE_INSTALL_PREFIX}/lib${LIB_SUFFIX})
+ INSTALL(TARGETS abcecho abcechobounds DESTINATION bin)
+diff --git a/bin/AbcLs/CMakeLists.txt b/bin/AbcLs/CMakeLists.txt
+index 815f84f..cd216e4 100644
+--- a/bin/AbcLs/CMakeLists.txt
++++ b/bin/AbcLs/CMakeLists.txt
+@@ -39,6 +39,6 @@ TARGET_LINK_LIBRARIES(abcls Alembic::Alembic)
+ set_target_properties(abcls PROPERTIES
+     INSTALL_RPATH_USE_LINK_PATH TRUE
+-    INSTALL_RPATH ${CMAKE_INSTALL_PREFIX}/lib)
++    INSTALL_RPATH ${CMAKE_INSTALL_PREFIX}/lib${LIB_SUFFIX})
+ INSTALL(TARGETS abcls DESTINATION bin)
+diff --git a/bin/AbcStitcher/CMakeLists.txt b/bin/AbcStitcher/CMakeLists.txt
+index a963420..5882287 100644
+--- a/bin/AbcStitcher/CMakeLists.txt
++++ b/bin/AbcStitcher/CMakeLists.txt
+@@ -38,6 +38,6 @@ TARGET_LINK_LIBRARIES(abcstitcher Alembic::Alembic)
+ set_target_properties(abcstitcher PROPERTIES
+     INSTALL_RPATH_USE_LINK_PATH TRUE
+-    INSTALL_RPATH ${CMAKE_INSTALL_PREFIX}/lib)
++    INSTALL_RPATH ${CMAKE_INSTALL_PREFIX}/lib${LIB_SUFFIX})
+ INSTALL(TARGETS abcstitcher DESTINATION bin)
+diff --git a/bin/AbcTree/CMakeLists.txt b/bin/AbcTree/CMakeLists.txt
+index b4f65f1..841e1d2 100644
+--- a/bin/AbcTree/CMakeLists.txt
++++ b/bin/AbcTree/CMakeLists.txt
+@@ -38,6 +38,6 @@ TARGET_LINK_LIBRARIES(abctree Alembic::Alembic)
+ set_target_properties(abctree PROPERTIES
+     INSTALL_RPATH_USE_LINK_PATH TRUE
+-    INSTALL_RPATH ${CMAKE_INSTALL_PREFIX}/lib)
++    INSTALL_RPATH ${CMAKE_INSTALL_PREFIX}/lib${LIB_SUFFIX})
+ INSTALL(TARGETS abctree DESTINATION bin)
+diff --git a/lib/Alembic/CMakeLists.txt b/lib/Alembic/CMakeLists.txt
+index e4d33cb..e43dcce 100644
+--- a/lib/Alembic/CMakeLists.txt
++++ b/lib/Alembic/CMakeLists.txt
+@@ -85,7 +85,7 @@ IF ( ${ALEMBIC_LIB_USES_TR1} AND CMAKE_COMPILER_IS_GNUCXX AND
+     TARGET_LINK_LIBRARIES( Alembic atomic )
+ ENDIF()
+-SET( ALEMBIC_LIB_INSTALL_DIR lib CACHE PATH "Where to install the Alembic libs")
++SET( ALEMBIC_LIB_INSTALL_DIR lib${LIB_SUFFIX} CACHE PATH "Where to install the Alembic libs")
+ INSTALL(TARGETS Alembic
+         EXPORT AlembicTargets
+         LIBRARY DESTINATION ${ALEMBIC_LIB_INSTALL_DIR}
+@@ -118,7 +118,7 @@ EXPORT(TARGETS
+     Alembic::
+     )
+-SET(ConfigPackageLocation lib/cmake/Alembic CACHE PATH
++SET(ConfigPackageLocation lib${LIB_SUFFIX}/cmake/Alembic CACHE PATH
+     "Where to install the Alembic's cmake files")
+ INSTALL(FILES
+diff --git a/maya/AbcExport/CMakeLists.txt b/maya/AbcExport/CMakeLists.txt
+index 50d2fd2..b4ce46d 100644
+--- a/maya/AbcExport/CMakeLists.txt
++++ b/maya/AbcExport/CMakeLists.txt
+@@ -77,7 +77,7 @@ TARGET_LINK_LIBRARIES(AbcExport
+ set_target_properties(AbcExport PROPERTIES
+     INSTALL_RPATH_USE_LINK_PATH TRUE
+-    INSTALL_RPATH ${CMAKE_INSTALL_PREFIX}/lib)
++    INSTALL_RPATH ${CMAKE_INSTALL_PREFIX}/lib${LIB_SUFFIX})
+ INSTALL(TARGETS AbcExport
+         DESTINATION ${ALEMBIC_MAYA_PLUGINS_INSTALL_DIR})
+diff --git a/maya/AbcImport/CMakeLists.txt b/maya/AbcImport/CMakeLists.txt
+index 6826183..5a5efad 100644
+--- a/maya/AbcImport/CMakeLists.txt
++++ b/maya/AbcImport/CMakeLists.txt
+@@ -81,7 +81,7 @@ TARGET_LINK_LIBRARIES(AbcImport
+ set_target_properties(AbcImport PROPERTIES
+     INSTALL_RPATH_USE_LINK_PATH TRUE
+-    INSTALL_RPATH ${CMAKE_INSTALL_PREFIX}/lib)
++    INSTALL_RPATH ${CMAKE_INSTALL_PREFIX}/lib${LIB_SUFFIX})
+ INSTALL(TARGETS AbcImport
+         DESTINATION ${ALEMBIC_MAYA_PLUGINS_INSTALL_DIR})
+diff --git a/prman/Procedural/CMakeLists.txt b/prman/Procedural/CMakeLists.txt
+index 6b46e91..c774c2a 100644
+--- a/prman/Procedural/CMakeLists.txt
++++ b/prman/Procedural/CMakeLists.txt
+@@ -60,10 +60,10 @@ TARGET_LINK_LIBRARIES(AlembicRiProcedural Alembic::Alembic)
+ set_target_properties(AlembicRiProcedural PROPERTIES
+     INSTALL_RPATH_USE_LINK_PATH TRUE
+-    INSTALL_RPATH ${CMAKE_INSTALL_PREFIX}/lib)
++    INSTALL_RPATH ${CMAKE_INSTALL_PREFIX}/lib${LIB_SUFFIX})
+ INSTALL(TARGETS
+     AlembicRiProcedural
+     DESTINATION
+-    prman/procedurals
++    $ENV{RMANTREE}/lib/plugins
+ )
+diff --git a/python/PyAlembic/CMakeLists.txt b/python/PyAlembic/CMakeLists.txt
+index af8dcb5..90f7428 100644
+--- a/python/PyAlembic/CMakeLists.txt
++++ b/python/PyAlembic/CMakeLists.txt
+@@ -141,7 +141,7 @@ IF (Boost_PYTHON${PYTHON_VERSION_MAJOR}${PYTHON_VERSION_MINOR}_LIBRARY_RELEASE A
+     )
+     SET( ALEMBIC_PYTHON_INSTALL_DIR
+-        lib/python${PYTHON_VERSION_MAJOR}.${PYTHON_VERSION_MINOR}/site-packages
++        lib${LIB_SUFFIX}/python${PYTHON_VERSION_MAJOR}.${PYTHON_VERSION_MINOR}/site-packages
+         CACHE PATH
+         "Alembic's python bindings install directory"
+     )
+@@ -156,7 +156,7 @@ IF (Boost_PYTHON${PYTHON_VERSION_MAJOR}${PYTHON_VERSION_MINOR}_LIBRARY_RELEASE A
+     set_target_properties(PyAlembic PROPERTIES
+         INSTALL_RPATH_USE_LINK_PATH TRUE
+-        INSTALL_RPATH ${CMAKE_INSTALL_PREFIX}/lib)
++        INSTALL_RPATH ${CMAKE_INSTALL_PREFIX}/lib${LIB_SUFFIX})
+ ELSE()
+     MESSAGE(FATAL_ERROR "Unable to find Python libs")
+ ENDIF()
+-- 
+2.22.0
+