dev-python/django-sortedm2m: Bump to 2.0.0, py3.{7,8}
authorMichał Górny <mgorny@gentoo.org>
Tue, 21 Apr 2020 14:03:16 +0000 (16:03 +0200)
committerMichał Górny <mgorny@gentoo.org>
Tue, 21 Apr 2020 14:20:34 +0000 (16:20 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/django-sortedm2m/Manifest
dev-python/django-sortedm2m/django-sortedm2m-2.0.0.ebuild [new file with mode: 0644]

index d1cf6cd588542f93d8a8ad443bb6ae1389c5259e..32b1572802aab4a48621adf854f05e76e28f60d1 100644 (file)
@@ -1 +1,2 @@
 DIST django-sortedm2m-1.3.2.tar.gz 36246 BLAKE2B c794373d3555010778727146717778130b311d3c1869f0539b07980de2222d69c1ad4dd508cf35da32f4f55af0ea6cbc0d322de40454548dc59f156ae7856f4f SHA512 3695cc0a565a6e1d47e3573dce1f8c860f78c8d11d248634a8ffd6534c621e7575b2333b7a83e6c521e6e737d7ffc67ce1bbcc8504542751d3cfb254b3d98584
+DIST django-sortedm2m-2.0.0.gh.tar.gz 44491 BLAKE2B f6fb1e8678a47881a52fa8dc65bd16b97871c9a711f6dd604c3293b6f77f943f3fc797c3dcebc43db7c6982d8bae8dbfbf7ae6d7904bd17309d6bd0a833083e3 SHA512 207abbe3ca9b46a26a8a6cea278c87a72990577afeaced347aa9c020a15fd8a384491f2c027d811ee96633cdafd23e2ab841b4cc90d88119415a71cf4860bb96
diff --git a/dev-python/django-sortedm2m/django-sortedm2m-2.0.0.ebuild b/dev-python/django-sortedm2m/django-sortedm2m-2.0.0.ebuild
new file mode 100644 (file)
index 0000000..f513c33
--- /dev/null
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Drop-in replacement for django's many to many field with sorted relations"
+HOMEPAGE="https://pypi.org/project/django-sortedm2m/
+       https://github.com/jazzband/django-sortedm2m"
+SRC_URI="
+       https://github.com/jazzband/django-sortedm2m/archive/${PV}.tar.gz
+               -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-python/django[${PYTHON_USEDEP}]"
+BDEPEND="test? ( ${RDEPEND} )"
+
+python_test() {
+       local -x PYTHONPATH=test_project:${PYTHONPATH}
+       django-admin test -v 2 --settings=settings --noinput sortedm2m_tests ||
+               die "Tests fail with ${EPYTHON}"
+}