net-libs/loudmouth: use official tarballs
authorAndrey Utkin <andrey_utkin@gentoo.org>
Mon, 28 Jan 2019 01:18:25 +0000 (01:18 +0000)
committerAndrey Utkin <andrey_utkin@gentoo.org>
Thu, 31 Jan 2019 10:38:37 +0000 (10:38 +0000)
Previously, Github-generated tarballs were used.

These required extra build step known as "bootstrapping", which required
eautoreconf run, and imposed a dependency on dev-util/gtk-doc (which I
worked around earlier rather inelegantly).

At the same time, this change has a side effect of disabling -Werror in
compilation flags, which is the reason of bug 673434.

Suggested-by: Mart Raudsepp <leio@gentoo.org>
Bug: https://bugs.gentoo.org/673434
Package-Manager: Portage-2.3.49, Repoman-2.3.12
Signed-off-by: Andrey Utkin <andrey_utkin@gentoo.org>
net-libs/loudmouth/Manifest
net-libs/loudmouth/loudmouth-1.5.3-r3.ebuild

index a905effb7a579edc5efb00b11081fa8aeae736ed..31a751df9e2522f9430a8e1321abeedb758ce4e5 100644 (file)
@@ -1 +1,2 @@
+DIST loudmouth-1.5.3.tar.bz2 375974 BLAKE2B c9707fe18560104456a624a61437240a16bb6bbaf544cdf775f6d6c64fdbeb6eb8f7042eb13fcdeb36c89bb8d9522c2eba02c24987757c0f0ac8748d92a2b166 SHA512 ab6b16b4e644b69cdb7d8df1753d1bb5b43c2f1e76944e639339169b332e1b5c6a4246053c5b8a579ee9b53c845cef610b0040dfdffeb857180b6bab71adfcce
 DIST loudmouth-1.5.3.tar.gz 114676 BLAKE2B 7a73e4e65046608fc8ec571b5448ab8344a8aed554fee1ecf7badd2ca5ed382ddb27e6ba7bd5d0a76d978d3079415b307f1b4ca77da450003ae936191cdbd33e SHA512 afae8b4ad1e9e5558cffa8f6b9f25331b01cfa09ea0b3defb74cac7d39477744e6d9181d3adefe242038020759df43558de0e61305fbc8e12a3b293b82856bf7
index f4cbccad2df53d83f18b444b1f8183bffaec45a3..f10f3698262f845b963e40f2b33bf3df533c6853 100644 (file)
@@ -2,11 +2,10 @@
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
-inherit autotools
 
 DESCRIPTION="Lightweight C Jabber library"
-HOMEPAGE="https://github.com/mcabber/loudmouth"
-SRC_URI="https://github.com/mcabber/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+HOMEPAGE="https://mcabber.com"
+SRC_URI="https://mcabber.com/files/${PN}/${P}.tar.bz2"
 
 LICENSE="LGPL-2.1"
 SLOT="0"
@@ -26,20 +25,15 @@ RDEPEND="
 "
 DEPEND="${RDEPEND}
        dev-util/glib-utils
+       dev-util/gtk-doc-am
        test? ( dev-libs/check )
        virtual/pkgconfig
 "
 
 PATCHES=(
        "${FILESDIR}"/${P}-gcc7.patch
-       "${FILESDIR}"/${P}-skip-gtk-doc.patch
 )
 
-src_prepare() {
-       default
-       eautoreconf
-}
-
 src_configure() {
        local myconf