Bug 165482...more to come
authorMartin Jackson <mjolnir@gentoo.org>
Sun, 11 Feb 2007 22:49:42 +0000 (22:49 +0000)
committerMartin Jackson <mjolnir@gentoo.org>
Sun, 11 Feb 2007 22:49:42 +0000 (22:49 +0000)
Package-Manager: portage-2.1.2-r9

dev-db/postgresql/files/digest-postgresql-7.3.18 [new file with mode: 0644]
dev-db/postgresql/files/postgresql-7.3.18-cubeparse.patch [new file with mode: 0644]
dev-db/postgresql/files/postgresql-7.3.18-gentoo.patch [new file with mode: 0644]
dev-db/postgresql/postgresql-7.3.18.ebuild [new file with mode: 0644]

diff --git a/dev-db/postgresql/files/digest-postgresql-7.3.18 b/dev-db/postgresql/files/digest-postgresql-7.3.18
new file mode 100644 (file)
index 0000000..73a8e3f
--- /dev/null
@@ -0,0 +1,12 @@
+MD5 e9205d6835933401db4c5991504f264b postgresql-base-7.3.18.tar.bz2 5695073
+RMD160 62607d50fbf97ae0b954943e2e27052bcf2c5aa0 postgresql-base-7.3.18.tar.bz2 5695073
+SHA256 648c7bddcab5477c5d7800795f8392a3ecdd361828c4374d9804bfa61a07b048 postgresql-base-7.3.18.tar.bz2 5695073
+MD5 621d4499418469248db2318b85a89c19 postgresql-docs-7.3.18.tar.bz2 2363625
+RMD160 5c95e654b7029f1d6289987ad0a08266ab6e54fa postgresql-docs-7.3.18.tar.bz2 2363625
+SHA256 24f509b444dc1a9009ffdb6a8e484f038762b971cea60fb9bdc8943fd6a0fa55 postgresql-docs-7.3.18.tar.bz2 2363625
+MD5 02c53c28a92b7bfc229c71c4b18dee49 postgresql-opt-7.3.18.tar.bz2 342315
+RMD160 fa7cb704ff7bb131f6108217c645821413ecd5b8 postgresql-opt-7.3.18.tar.bz2 342315
+SHA256 6d422a3d4d56192952c035d01aff59b90c7ab7b3cdb7f300572e40dd20db5e4b postgresql-opt-7.3.18.tar.bz2 342315
+MD5 256553aa18822775c63924c787ded200 postgresql-test-7.3.18.tar.bz2 891032
+RMD160 f18fa7025a37bf85936ba78f5cdbb4e26e0a9bfb postgresql-test-7.3.18.tar.bz2 891032
+SHA256 61bf71f0b09fa0a0dc667f636fe7a338f33d7b337159b16820a0a6240318a48e postgresql-test-7.3.18.tar.bz2 891032
diff --git a/dev-db/postgresql/files/postgresql-7.3.18-cubeparse.patch b/dev-db/postgresql/files/postgresql-7.3.18-cubeparse.patch
new file mode 100644 (file)
index 0000000..705e073
--- /dev/null
@@ -0,0 +1,36 @@
+--- contrib/cube/cubescan.l.orig       2006-07-05 06:56:04.000000000 +0000
++++ contrib/cube/cubescan.l    2006-07-05 06:56:12.000000000 +0000
+@@ -9,6 +9,10 @@
+ /* flex screws a couple symbols when used with the -P option; fix those */
++#ifndef YY_PROTO
++#define YY_PROTO(proto) proto
++#endif
++
+ #define YY_DECL int cube_yylex YY_PROTO(( void )); \
+ int cube_yylex YY_PROTO(( void ))
+ #define yylval cube_yylval
+--- contrib/seg/segscan.l.orig 2006-07-05 07:08:26.000000000 +0000
++++ contrib/seg/segscan.l      2006-07-05 07:08:51.000000000 +0000
+@@ -9,6 +9,10 @@
+ /* flex screws a couple symbols when used with the -P option; fix those */
++#ifndef YY_PROTO
++#define YY_PROTO(proto) proto
++#endif
++
+ #define YY_DECL int seg_yylex YY_PROTO(( void )); \
+ int seg_yylex YY_PROTO(( void ))
+ #define yylval seg_yylval
+--- contrib/tsearch/parser.l.orig      2006-07-05 07:22:36.000000000 +0000
++++ contrib/tsearch/parser.l   2006-07-05 07:23:33.000000000 +0000
+@@ -18,6 +18,7 @@
+ char *s     = NULL;  /* to return WHOLE hyphenated-word */
+ YY_BUFFER_STATE buf = NULL; /* buffer to parse; it need for parse from string */
++static YY_BUFFER_STATE yy_current_buffer = 0;
+ int lrlimit = -1;     /* for limiting read from filehandle ( -1 - unlimited read ) */
+ int bytestoread = 0;  /* for limiting read from filehandle */
diff --git a/dev-db/postgresql/files/postgresql-7.3.18-gentoo.patch b/dev-db/postgresql/files/postgresql-7.3.18-gentoo.patch
new file mode 100644 (file)
index 0000000..079f7c6
--- /dev/null
@@ -0,0 +1,63 @@
+diff -Nru postgresql-7.3.16.orig/configure postgresql-7.3.16/configure
+--- postgresql-7.3.16.orig/configure   2006-11-05 13:20:08.000000000 +0100
++++ postgresql-7.3.16/configure        2006-11-05 14:10:03.000000000 +0100
+@@ -5871,7 +5871,7 @@
+   echo $ECHO_N "(cached) $ECHO_C" >&6
+ else
+   pgac_cv_check_readline=no
+-for pgac_lib in "" " -ltermcap" " -lncurses" " -lcurses" ; do
++for pgac_lib in "" " -lncurses" " -lcurses" ; do
+   for pgac_rllib in -lreadline -ledit ; do
+     pgac_save_LIBS=$LIBS
+     LIBS="${pgac_rllib}${pgac_lib} $LIBS"
+diff -Nru postgresql-7.3.16.orig/src/bin/Makefile postgresql-7.3.16/src/bin/Makefile
+--- postgresql-7.3.16.orig/src/bin/Makefile    2006-11-05 13:20:09.000000000 +0100
++++ postgresql-7.3.16/src/bin/Makefile 2006-11-05 15:46:42.000000000 +0100
+@@ -14,7 +14,7 @@
+ include $(top_builddir)/src/Makefile.global
+ DIRS := initdb initlocation ipcclean pg_ctl pg_dump pg_id \
+-      psql scripts pg_config pg_controldata pg_resetxlog \
++      psql scripts pg_controldata pg_resetxlog \
+       pg_encoding
+ ifeq ($(with_tcl), yes)
+diff -Nru postgresql-7.3.16.orig/src/interfaces/Makefile postgresql-7.3.16/src/interfaces/Makefile
+--- postgresql-7.3.16.orig/src/interfaces/Makefile     2006-11-05 13:20:09.000000000 +0100
++++ postgresql-7.3.16/src/interfaces/Makefile  2006-11-05 14:10:03.000000000 +0100
+@@ -12,7 +12,7 @@
+ top_builddir = ../..
+ include $(top_builddir)/src/Makefile.global
+-DIRS := libpq ecpg 
++DIRS := ecpg 
+ ALLDIRS := $(DIRS) libpgtcl python jdbc
+diff -Nru postgresql-7.3.16.orig/src/Makefile postgresql-7.3.16/src/Makefile
+--- postgresql-7.3.16.orig/src/Makefile        2006-11-05 13:20:09.000000000 +0100
++++ postgresql-7.3.16/src/Makefile     2006-11-05 14:10:03.000000000 +0100
+@@ -17,7 +17,6 @@
+       $(MAKE) -C port $@
+       $(MAKE) -C backend $@
+       $(MAKE) -C backend/utils/mb/conversion_procs $@
+-      $(MAKE) -C include $@
+       $(MAKE) -C interfaces $@
+       $(MAKE) -C bin $@
+       $(MAKE) -C pl $@
+@@ -28,7 +27,6 @@
+ clean:
+       $(MAKE) -C port $@
+       $(MAKE) -C backend $@
+-      $(MAKE) -C include $@
+       $(MAKE) -C interfaces $@
+       $(MAKE) -C bin $@
+       $(MAKE) -C pl $@
+@@ -39,7 +37,6 @@
+ distclean maintainer-clean:
+       -$(MAKE) -C port $@
+       -$(MAKE) -C backend $@
+-      -$(MAKE) -C include $@
+       -$(MAKE) -C interfaces $@
+       -$(MAKE) -C bin $@
+       -$(MAKE) -C pl $@
diff --git a/dev-db/postgresql/postgresql-7.3.18.ebuild b/dev-db/postgresql/postgresql-7.3.18.ebuild
new file mode 100644 (file)
index 0000000..9cbe94c
--- /dev/null
@@ -0,0 +1,242 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/postgresql-7.3.18.ebuild,v 1.1 2007/02/11 22:49:42 mjolnir Exp $
+
+inherit eutils gnuconfig flag-o-matic multilib toolchain-funcs versionator
+
+KEYWORDS="alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+
+DESCRIPTION="Sophisticated and powerful Object-Relational DBMS."
+HOMEPAGE="http://www.postgresql.org/"
+SRC_URI="mirror://postgresql/source/v${PV}/${PN}-base-${PV}.tar.bz2
+               mirror://postgresql/source/v${PV}/${PN}-opt-${PV}.tar.bz2
+               doc? ( mirror://postgresql/source/v${PV}/${PN}-docs-${PV}.tar.bz2 )
+               test? ( mirror://postgresql/source/v${PV}/${PN}-test-${PV}.tar.bz2 )"
+LICENSE="POSTGRESQL"
+SLOT="0"
+IUSE="doc kerberos nls pam perl pg-intdatetime python readline selinux ssl tcl test xml zlib"
+
+RDEPEND="~dev-db/libpq-${PV}
+               >=sys-libs/ncurses-5.2
+               kerberos? ( virtual/krb5 )
+               pam? ( virtual/pam )
+               perl? ( >=dev-lang/perl-5.6.1-r2 )
+               python? ( >=dev-lang/python-2.2 dev-python/egenix-mx-base )
+               readline? ( >=sys-libs/readline-4.1 )
+               selinux? ( sec-policy/selinux-postgresql )
+               ssl? ( >=dev-libs/openssl-0.9.6-r1 )
+               tcl? ( >=dev-lang/tcl-8 )
+               xml? ( dev-libs/libxml2 dev-libs/libxslt )
+               zlib? ( >=sys-libs/zlib-1.1.3 )"
+DEPEND="${RDEPEND}
+               sys-devel/autoconf
+               >=sys-devel/bison-1.875
+               nls? ( sys-devel/gettext )
+               xml? ( dev-util/pkgconfig )"
+
+PG_DIR="/var/lib/postgresql"
+[[ -z "${PG_MAX_CONNECTIONS}" ]] && PG_MAX_CONNECTIONS="512"
+
+pkg_setup() {
+       if [[ -f "${PG_DIR}/data/PG_VERSION" ]] ; then
+               if [[ $(cat "${PG_DIR}/data/PG_VERSION") != $(get_version_component_range 1-2) ]] ; then
+                       eerror "PostgreSQL ${PV} cannot upgrade your existing databases, you must"
+                       eerror "use pg_dump to export your existing databases to a file, and then"
+                       eerror "pg_restore to import them when you have upgraded completely."
+                       eerror "You must remove your entire database directory to continue."
+                       eerror "(database directory = ${PG_DIR})."
+                       die "Remove your database directory to continue"
+               fi
+       fi
+       enewgroup postgres 70
+       enewuser postgres 70 /bin/bash /var/lib postgres
+}
+
+src_unpack() {
+       unpack ${A}
+       cd "${S}"
+
+       epatch "${FILESDIR}/${PN}-${PV}-gentoo.patch"
+       epatch "${FILESDIR}/${PN}-${PV}-cubeparse.patch"
+
+       # Prepare package for future tests
+       if use test ; then
+               # We need to run the tests as a non-root user, portage seems the most fitting here,
+               # so if userpriv is enabled, we use it directly. If userpriv is disabled, well, we
+               # don't support that in this version of PostgreSQL ... :)
+               mkdir -p "${S}/src/test/regress/tmp_check"
+               chown portage "${S}/src/test/regress/tmp_check"
+               einfo "Tests will be run as user portage."
+       fi
+}
+
+src_compile() {
+       filter-flags -ffast-math -feliminate-dwarf2-dups
+
+       # Correctly support the XML stuff
+       if use xml ; then
+               CFLAGS="${CFLAGS} $(pkg-config --cflags libxml-2.0)"
+               LIBS="${LIBS} $(pkg-config --libs libxml-2.0)"
+       fi
+
+       # Detect mips systems properly
+       gnuconfig_update
+
+       cd "${S}"
+
+       ./configure --prefix=/usr \
+               --includedir=/usr/include/postgresql/pgsql \
+               --sysconfdir=/etc/postgresql \
+               --mandir=/usr/share/man \
+               --host=${CHOST} \
+               --docdir=/usr/share/doc/${PF} \
+               --libdir=/usr/$(get_libdir) \
+               --enable-depend \
+               $(use_with kerberos krb5) \
+               $(use_enable nls ) \
+               $(use_with pam) \
+               $(use_with perl) \
+               $(use_enable pg-intdatetime integer-datetimes ) \
+               $(use_with python) \
+               $(use_with readline) \
+               $(use_with ssl openssl) \
+               $(use_with tcl) \
+               --without-tk \
+               $(use_with zlib) \
+               || die "configure failed"
+
+       emake -j1 LD="$(tc-getLD) $(get_abi_LDFLAGS)" || die "main emake failed"
+
+       cd "${S}/contrib"
+       emake -j1 LD="$(tc-getLD) $(get_abi_LDFLAGS)" || die "contrib emake failed"
+
+       if use xml ; then
+               cd "${S}/contrib/xml"
+               emake -j1 LD="$(tc-getLD) $(get_abi_LDFLAGS)" || die "contrib/xml emake failed"
+       fi
+}
+
+src_install() {
+       if use perl ; then
+               mv -f "${S}/src/pl/plperl/GNUmakefile" "${S}/src/pl/plperl/GNUmakefile_orig"
+               sed -e "s:\$(DESTDIR)\$(plperl_installdir):\$(plperl_installdir):" \
+                       "${S}/src/pl/plperl/GNUmakefile_orig" > "${S}/src/pl/plperl/GNUmakefile"
+       fi
+
+       cd "${S}"
+       emake -j1 DESTDIR="${D}" LIBDIR="${D}/usr/$(get_libdir)" install || die "main emake install failed"
+
+       cd "${S}/contrib"
+       emake -j1 DESTDIR="${D}" LIBDIR="${D}/usr/$(get_libdir)" install || die "contrib emake install failed"
+
+       if use xml ; then
+               cd "${S}/contrib/xml"
+               emake -j1 DESTDIR="${D}" LIBDIR="${D}/usr/$(get_libdir)" install || die "contrib/xml emake install failed"
+       fi
+
+       cd "${S}"
+       dodoc README HISTORY
+       dodoc contrib/adddepend/*
+
+       cd "${S}/doc"
+       dodoc FAQ* README.* TODO bug.template
+
+       if use doc ; then
+               cd "${S}/doc"
+               docinto FAQ_html
+               dodoc src/FAQ/*
+               docinto sgml
+               dodoc src/sgml/*.{sgml,dsl}
+               docinto sgml/ref
+               dodoc src/sgml/ref/*.sgml
+               docinto TODO.detail
+               dodoc TODO.detail/*
+       fi
+
+       newinitd "${FILESDIR}/postgresql.init-${PV%.*}" postgresql || die "Inserting init.d-file failed"
+       newconfd "${FILESDIR}/postgresql.conf-${PV%.*}" postgresql || die "Inserting conf.d-file failed"
+}
+
+pkg_postinst() {
+       elog "Execute the following command to setup the initial database environment:"
+       elog
+       elog "emerge --config =${PF}"
+       elog
+       elog "If you need a global psqlrc-file, you can place it in '${ROOT}/etc/postgresql/'."
+}
+
+pkg_config() {
+       einfo "Creating the data directory ..."
+       mkdir -p "${PG_DIR}/data"
+       chown -Rf postgres:postgres "${PG_DIR}"
+       chmod 0700 "${PG_DIR}/data"
+
+       einfo "Initializing the database ..."
+       if [[ -f "${PG_DIR}/data/PG_VERSION" ]] ; then
+               eerror "PostgreSQL ${PV} cannot upgrade your existing databases."
+               eerror "You must remove your entire database directory to continue."
+               eerror "(database directory = ${PG_DIR})."
+               die "Remove your database directory to continue"
+       else
+               if use kernel_linux ; then
+                       local SEM=`sysctl -n kernel.sem | cut -f-3`
+                       local SEMMNI=`sysctl -n kernel.sem | cut -f4`
+                       local SEMMNI_MIN=`expr \( ${PG_MAX_CONNECTIONS} + 15 \) / 16`
+                       local SHMMAX=`sysctl -n kernel.shmmax`
+                       local SHMMAX_MIN=`expr 500000 + 30600 \* ${PG_MAX_CONNECTIONS}`
+
+                       if [ ${SEMMNI} -lt ${SEMMNI_MIN} ] ; then
+                               eerror "The current value of SEMMNI is too low"
+                               eerror "for PostgreSQL to run ${PG_MAX_CONNECTIONS} connections!"
+                               eerror "Temporary setting this value to ${SEMMNI_MIN} while creating the initial database."
+                               echo ${SEM} ${SEMMNI_MIN} > /proc/sys/kernel/sem
+                       fi
+
+                       su postgres -c "/usr/bin/initdb --pgdata ${PG_DIR}/data"
+
+                       if [ ! `sysctl -n kernel.sem | cut -f4` -eq ${SEMMNI} ] ; then
+                               echo ${SEM} ${SEMMNI} > /proc/sys/kernel/sem
+                               ewarn "Restoring the SEMMNI value to the previous value."
+                               ewarn "Please edit the last value of kernel.sem in /etc/sysctl.conf"
+                               ewarn "and set it to at least ${SEMMNI_MIN}:"
+                               ewarn
+                               ewarn "  kernel.sem = ${SEM} ${SEMMNI_MIN}"
+                               ewarn
+                       fi
+
+                       if [ ${SHMMAX} -lt ${SHMMAX_MIN} ] ; then
+                               eerror "The current value of SHMMAX is too low for postgresql to run."
+                               eerror "Please edit /etc/sysctl.conf and set this value to at least ${SHMMAX_MIN}:"
+                               eerror
+                               eerror "  kernel.shmmax = ${SHMMAX_MIN}"
+                               eerror
+                       fi
+               else
+                       su postgres -c "/usr/bin/initdb --pgdata ${PG_DIR}/data"
+               fi
+
+               einfo
+               einfo "You can use the '${ROOT}/etc/init.d/postgresql' script to run PostgreSQL instead of 'pg_ctl'."
+               einfo
+       fi
+}
+
+src_test() {
+       cd "${S}"
+
+       einfo ">>> Test phase [check]: ${CATEGORY}/${PF}"
+       if hasq userpriv ${FEATURES} ; then
+               if ! emake -j1 check ; then
+                       hasq test ${FEATURES} && die "Make check failed. See above for details."
+                       hasq test ${FEATURES} || eerror "Make check failed. See above for details."
+               fi
+       else
+               eerror "Tests won't be run if FEATURES=userpriv is disabled!"
+       fi
+
+       einfo "Yes, there are other tests which could be run."
+       einfo "... and no, we don't plan to add/support them."
+       einfo "For now, the main regressions tests will suffice."
+       einfo "If you think other tests are necessary, please submit a"
+       einfo "bug including a patch for this ebuild to enable them."
+}