app-emulation/qemu: tweak python dependency when USE=-python
authorMike Gilbert <floppym@gentoo.org>
Tue, 9 Jul 2019 16:06:05 +0000 (12:06 -0400)
committerMatthias Maier <tamiko@gentoo.org>
Tue, 9 Jul 2019 16:12:17 +0000 (11:12 -0500)
When USE=python is disabled, we still need a python interpreter at build time
with no extra USE dependencies.

Closes: https://github.com/gentoo/gentoo/pull/12408/
Package-Manager: Portage-2.3.68, Repoman-2.3.16_p2
Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Signed-off-by: Matthias Maier <tamiko@gentoo.org>
app-emulation/qemu/qemu-4.0.0-r3.ebuild
app-emulation/qemu/qemu-9999.ebuild

index bd09a33e9d4685d2475ec83ced3c5d1ca9ddae71..49fcec6ba3fe03807016dcc2e0f1b2b221e5d9dd 100644 (file)
@@ -169,7 +169,7 @@ PPC64_FIRMWARE_DEPEND="
 "
 
 BDEPEND="
-       ${PYTHON_DEPS}
+       $(python_gen_impl_dep)
        dev-lang/perl
        sys-apps/texinfo
        virtual/pkgconfig
@@ -190,7 +190,6 @@ CDEPEND="
        qemu_softmmu_targets_ppc64? ( ${PPC64_FIRMWARE_DEPEND} )
 "
 DEPEND="${CDEPEND}
-       ${PYTHON_DEPS}
        kernel_linux? ( >=sys-kernel/linux-headers-2.6.35 )
        static? (
                ${ALL_DEPEND}
index 60bf2213431b5a33477578e7e9c051303981efdd..8d1410fd8d2de563d62a2ead79edfdc2ac1e4d29 100644 (file)
@@ -169,7 +169,7 @@ PPC64_FIRMWARE_DEPEND="
 "
 
 BDEPEND="
-       ${PYTHON_DEPS}
+       $(python_gen_impl_dep)
        dev-lang/perl
        sys-apps/texinfo
        virtual/pkgconfig
@@ -190,7 +190,6 @@ CDEPEND="
        qemu_softmmu_targets_ppc64? ( ${PPC64_FIRMWARE_DEPEND} )
 "
 DEPEND="${CDEPEND}
-       ${PYTHON_DEPS}
        kernel_linux? ( >=sys-kernel/linux-headers-2.6.35 )
        static? (
                ${ALL_DEPEND}