dev-python/numexpr: Drop old
authorJustin Lecher <jlec@gentoo.org>
Sat, 25 Feb 2017 20:09:41 +0000 (20:09 +0000)
committerJustin Lecher <jlec@gentoo.org>
Sat, 25 Feb 2017 20:42:16 +0000 (20:42 +0000)
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Signed-off-by: Justin Lecher <jlec@gentoo.org>
dev-python/numexpr/Manifest
dev-python/numexpr/files/numexpr-2.4.3-testfix.patch [deleted file]
dev-python/numexpr/numexpr-2.4.3.ebuild [deleted file]
dev-python/numexpr/numexpr-2.4.4.ebuild [deleted file]
dev-python/numexpr/numexpr-2.4.6.ebuild [deleted file]
dev-python/numexpr/numexpr-2.5.ebuild [deleted file]

index 87f2ee2ba2c26761b32c4ddea98c805aeed17ae8..183b02c5feb8d6ecd5bb2efe9ce366c96750819f 100644 (file)
@@ -1,5 +1 @@
-DIST numexpr-2.4.3.tar.gz 85171 SHA256 3ae7191c89df40db6b0a8637a4dace7c5956bc910793a53225f985f3b443c722 SHA512 b33984072fddd4303980be8533e1348b48ff27de5e150029147e3666ce6bb9e1147dbc45eb0ef22506aebaea6fb366d65ff01221235f9b9935d78ea70ba9aa53 WHIRLPOOL ac5981bac643b825d6ab2fbd6c46b6d73ad62374490e5f05a71fc0b9c4269ab401617da98079e1604b11f454863e64e009a2acc00b7b30499b20eff73efe033f
-DIST numexpr-2.4.4.tar.gz 87133 SHA256 dfa2fad1af040e93a8022fbe4437f2183bf80e5f64d466381ad589308a73565b SHA512 abc53f8aafb39e55b6b811c1f08c01eefca23c36fb9d20a82484ef658c8062ffe51d8841d6651f43fb7f8cea6420270623df6ba9f98a95a0f7a09e6ceef91b35 WHIRLPOOL 9ab19609189e866a11c03b0aeaa3b93124d8018d53e8dec641721eff39eb73c969c34c457209d63988361ffadef13a205ba5b71d19ad120e9f44313f42c7cd1b
-DIST numexpr-2.4.6.tar.gz 87481 SHA256 052397670dc56d7845ff894cd7d858e4f115491ecd93bcc0eda5cb83990c5da3 SHA512 fb68e0e782fd9e9e3cef9288addc0dfc3b79dbf01f0e72422cda6d5effd0f1629a49f9e5b89dcd16fa904423e0e9c776f3f276b4817e83cc58029c90a8627096 WHIRLPOOL 485eb98636f1ee5e1efbc843b404a23f3495d1b6682de15b67275a9c4082c87a1550d1bb91a19a7942f10f2f137af4a6294aaed95d7fd746f2db45d7319b70ec
-DIST numexpr-2.5.tar.gz 88347 SHA256 319cdf4e402177a1c8ed4972cffd09f523446f186d347b7c1974787cdabf0294 SHA512 32cc70a9dd8cec67d014056c98e798bdaef6338365366ebebd60fa5655dda2cdcb5df550c8afe87aa85e0c87ebada6ae695d125d8b605f32c368bde731ff2a6c WHIRLPOOL a48a887b324d9a904083621024fcdd6c5fcaa60577c9d76bf88bb370d844b75c409851e9f4a28aefce2a5a3f0420329c67f3d68e825c2525db1dd6aea2340bb1
 DIST numexpr-2.6.1.tar.gz 90819 SHA256 db2ee72f277b23c82d204189290ea4b792f9bd5b9d67744b045f8c2a8e929a06 SHA512 07c88b1788ecad2c59260e7a6a15dfc21d486462a8866091d157286e5ce3b5b77f5fdab401fd30e2a5e4880398af53641d557003497c7d3658421bfcff38c31c WHIRLPOOL ef77ff356f79d2171685aa1267a63dfbd89a120300dd970bb9768df611a734483e21f78d4b1b09c4f3a5943cbbb6e9b48f03191bd7738063df076c07b6663a49
diff --git a/dev-python/numexpr/files/numexpr-2.4.3-testfix.patch b/dev-python/numexpr/files/numexpr-2.4.3-testfix.patch
deleted file mode 100644 (file)
index 3104ddc..0000000
+++ /dev/null
@@ -1,34 +0,0 @@
-https://github.com/avalentino/numexpr/commit/0c2ef2ed05185211d2dd90a193c26f1805c30ad4
-diff --git a/numexpr/tests/test_numexpr.py b/numexpr/tests/test_numexpr.py
-index 44761c3..e7e109f 100644
---- a/numexpr/tests/test_numexpr.py
-+++ b/numexpr/tests/test_numexpr.py
-@@ -721,19 +721,19 @@ def test_add_string_array(self):
-         self.assert_missing_op('add_sss', expr, locals())
-     def test_empty_string1(self):
--        a = np.array(["", "pepe"])
--        b = np.array(["pepe2", ""])
--        res = evaluate("(a == '') & (b == 'pepe2')")
-+        a = np.array([b"", b"pepe"])
-+        b = np.array([b"pepe2", b""])
-+        res = evaluate("(a == b'') & (b == b'pepe2')")
-         assert_array_equal(res, np.array([True, False]))
--        res2 = evaluate("(a == 'pepe') & (b == '')")
-+        res2 = evaluate("(a == b'pepe') & (b == b'')")
-         assert_array_equal(res2, np.array([False, True]))
-     def test_empty_string2(self):
--        a = np.array(["p", "pepe"])
--        b = np.array(["pepe2", ""])
--        res = evaluate("(a == '') & (b == 'pepe2')")
-+        a = np.array([b"p", b"pepe"])
-+        b = np.array([b"pepe2", b""])
-+        res = evaluate("(a == b'') & (b == b'pepe2')")
-         assert_array_equal(res, np.array([False, False]))
--        res2 = evaluate("(a == 'pepe') & (b == '')")
-+        res2 = evaluate("(a == b'pepe') & (b == b'')")
-         assert_array_equal(res, np.array([False, False]))
-     def test_add_numeric_array(self):
-
diff --git a/dev-python/numexpr/numexpr-2.4.3.ebuild b/dev-python/numexpr/numexpr-2.4.3.ebuild
deleted file mode 100644 (file)
index a69f392..0000000
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_4} )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="Fast numerical array expression evaluator for Python and NumPy"
-HOMEPAGE="https://github.com/pydata/numexpr"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
-IUSE="mkl"
-
-RDEPEND="
-       >=dev-python/numpy-1.6[${PYTHON_USEDEP}]
-       mkl? ( sci-libs/mkl )"
-DEPEND="${RDEPEND}
-       dev-python/setuptools[${PYTHON_USEDEP}]"
-
-PATCHES=( "${FILESDIR}"/${P}-testfix.patch )
-
-python_prepare_all() {
-       # TODO: mkl can be used but it fails for me
-       # only works with mkl in tree. newer mkl will use pkgconfig
-       if use mkl; then
-               local ext
-               use amd64 && ext=_lp64
-               cat <<- EOF > "${S}"/site.cfg
-               [mkl]
-               library_dirs = ${MKLROOT}/lib/em64t
-               include_dirs = ${MKLROOT}/include
-               mkl_libs = mkl_solver${ext}, mkl_intel${ext}, \
-               mkl_intel_thread, mkl_core, iomp5
-               EOF
-       fi
-       distutils-r1_python_prepare_all
-}
-
-python_compile() {
-       python_is_python3 || local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
-       distutils-r1_python_compile
-}
-
-python_test() {
-       pushd "${BUILD_DIR}"/lib > /dev/null
-       "${PYTHON}" -c "import numexpr; numexpr.test()" || die
-       pushd > /dev/null
-}
diff --git a/dev-python/numexpr/numexpr-2.4.4.ebuild b/dev-python/numexpr/numexpr-2.4.4.ebuild
deleted file mode 100644 (file)
index a524594..0000000
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_{4,5} )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="Fast numerical array expression evaluator for Python and NumPy"
-HOMEPAGE="https://github.com/pydata/numexpr"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="mkl"
-
-RDEPEND="
-       >=dev-python/numpy-1.6[${PYTHON_USEDEP}]
-       mkl? ( sci-libs/mkl )"
-DEPEND="${RDEPEND}
-       dev-python/setuptools[${PYTHON_USEDEP}]"
-
-python_prepare_all() {
-       # TODO: mkl can be used but it fails for me
-       # only works with mkl in tree. newer mkl will use pkgconfig
-       if use mkl; then
-               local ext
-               use amd64 && ext=_lp64
-               cat <<- EOF > "${S}"/site.cfg
-               [mkl]
-               library_dirs = ${MKLROOT}/lib/em64t
-               include_dirs = ${MKLROOT}/include
-               mkl_libs = mkl_solver${ext}, mkl_intel${ext}, \
-               mkl_intel_thread, mkl_core, iomp5
-               EOF
-       fi
-       distutils-r1_python_prepare_all
-}
-
-python_compile() {
-       python_is_python3 || local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
-       distutils-r1_python_compile
-}
-
-python_test() {
-       pushd "${BUILD_DIR}"/lib > /dev/null
-       "${PYTHON}" -c "import numexpr; numexpr.test()" || die
-       pushd > /dev/null
-}
diff --git a/dev-python/numexpr/numexpr-2.4.6.ebuild b/dev-python/numexpr/numexpr-2.4.6.ebuild
deleted file mode 100644 (file)
index a524594..0000000
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_{4,5} )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="Fast numerical array expression evaluator for Python and NumPy"
-HOMEPAGE="https://github.com/pydata/numexpr"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="mkl"
-
-RDEPEND="
-       >=dev-python/numpy-1.6[${PYTHON_USEDEP}]
-       mkl? ( sci-libs/mkl )"
-DEPEND="${RDEPEND}
-       dev-python/setuptools[${PYTHON_USEDEP}]"
-
-python_prepare_all() {
-       # TODO: mkl can be used but it fails for me
-       # only works with mkl in tree. newer mkl will use pkgconfig
-       if use mkl; then
-               local ext
-               use amd64 && ext=_lp64
-               cat <<- EOF > "${S}"/site.cfg
-               [mkl]
-               library_dirs = ${MKLROOT}/lib/em64t
-               include_dirs = ${MKLROOT}/include
-               mkl_libs = mkl_solver${ext}, mkl_intel${ext}, \
-               mkl_intel_thread, mkl_core, iomp5
-               EOF
-       fi
-       distutils-r1_python_prepare_all
-}
-
-python_compile() {
-       python_is_python3 || local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
-       distutils-r1_python_compile
-}
-
-python_test() {
-       pushd "${BUILD_DIR}"/lib > /dev/null
-       "${PYTHON}" -c "import numexpr; numexpr.test()" || die
-       pushd > /dev/null
-}
diff --git a/dev-python/numexpr/numexpr-2.5.ebuild b/dev-python/numexpr/numexpr-2.5.ebuild
deleted file mode 100644 (file)
index a1cb990..0000000
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5} )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="Fast numerical array expression evaluator for Python and NumPy"
-HOMEPAGE="https://github.com/pydata/numexpr"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="mkl"
-
-RDEPEND="
-       >=dev-python/numpy-1.6[${PYTHON_USEDEP}]
-       mkl? ( sci-libs/mkl )"
-DEPEND="${RDEPEND}
-       dev-python/setuptools[${PYTHON_USEDEP}]"
-
-python_prepare_all() {
-       # TODO: mkl can be used but it fails for me
-       # only works with mkl in tree. newer mkl will use pkgconfig
-       if use mkl; then
-               local ext
-               use amd64 && ext=_lp64
-               cat <<- EOF > "${S}"/site.cfg
-               [mkl]
-               library_dirs = ${MKLROOT}/lib/em64t
-               include_dirs = ${MKLROOT}/include
-               mkl_libs = mkl_solver${ext}, mkl_intel${ext}, \
-               mkl_intel_thread, mkl_core, iomp5
-               EOF
-       fi
-       distutils-r1_python_prepare_all
-}
-
-python_compile() {
-       python_is_python3 || local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
-       distutils-r1_python_compile
-}
-
-python_test() {
-       pushd "${BUILD_DIR}"/lib > /dev/null
-       "${PYTHON}" \
-               -c "import sys;import numexpr;sys.exit(0 if numexpr.test() else 1)" \
-               || die
-       pushd > /dev/null
-}