dev-python/txrequests: rev-bump, add python 3.{4,5,6}
authorBrian Dolbec <dolsen@gentoo.org>
Wed, 5 Apr 2017 00:25:30 +0000 (17:25 -0700)
committerBrian Dolbec <dolsen@gentoo.org>
Tue, 16 May 2017 02:07:07 +0000 (19:07 -0700)
Reduce the twisted dep to only the new single pkg.

Package-Manager: Portage-2.3.5, Repoman-2.3.2_p30

dev-python/txrequests/txrequests-0.9.5-r1.ebuild [new file with mode: 0644]

diff --git a/dev-python/txrequests/txrequests-0.9.5-r1.ebuild b/dev-python/txrequests/txrequests-0.9.5-r1.ebuild
new file mode 100644 (file)
index 0000000..6fe8cba
--- /dev/null
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6})
+
+inherit distutils-r1
+
+DESCRIPTION="Asynchronous Python HTTP for Humans"
+HOMEPAGE="https://github.com/tardyp/txrequests"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+       >=dev-python/requests-1.2.0[${PYTHON_USEDEP}]
+       dev-python/twisted[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+       dev-python/setuptools[${PYTHON_USEDEP}]
+"