kde-apps/ktp-common-internals: Build w/ >=net-libs/telepathy-qt-0.9.8
authorAndreas Sturmlechner <asturm@gentoo.org>
Thu, 14 Nov 2019 16:30:57 +0000 (17:30 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Fri, 15 Nov 2019 00:35:57 +0000 (01:35 +0100)
Bug: https://bugs.gentoo.org/699882
Package-Manager: Portage-2.3.79, Repoman-2.3.18
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
kde-apps/ktp-common-internals/files/ktp-common-internals-19.08.3-telepathy-0.9.8.patch [new file with mode: 0644]
kde-apps/ktp-common-internals/ktp-common-internals-19.08.3.ebuild

diff --git a/kde-apps/ktp-common-internals/files/ktp-common-internals-19.08.3-telepathy-0.9.8.patch b/kde-apps/ktp-common-internals/files/ktp-common-internals-19.08.3-telepathy-0.9.8.patch
new file mode 100644 (file)
index 0000000..9cc3b30
--- /dev/null
@@ -0,0 +1,57 @@
+From f030b527c4d390ead78d2e56a1655444f97b5545 Mon Sep 17 00:00:00 2001
+From: Antonio Rojas <arojas@archlinux.org>
+Date: Thu, 14 Nov 2019 20:34:21 +0100
+Subject: [PATCH] Fix build with telepathy-qt 0.9.8
+
+Explicitely add the necessary link targets which are no longer exported by telepathy-qt
+
+Differential Revision: https://phabricator.kde.org/D25269
+---
+ CMakeLists.txt         | 4 +++-
+ KTp/CMakeLists.txt     | 2 ++
+ KTp/OTR/CMakeLists.txt | 1 +
+ 3 files changed, 6 insertions(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 187400e..2650321 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -20,8 +20,10 @@ set (KTP_VERSION "${KDE_APPLICATIONS_VERSION_MAJOR}.${KDE_APPLICATIONS_VERSION_M
+ set (KTP_MESSAGE_FILTER_FRAMEWORK_VERSION "5")
+ find_package (Qt5 REQUIRED CONFIG COMPONENTS
++              DBus
+               Qml
+-              Test)
++              Test
++              Xml)
+ find_package (KF5 5.11 REQUIRED COMPONENTS
+               CoreAddons
+diff --git a/KTp/CMakeLists.txt b/KTp/CMakeLists.txt
+index 85d578b..ffbce10 100644
+--- a/KTp/CMakeLists.txt
++++ b/KTp/CMakeLists.txt
+@@ -91,6 +91,8 @@ set_target_properties(KTpCommonInternals PROPERTIES
+ target_link_libraries (KTpCommonInternals
+                 PUBLIC
++                    Qt5::DBus
++                    Qt5::Xml
+                     KF5::Wallet #included from wallet-interface.h
+                     ${TELEPATHY_QT5_LIBRARIES}
+                 PRIVATE
+diff --git a/KTp/OTR/CMakeLists.txt b/KTp/OTR/CMakeLists.txt
+index 12e28de..0743e25 100644
+--- a/KTp/OTR/CMakeLists.txt
++++ b/KTp/OTR/CMakeLists.txt
+@@ -28,6 +28,7 @@ generate_export_header(KTpOTR)
+ target_link_libraries (KTpOTR
+                         PUBLIC
++                            Qt5::DBus
+                             ${TELEPATHY_QT5_LIBRARIES}
+                         PRIVATE
+                             KF5::I18n
+-- 
+2.24.0
index ce1d9ddfacc5a3b15a874a2257b7b39d50075ed7..2df7d44da82d8912cd88a827ba51abc1ff7f1b27 100644 (file)
@@ -56,6 +56,8 @@ DEPEND="${RDEPEND}
        >=dev-qt/qtnetwork-${QTMIN}:5
 "
 
+PATCHES=( "${FILESDIR}/${P}-telepathy-0.9.8.patch" )
+
 src_configure() {
        local mycmakeargs=(
                $(cmake-utils_use_find_package sso KAccounts)