fix use invocation
authorMichael Sterrett <mr_bones_@gentoo.org>
Thu, 3 Jun 2004 07:51:07 +0000 (07:51 +0000)
committerMichael Sterrett <mr_bones_@gentoo.org>
Thu, 3 Jun 2004 07:51:07 +0000 (07:51 +0000)
games-action/descent3/ChangeLog
games-action/descent3/descent3-1.4.0b.ebuild
games-action/fakk2/ChangeLog
games-action/fakk2/fakk2-1.02.ebuild
games-action/heavygear2/ChangeLog
games-action/heavygear2/heavygear2-1.0b.ebuild

index e662ae0797db5f47d338914363e5697da4dfb4b2..6081c4207edb81bd9be92aeac836855f2a11e4fa 100644 (file)
@@ -1,6 +1,9 @@
 # ChangeLog for games-action/descent3
 # Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/descent3/ChangeLog,v 1.5 2004/04/04 07:10:06 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/descent3/ChangeLog,v 1.6 2004/06/03 07:51:07 mr_bones_ Exp $
+
+  03 Jun 2004; Michael Sterrett <mr_bones_@gentoo.org> descent3-1.4.0b.ebuild:
+  fix use invocation
 
   04 Apr 2004; Chris Gianelloni <wolf31o2@gentoo.org> descent3-1.4.0b.ebuild:
   Fixed crash with 2.6 and closing bug #38862.
index 8c0b1901ee69603abcb9099b698edb0def9056cc..c96a338d63dff458f94e496825aed045c8cfd863 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2004 Gentoo Technologies, Inc.
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/descent3/descent3-1.4.0b.ebuild,v 1.4 2004/04/04 07:10:06 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/descent3/descent3-1.4.0b.ebuild,v 1.5 2004/06/03 07:51:07 mr_bones_ Exp $
 
 inherit games
 
@@ -23,13 +23,13 @@ dir=${GAMES_PREFIX_OPT}/${PN}
 Ddir=${D}/${dir}
 
 pkg_setup() {
-       if [ "`use videos`" ]; then
+       if use videos ; then
                ewarn "The installed game takes about 1.2GB of space!"
                cdrom_get_cds missions/d3.mn3 movies/level1.mve
        else
                cdrom_get_cds missions/d3.mn3
        fi
-       if [ "`use nocd`" ]; then
+       if use nocd ; then
                ewarn "The installed game takes about 510MB of space!"
        else
                ewarn "The installed game takes about 220MB of space!"
@@ -62,7 +62,7 @@ src_install() {
 
        use nocd && cp ${CDROM_ROOT}/missions/* ${Ddir}/missions
 
-       if [ "`use videos`" ]; then
+       if use videos ; then
                cdrom_load_next_cd
                cp ${CDROM_ROOT}/movies/* ${Ddir}/movies || die "copying movies"
        fi
index 2f9516817c6606fbf659df54527821209fd7a834..d3e0331123007aedffc15ff7149986b409f81f55 100644 (file)
@@ -1,6 +1,9 @@
 # ChangeLog for games-action/fakk2
 # Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/fakk2/ChangeLog,v 1.3 2004/02/15 23:20:02 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/fakk2/ChangeLog,v 1.4 2004/06/03 07:49:05 mr_bones_ Exp $
+
+  03 Jun 2004; Michael Sterrett <mr_bones_@gentoo.org> fakk2-1.02.ebuild:
+  fix use invocation
 
   15 Feb 2004; Chris Gianelloni <wolf31o2@gentoo.org> fakk2-1.02.ebuild:
   Updated to use new cdrom_get_cds routine in eutils.eclass.
index e00a7ff946a3956ffad8329a6d066ee5b7c01ec6..3e4b376deda98285a6bc68c16a9062c43cf30aab 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2004 Gentoo Technologies, Inc.
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/fakk2/fakk2-1.02.ebuild,v 1.2 2004/02/15 23:20:02 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/fakk2/fakk2-1.02.ebuild,v 1.3 2004/06/03 07:49:05 mr_bones_ Exp $
 
 inherit games
 
@@ -25,7 +25,7 @@ Ddir=${D}/${dir}
 
 pkg_setup() {
        check_license || die "License check failed"
-       if [ "`use nocd`" ]; then
+       if use nocd ; then
                ewarn "The installed game takes about 378MB of space!"
        fi
        cdrom_get_cds fakk
@@ -42,7 +42,7 @@ src_install() {
        dodir ${dir}/fakk
        exeinto /opt/fakk2/fakk
        doexe ${CDROM_ROOT}/bin/x86/glibc-2.1/fakk/{c,f}game.so
-       if [ "`use nocd`" ]; then
+       if use nocd ; then
                insinto /opt/fakk2/fakk
                doins ${CDROM_ROOT}/fakk/pak{0,1,2,3}.pk3
        fi
index 8b99d57cf051687e241c28b446e4a6b59a5e82fa..9292b16fea51997abd6757903bcd83e9bf5f3395 100644 (file)
@@ -1,6 +1,9 @@
 # ChangeLog for games-action/heavygear2
 # Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/heavygear2/ChangeLog,v 1.4 2004/02/15 23:23:18 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/heavygear2/ChangeLog,v 1.5 2004/06/03 07:47:44 mr_bones_ Exp $
+
+  03 Jun 2004; Michael Sterrett <mr_bones_@gentoo.org> heavygear2-1.0b.ebuild:
+  fix use invocation
 
   15 Feb 2004; Chris Gianelloni <wolf31o2@gentoo.org> heavygear2-1.0b.ebuild:
   Updated to use new cdrom_get_cds routine in eutils.eclass.
index be530afc7fac74043afa4675174a2e4d5a08748e..acc030bbd3774aa456b6afe71f2e2fed2415361c 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2004 Gentoo Technologies, Inc.
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/heavygear2/heavygear2-1.0b.ebuild,v 1.3 2004/02/15 23:23:18 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/heavygear2/heavygear2-1.0b.ebuild,v 1.4 2004/06/03 07:47:44 mr_bones_ Exp $
 
 inherit games
 
@@ -28,7 +28,7 @@ Ddir=${D}/${dir}
 pkg_setup() {
        check_license || die "License check failed"
        cdrom_get_cds shell/movies/asteroid.mpg
-       if [ "`use videos`" ]; then
+       if use videos ; then
                ewarn "The installed game takes about 500MB of space!"
        else
                ewarn "The installed game takes about 400MB of space!"
@@ -77,7 +77,7 @@ src_install() {
 }
 
 pkg_postinst() {
-       if [ ! "`use videos`" ]; then
+       if ! use videos ; then
                einfo "You will need to mount the Heavy Gear II CD to see the cut-scene videos."
                echo
        fi