media-video/mpv: version bump (bug 560030)
authorBen de Groot <yngwin@gentoo.org>
Sat, 26 Sep 2015 07:03:31 +0000 (15:03 +0800)
committerBen de Groot <yngwin@gentoo.org>
Sat, 26 Sep 2015 07:03:31 +0000 (15:03 +0800)
Package-Manager: portage-2.2.22

media-video/mpv/Manifest
media-video/mpv/mpv-0.11.0.ebuild [new file with mode: 0644]

index ea1202f8b43759b146bb395efd5e88d16e45da6d..89e69f2dc92d68f9ee866f2d1e6cc005237aa669 100644 (file)
@@ -1,3 +1,5 @@
+DIST mpv-0.11.0.tar.gz 2689655 SHA256 a2157174e46db46dad5deb1fde94283e72ebe922fd15447cb16a2a243fae5bda SHA512 f85da000770dbca09be2a59c4eda7e6d7142ca17328844d2b08a173f64554159f50ba9b32661ba67924b789e886940cda1add993862f02f295e7753f50388bdb WHIRLPOOL 1184f09435d6f30119143ab98ddd4767e53c701bdc5b850eb62c19607652a7103699a6b54a0d165acb548f4cced4179af6f7decbf64c8289ff56736e26ed7924
 DIST mpv-0.9.2.tar.gz 2701306 SHA256 c0148f55dbd17705f49bb496d0ce374419de62e1b17195d91409d7727cbd4751 SHA512 4f652a8e78d65b0ef44a06287b05250dfdfbce4cf5a6e21d3b446eedec268d83cf98afcc687272e2da2cfac9e9f69a303847dffdfd45cecdd4273b943ce50967 WHIRLPOOL 1512bacc2ce50e875770c76106a1bb2bc1d0cc5f6e2bdce91ff8c5cfc8bf13ffb48519858a5fa2a7d57880820dc12e5eb20f34ab71eca5d76ec303618da8f3fe
 DIST mpv-0.9.2_p20150824.tar.xz 1867384 SHA256 67fa5ce11740b83ceef8bc435d5ef17803f1ec328dd2fee93b67e46ccc195209 SHA512 1ae0fd4faa180472c023c0ba77a28f2d1319f597763d5249259d55a04387b5f6384e2c5a8ff78bb514dfda86c30ceb474c35e54468a29ad3fc6327c4baaf75cc WHIRLPOOL cb61758234f9186880def4dcb7cb7e54d03abd6734484b5691926e2514cae1bebef6f9a53465e2aa2710e4ad5dbe1875369d483489a5cb853c3fa756ff7e968a
+DIST waf-1.8.12 97567 SHA256 01bf2beab2106d1558800c8709bc2c8e496d3da4a2ca343fe091f22fca60c98b SHA512 8e47112abb134f965f15a27a600b4453cad3075afb5dadc17f2f6dac33d80ec68b679ac0ebc5f8a0245cbd07ae9fc7b899e69afc1bd021cce74e7af2ab457939 WHIRLPOOL c36d37c2d8c08e4048b4800f511611af5cf534304fcb58388ca491ff308bfcbcdd959d153edfd6ff8c118404e7293d8b786e43b07486139bf915a82aa75d792b
 DIST waf-1.8.4 96179 SHA256 f02035fa5d8814f33f19b2b20d43822ddef6bb39b955ca196c2a247a1f9ffaa8 SHA512 3a132d8b1cba0af0e3df046c0204c5df706fae4e0fac41cf74b53f6cdea6210ed798671c7a3cb3fee70573aacab16d4c0cc699cc4b7aa74c8a416346c5513f4c WHIRLPOOL fe8d7f42e5118a1f9490a0c9add1355c969185376b57d0bab024068dd6e7364632d862bf9432e1209165c5313ae843479ef334f4bd6285db05dfebff9a1b640e
diff --git a/media-video/mpv/mpv-0.11.0.ebuild b/media-video/mpv/mpv-0.11.0.ebuild
new file mode 100644 (file)
index 0000000..7bfb032
--- /dev/null
@@ -0,0 +1,259 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+PYTHON_REQ_USE='threads(+)'
+inherit eutils python-any-r1 waf-utils pax-utils fdo-mime gnome2-utils
+
+WAF_V="1.8.12"
+
+DESCRIPTION="Media player based on MPlayer and mplayer2"
+HOMEPAGE="http://mpv.io/"
+SRC_URI="http://ftp.waf.io/pub/release/waf-${WAF_V}"
+DOCS=( README.md etc/example.conf etc/input.conf )
+
+if [[ ${PV} == *9999* ]]; then
+       EGIT_REPO_URI="https://github.com/mpv-player/mpv.git"
+       inherit git-r3
+else
+       SRC_URI+=" https://github.com/mpv-player/mpv/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+       KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux"
+       #DOCS+=( RELEASE_NOTES )
+fi
+
+# See Copyright in source tarball and bug #506946. Waf is BSD, libmpv is ISC.
+LICENSE="GPL-2+ BSD ISC"
+SLOT="0"
+IUSE="+alsa bluray cdio +cli doc-pdf drm dvb +dvd egl +enca encode +iconv
+jack jpeg lcms +libass libav libcaca libguess libmpv lua luajit openal
++opengl oss pulseaudio pvr raspberry-pi rubberband samba sdl selinux v4l vaapi
+vdpau vf-dlopen wayland +X xinerama +xscreensaver xv"
+
+REQUIRED_USE="
+       || ( cli libmpv )
+       egl? ( opengl X )
+       enca? ( iconv )
+       lcms? ( opengl )
+       libguess? ( iconv )
+       luajit? ( lua )
+       opengl? ( || ( wayland X ) )
+       pvr? ( v4l )
+       vaapi? ( X )
+       vdpau? ( X )
+       wayland? ( opengl )
+       xinerama? ( X )
+       xscreensaver? ( X )
+       xv? ( X )
+"
+
+RDEPEND="
+       libav? ( >=media-video/libav-11:0=[encode?,threads,vaapi?,vdpau?] )
+       !libav? ( >=media-video/ffmpeg-2.4.0:0=[encode?,threads,vaapi?,vdpau?] )
+       sys-libs/zlib
+       X? (
+               x11-libs/libX11
+               x11-libs/libXext
+               >=x11-libs/libXrandr-1.2.0
+               opengl? (
+                       virtual/opengl
+                       egl? ( media-libs/mesa[egl] )
+               )
+               lcms? ( >=media-libs/lcms-2.6:2 )
+               vaapi? ( >=x11-libs/libva-0.34.0[X(+)] )
+               vdpau? ( >=x11-libs/libvdpau-0.2 )
+               xinerama? ( x11-libs/libXinerama )
+               xscreensaver? ( x11-libs/libXScrnSaver )
+               xv? ( x11-libs/libXv )
+       )
+       alsa? ( >=media-libs/alsa-lib-1.0.18 )
+       bluray? ( >=media-libs/libbluray-0.3.0 )
+       cdio? (
+               dev-libs/libcdio
+               dev-libs/libcdio-paranoia
+       )
+       drm? ( x11-libs/libdrm )
+       dvb? ( virtual/linuxtv-dvb-headers )
+       dvd? (
+               >=media-libs/libdvdread-4.1.3
+               >=media-libs/libdvdnav-4.2.0
+       )
+       enca? ( app-i18n/enca )
+       iconv? ( virtual/libiconv )
+       jack? ( media-sound/jack-audio-connection-kit )
+       jpeg? ( virtual/jpeg:0 )
+       libass? (
+               >=media-libs/libass-0.12.1:=[enca?,fontconfig]
+               virtual/ttf-fonts
+       )
+       libcaca? ( >=media-libs/libcaca-0.99_beta18 )
+       libguess? ( >=app-i18n/libguess-1.0 )
+       lua? (
+               !luajit? ( || ( =dev-lang/lua-5.1*:= =dev-lang/lua-5.2*:= ) )
+               luajit? ( dev-lang/luajit:2 )
+       )
+       openal? ( >=media-libs/openal-1.13 )
+       pulseaudio? ( media-sound/pulseaudio )
+       rubberband? ( >=media-libs/rubberband-1.8.0 )
+       samba? ( net-fs/samba )
+       sdl? ( media-libs/libsdl2[threads] )
+       v4l? ( media-libs/libv4l )
+       wayland? (
+               >=dev-libs/wayland-1.6.0
+               media-libs/mesa[egl,wayland]
+               >=x11-libs/libxkbcommon-0.3.0
+       )
+"
+DEPEND="${RDEPEND}
+       ${PYTHON_DEPS}
+       virtual/pkgconfig
+       >=dev-lang/perl-5.8
+       dev-python/docutils
+       doc-pdf? ( dev-python/rst2pdf )
+       X? (
+               x11-proto/videoproto
+               xinerama? ( x11-proto/xineramaproto )
+               xscreensaver? ( x11-proto/scrnsaverproto )
+       )
+"
+RDEPEND+="
+       selinux? ( sec-policy/selinux-mplayer )
+"
+
+pkg_setup() {
+       if ! use libass; then
+               ewarn "You have disabled the libass flag. No OSD or subtitles will be displayed."
+       fi
+
+       if use openal; then
+               ewarn "You have enabled the openal audio output which is a fallback"
+               ewarn "and disabled by upstream."
+       fi
+
+       if use sdl; then
+               ewarn "You have enabled the sdl video and audio outputs which are fallbacks"
+               ewarn "and disabled by upstream."
+       fi
+
+       if use libav; then
+               einfo "You have enabled media-video/libav instead of media-video/ffmpeg."
+               einfo "Upstream recommends media-video/ffmpeg, as some functionality is not"
+               einfo "provided by media-video/libav."
+       fi
+
+       einfo "For additional format support you need to enable the support on your"
+       einfo "libavcodec/libavformat provider:"
+       einfo "    media-video/ffmpeg or media-video/libav"
+
+       python-any-r1_pkg_setup
+}
+
+src_prepare() {
+       cp "${DISTDIR}"/waf-${WAF_V} "${S}"/waf || die
+       chmod 0755 "${S}"/waf || die
+       epatch_user
+}
+
+src_configure() {
+       local mywafargs=(
+               --confdir="${EPREFIX}"/etc/${PN}
+               --docdir="${EPREFIX}"/usr/share/doc/${PF}
+               $(usex cli '' '--disable-cplayer')
+               $(use_enable libmpv libmpv-shared)
+               --disable-libmpv-static
+               --disable-build-date    # keep build reproducible
+               --disable-optimize      # do not add '-O2' to CFLAGS
+               --disable-debug-build   # do not add '-g' to CFLAGS
+               --disable-test          # avoid dev-util/cmocka automagic
+               $(use_enable doc-pdf pdf-build)
+               $(use_enable vf-dlopen vf-dlopen-filters)
+               $(use_enable cli zsh-comp)
+
+               # optional features
+               $(use_enable iconv)
+               $(use_enable libguess)
+               $(use_enable samba libsmbclient)
+               $(use_enable lua)
+               $(use_enable libass)
+               $(use_enable libass libass-osd)
+               $(use_enable encode encoding)
+               $(use_enable bluray libbluray)
+               $(use_enable dvd dvdread)
+               $(use_enable dvd dvdnav)
+               $(use_enable cdio cdda)
+               $(use_enable enca)
+               $(use_enable rubberband)
+               $(use_enable lcms lcms2)
+               --disable-vapoursynth   # vapoursynth is not packaged
+               --disable-vapoursynth-lazy
+               --enable-libavfilter
+               --enable-libavdevice
+               $(usex luajit '--lua=luajit' '')
+
+               # audio outputs
+               $(use_enable sdl sdl2)  # SDL output is fallback for platforms where nothing better is available
+               --disable-sdl1
+               $(use_enable oss oss-audio)
+               --disable-rsound        # media-sound/rsound is in pro-audio overlay only
+               $(use_enable pulseaudio pulse)
+               $(use_enable jack)
+               $(use_enable openal)
+               $(use_enable alsa)
+
+               # video outputs
+               $(use_enable wayland)
+               $(use_enable X x11)
+               $(use_enable xscreensaver xss)
+               $(use_enable X xext)
+               $(use_enable xv)
+               $(use_enable xinerama)
+               $(use_enable X xrandr)
+               $(usex X "$(use_enable opengl gl-x11)" '--disable-gl-x11')
+               $(use_enable egl egl-x11)
+               $(usex wayland "$(use_enable opengl gl-wayland)" '--disable-gl-wayland')
+               $(use_enable opengl gl)
+               $(use_enable vdpau)
+               $(usex vdpau "$(use_enable opengl vdpau-gl-x11)" '--disable-vdpau-gl-x11')
+               $(use_enable vaapi)
+               $(use_enable vaapi vaapi-vpp)
+               $(usex vaapi "$(use_enable opengl vaapi-glx)" '--disable-vaapi-glx')
+               $(use_enable libcaca caca)
+               $(use_enable drm)
+               $(use_enable jpeg)
+               $(use_enable raspberry-pi rpi)
+
+               # hwaccels
+               $(use_enable vaapi vaapi-hwaccel)
+
+               # tv features
+               $(use_enable v4l tv)
+               $(use_enable v4l tv-v4l2)
+               $(use_enable v4l libv4l2)
+               $(use_enable pvr)
+               $(use_enable dvb dvbin)
+       )
+       waf-utils_src_configure "${mywafargs[@]}"
+}
+
+src_install() {
+       waf-utils_src_install
+
+       if use cli && use luajit; then
+               pax-mark -m "${ED}"usr/bin/mpv
+       fi
+}
+
+pkg_preinst() {
+       gnome2_icon_savelist
+}
+
+pkg_postinst() {
+       fdo-mime_desktop_database_update
+       gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+       fdo-mime_desktop_database_update
+       gnome2_icon_cache_update
+}