app-admin/webapp-config: respect EPREFIX during src_install
authorMartin Mokrejš <mmokrejs@gmail.com>
Tue, 10 Jan 2017 14:21:55 +0000 (15:21 +0100)
committerMichał Górny <mgorny@gentoo.org>
Tue, 23 May 2017 06:03:56 +0000 (08:03 +0200)
Closes: https://github.com/gentoo/gentoo/pull/3415

app-admin/webapp-config/webapp-config-1.52-r1.ebuild
app-admin/webapp-config/webapp-config-1.53-r2.ebuild
app-admin/webapp-config/webapp-config-1.54-r1.ebuild
app-admin/webapp-config/webapp-config-1.54-r2.ebuild

index 2cca142219d5c9b662fa01d56b69a6dfdbfb2996..e8c416dd5e3a6db9429fb1819efcb9db89575456 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI="5"
@@ -35,7 +35,7 @@ python_install() {
        # distutils does not provide for specifying two different script install
        # locations. Since we only install one script here the following should
        # be ok
-       distutils-r1_python_install --install-scripts="/usr/sbin"
+       distutils-r1_python_install --install-scripts="${EPREFIX}/usr/sbin"
 }
 
 python_install_all() {
index 795e702cd8fc6600c0684f041ef3c7386b69875e..e7084845cb46ad3dfe742adfe70864a3f67035ba 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI="5"
@@ -38,7 +38,7 @@ python_install() {
        # distutils does not provide for specifying two different script install
        # locations. Since we only install one script here the following should
        # be ok
-       distutils-r1_python_install --install-scripts="/usr/sbin"
+       distutils-r1_python_install --install-scripts="${EPREFIX}/usr/sbin"
 }
 
 python_install_all() {
index f33bfb49fc521910c383cdc5e9cb48b632062ced..2141c27bac3b6eefc94edafd0d17ae5e6ef33636 100644 (file)
@@ -34,7 +34,7 @@ python_install() {
        # distutils does not provide for specifying two different script install
        # locations. Since we only install one script here the following should
        # be ok
-       distutils-r1_python_install --install-scripts="/usr/sbin"
+       distutils-r1_python_install --install-scripts="${EPREFIX}/usr/sbin"
 }
 
 python_install_all() {
index 9936cfe55d7ed1b5b1ce3292ba434bc4021af244..d364cbb451135fdc0118c67e72c4cb7da5d19187 100644 (file)
@@ -35,7 +35,7 @@ python_install() {
        # distutils does not provide for specifying two different script install
        # locations. Since we only install one script here the following should
        # be ok
-       distutils-r1_python_install --install-scripts="/usr/sbin"
+       distutils-r1_python_install --install-scripts="${EPREFIX}/usr/sbin"
 }
 
 python_install_all() {