dev-lang/gnat-gcc: fixed ncurses SLOT dep to :0
authorGeorge Shapovalov <george@gentoo.org>
Thu, 3 Sep 2015 06:29:53 +0000 (08:29 +0200)
committerGeorge Shapovalov <george@gentoo.org>
Thu, 3 Sep 2015 06:29:53 +0000 (08:29 +0200)
As per discussion on -dev list. Also revbumped to updated VDB.

Acked-by: hasufell <hasufell@gentoo.org>
Package-Manager: portage-2.2.20.1

dev-lang/gnat-gcc/gnat-gcc-4.3.6-r1.ebuild [new file with mode: 0644]
dev-lang/gnat-gcc/gnat-gcc-4.4.7-r1.ebuild [new file with mode: 0644]
dev-lang/gnat-gcc/gnat-gcc-4.5.4-r1.ebuild [new file with mode: 0644]
dev-lang/gnat-gcc/gnat-gcc-4.6.4-r1.ebuild [new file with mode: 0644]

diff --git a/dev-lang/gnat-gcc/gnat-gcc-4.3.6-r1.ebuild b/dev-lang/gnat-gcc/gnat-gcc-4.3.6-r1.ebuild
new file mode 100644 (file)
index 0000000..19c9a5a
--- /dev/null
@@ -0,0 +1,65 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit gnatbuild
+
+DESCRIPTION="GNAT Ada Compiler - gcc version"
+HOMEPAGE="https://gcc.gnu.org/"
+LICENSE="GMGPL"
+
+IUSE="doc lto" # doc and lto from gnatbuild.eclass
+
+# SLOT is set in gnatbuild.eclass, depends only on PV (basically SLOT=GCCBRANCH)
+# so the URI's are static.
+SRC_URI="ftp://gcc.gnu.org/pub/gcc/releases/gcc-${PV}/gcc-core-${PV}.tar.bz2
+       ftp://gcc.gnu.org/pub/gcc/releases/gcc-${PV}/gcc-ada-${PV}.tar.bz2
+       amd64? ( https://dev.gentoo.org/~george/src/gnatboot-${SLOT}-amd64.tar.bz2 )
+       x86?   ( https://dev.gentoo.org/~george/src/gnatboot-${SLOT}-i686.tar.bz2 )
+       ppc?   ( https://dev.gentoo.org/~george/src/gnatboot-4.1-ppc.tar.bz2 )"
+#      sparc? ( mirror://gentoo/gnatboot-${BOOT_SLOT}-sparc.tar.bz2 )
+
+KEYWORDS="~amd64 ~ppc ~x86"
+
+# starting with 4.3.0 gnat needs these libs
+RDEPEND=">=dev-libs/mpfr-2.3.1:*
+       >=dev-libs/gmp-4.2.2:*
+       >=sys-libs/zlib-1.1.4
+       >=sys-libs/ncurses-5.2-r2:0"
+
+DEPEND="${RDEPEND}
+       <sys-apps/texinfo-5.1
+       >=sys-devel/bison-1.875
+       >=sys-libs/glibc-2.8
+       >=sys-devel/binutils-2.15.94"
+
+#QA_EXECSTACK="${BINPATH:1}/gnatls ${BINPATH:1}/gnatbind ${BINPATH:1}/gnatmake
+#      ${LIBEXECPATH:1}/gnat1 ${LIBPATH:1}/adalib/libgnat-${SLOT}.so"
+
+src_unpack() {
+       gnatbuild_src_unpack
+
+       # newly added zlib dir is processed by configure even with
+       # --with-systtem-zlib passed, causing toruble on multilib
+       rm -rf "${S}"/zlib
+
+       #fixup some hardwired flags
+       cd "${S}"/gcc/ada
+
+       # universal gcc -> gnatgcc substitution occasionally produces lines too long
+       # and then build halts on the style check.
+       #
+       # The sed in makegpr.adb is actually not for the line length but rather to
+       # "undo" the fixing, Last3 is matching just that - the last three characters
+       # of the compiler name.
+       sed -i -e 's:(Last3 = "gnatgcc"):(Last3 = "gcc"):' makegpr.adb &&
+       sed -i -e 's:and Nam is "gnatgcc":and Nam is "gcc":' osint.ads ||
+               die     "reversing [gnat]gcc substitution in comments failed"
+}
+
+src_compile() {
+       # looks like gnatlib_and_tools and gnatlib_shared have become part of
+       # bootstrap
+       gnatbuild_src_compile configure make-tools bootstrap
+}
diff --git a/dev-lang/gnat-gcc/gnat-gcc-4.4.7-r1.ebuild b/dev-lang/gnat-gcc/gnat-gcc-4.4.7-r1.ebuild
new file mode 100644 (file)
index 0000000..e9875e3
--- /dev/null
@@ -0,0 +1,64 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit gnatbuild
+
+DESCRIPTION="GNAT Ada Compiler - gcc version"
+HOMEPAGE="https://gcc.gnu.org/"
+LICENSE="GMGPL"
+
+IUSE=""
+
+BOOT_SLOT="4.3"
+
+# SLOT is set in gnatbuild.eclass, depends only on PV (basically SLOT=GCCBRANCH)
+# so the URI's are static.
+SRC_URI="ftp://gcc.gnu.org/pub/gcc/releases/gcc-${PV}/gcc-core-${PV}.tar.bz2
+       ftp://gcc.gnu.org/pub/gcc/releases/gcc-${PV}/gcc-ada-${PV}.tar.bz2
+       amd64? ( https://dev.gentoo.org/~george/src/gnatboot-${SLOT}-amd64.tar.bz2 )
+       sparc? ( https://dev.gentoo.org/~george/src/gnatboot-${SLOT}-sparc.tar.bz2 )
+       x86?   ( https://dev.gentoo.org/~george/src/gnatboot-${SLOT}-i686.tar.bz2 )"
+#      ppc?   ( mirror://gentoo/gnatboot-${BOOT_SLOT}-ppc.tar.bz2 )
+
+KEYWORDS="~amd64 ~x86"
+
+# starting with 4.3.0 gnat needs these libs
+RDEPEND=">=dev-libs/mpfr-3.0.1
+       >=dev-libs/gmp-5.0
+       >=sys-libs/zlib-1.2
+       >=sys-libs/ncurses-5.7:0"
+
+DEPEND="${RDEPEND}
+       <sys-apps/texinfo-5.1
+       >=sys-devel/bison-1.875
+       >=sys-libs/glibc-2.8
+       >=sys-devel/binutils-2.20"
+
+#QA_EXECSTACK="${BINPATH:1}/gnatls ${BINPATH:1}/gnatbind ${BINPATH:1}/gnatmake
+#      ${LIBEXECPATH:1}/gnat1 ${LIBPATH:1}/adalib/libgnat-${SLOT}.so"
+
+src_unpack() {
+       gnatbuild_src_unpack
+
+       #fixup some hardwired flags
+       cd "${S}"/gcc/ada
+
+       # universal gcc -> gnatgcc substitution occasionally produces lines too long
+       # and then build halts on the style check.
+       #
+       sed -i -e 's:and Nam is "gnatgcc":and Nam is "gcc":' osint.ads ||
+               die     "reversing [gnat]gcc substitution in comments failed"
+
+       # gcc pretty much ignores --with-system-zlib. At least it still descends
+       # into zlib and does configure and build there (gcc bug@7125?). For whatever
+       # reason this conflicts with multilib in gcc-4.4..
+       sed -i -e "s:libgui zlib:libgui:" "${S}"/configure
+}
+
+src_compile() {
+       # looks like gnatlib_and_tools and gnatlib_shared have become part of
+       # bootstrap
+       gnatbuild_src_compile configure make-tools bootstrap
+}
diff --git a/dev-lang/gnat-gcc/gnat-gcc-4.5.4-r1.ebuild b/dev-lang/gnat-gcc/gnat-gcc-4.5.4-r1.ebuild
new file mode 100644 (file)
index 0000000..fbf8dcc
--- /dev/null
@@ -0,0 +1,76 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit gnatbuild
+
+DESCRIPTION="GNAT Ada Compiler - gcc version"
+HOMEPAGE="https://gcc.gnu.org/"
+LICENSE="GMGPL"
+
+IUSE="doc"
+
+BOOT_SLOT="4.4"
+
+# SLOT is set in gnatbuild.eclass, depends only on PV (basically SLOT=GCCBRANCH)
+# so the URI's are static.
+SRC_URI="ftp://gcc.gnu.org/pub/gcc/releases/gcc-${PV}/gcc-core-${PV}.tar.bz2
+       ftp://gcc.gnu.org/pub/gcc/releases/gcc-${PV}/gcc-ada-${PV}.tar.bz2
+       amd64? ( https://dev.gentoo.org/~george/src/gnatboot-${BOOT_SLOT}-amd64.tar.bz2 )
+       sparc? ( https://dev.gentoo.org/~george/src/gnatboot-${BOOT_SLOT}-sparc.tar.bz2 )
+       x86?   ( https://dev.gentoo.org/~george/src/gnatboot-${BOOT_SLOT}-i686.tar.bz2 )"
+#      ppc?   ( mirror://gentoo/gnatboot-${BOOT_SLOT}-ppc.tar.bz2 )
+
+KEYWORDS="~amd64 ~x86"
+
+# starting with 4.3.0 gnat needs these libs
+RDEPEND=">=dev-libs/mpfr-3.0.1
+       >=dev-libs/gmp-5.0
+       >=sys-libs/zlib-1.2
+       >=sys-libs/ncurses-5.7:0"
+
+DEPEND="${RDEPEND}
+       doc? ( sys-apps/texinfo )
+       >=sys-devel/bison-1.875
+       >=sys-libs/glibc-2.8
+       >=sys-devel/binutils-2.20"
+
+#QA_EXECSTACK="${BINPATH:1}/gnatls ${BINPATH:1}/gnatbind ${BINPATH:1}/gnatmake
+#      ${LIBEXECPATH:1}/gnat1 ${LIBPATH:1}/adalib/libgnat-${SLOT}.so"
+
+src_unpack() {
+       gnatbuild_src_unpack
+
+       #fixup some hardwired flags
+       cd "${S}"/gcc/ada
+
+       # universal gcc -> gnatgcc substitution occasionally produces lines too long
+       # and then build halts on the style check.
+       #
+       sed -i -e 's:gnatgcc:gcc:' osint.ads switch.ads ||
+               die     "reversing [gnat]gcc substitution in comments failed"
+
+       # gcc pretty much ignores --with-system-zlib. At least it still descends
+       # into zlib and does configure and build there (gcc bug@7125?). For whatever
+       # reason this conflicts with multilib in gcc-4.4..
+       sed -i -e "s:libgui zlib:libgui:" "${S}"/configure
+}
+
+src_compile() {
+       # work-around for downgrading texinfo.  See bug #483192
+       if use doc ; then
+               if has_version ">=sys-apps/texinfo-5.1" ; then
+                       ewarn "Disabling info docs.  Please downgrade texinfo to less than 5.x or"
+                       ewarn "use ${PN}-4.6 instead (as upstream has only patched 4.6 and higher)."
+                       epatch "${FILESDIR}"/${P}-tex-version-workaround.patch
+               fi
+       else
+               elog "Disabling info docs."
+               epatch "${FILESDIR}"/${P}-tex-version-workaround.patch
+       fi
+
+       # looks like gnatlib_and_tools and gnatlib_shared have become part of
+       # bootstrap
+       gnatbuild_src_compile configure make-tools bootstrap
+}
diff --git a/dev-lang/gnat-gcc/gnat-gcc-4.6.4-r1.ebuild b/dev-lang/gnat-gcc/gnat-gcc-4.6.4-r1.ebuild
new file mode 100644 (file)
index 0000000..6fa8363
--- /dev/null
@@ -0,0 +1,62 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit gnatbuild
+
+DESCRIPTION="GNAT Ada Compiler - gcc version"
+HOMEPAGE="https://gcc.gnu.org/"
+LICENSE="GMGPL"
+
+IUSE="doc lto openmp"
+
+BOOT_SLOT="4.4"
+
+# SLOT is set in gnatbuild.eclass, depends only on PV (basically SLOT=GCCBRANCH)
+# so the URI's are static.
+SRC_URI="ftp://gcc.gnu.org/pub/gcc/releases/gcc-${PV}/gcc-core-${PV}.tar.bz2
+       ftp://gcc.gnu.org/pub/gcc/releases/gcc-${PV}/gcc-ada-${PV}.tar.bz2
+       amd64? ( https://dev.gentoo.org/~george/src/gnatboot-${BOOT_SLOT}-amd64.tar.bz2 )
+       sparc? ( https://dev.gentoo.org/~george/src/gnatboot-${BOOT_SLOT}-sparc.tar.bz2 )
+       x86?   ( https://dev.gentoo.org/~george/src/gnatboot-${BOOT_SLOT}-i686.tar.bz2 )"
+#      ppc?   ( mirror://gentoo/gnatboot-${BOOT_SLOT}-ppc.tar.bz2 )
+
+KEYWORDS="~amd64 ~x86"
+
+# starting with 4.3.0 gnat needs these libs
+RDEPEND=">=dev-libs/mpfr-3.1.2
+       >=dev-libs/gmp-5.1.3
+       >=dev-libs/mpc-1.0.1
+       >=sys-libs/zlib-1.2
+       >=sys-libs/ncurses-5.7:0"
+
+DEPEND="${RDEPEND}
+       doc? ( >=sys-apps/texinfo-5 )
+       >=sys-devel/bison-1.875
+       >=sys-libs/glibc-2.8
+       >=sys-devel/binutils-2.20"
+
+src_unpack() {
+       gnatbuild_src_unpack
+
+       #fixup some hardwired flags
+       cd "${S}"/gcc/ada
+
+       # universal gcc -> gnatgcc substitution occasionally produces lines too long
+       # and then build halts on the style check.
+       #
+       sed -i -e 's:gnatgcc:gcc:' osint.ads switch.ads ||
+               die     "reversing [gnat]gcc substitution in comments failed"
+
+       # gcc pretty much ignores --with-system-zlib. At least it still descends
+       # into zlib and does configure and build there (gcc bug@7125?). For whatever
+       # reason this conflicts with multilib in gcc-4.4..
+       sed -i -e "s:libgui zlib:libgui:" "${S}"/configure
+}
+
+src_compile() {
+       # looks like gnatlib_and_tools and gnatlib_shared have become part of
+       # bootstrap
+       gnatbuild_src_compile configure make-tools bootstrap
+}