media-plugins/gst-plugins-ximagesrc: version bump to 1.6.3
authorGilles Dartiguelongue <g.dartiguelongue@lexfo.fr>
Sun, 31 Jan 2016 13:49:18 +0000 (14:49 +0100)
committerGilles Dartiguelongue <g.dartiguelongue@lexfo.fr>
Sun, 31 Jan 2016 13:50:58 +0000 (14:50 +0100)
Package-Manager: portage-2.2.27

media-plugins/gst-plugins-ximagesrc/Manifest
media-plugins/gst-plugins-ximagesrc/gst-plugins-ximagesrc-1.6.3.ebuild [new file with mode: 0644]

index 647171b65849d0594f98f5c6994359b9f6a6ac72..b80266c87cc3d7d850e50bfe1fd5965ae5bb868d 100644 (file)
@@ -2,3 +2,4 @@ DIST gst-plugins-good-0.10.31.tar.xz 2738016 SHA256 77a8436a7c0a15f876bad2961683
 DIST gst-plugins-good-1.4.5.tar.xz 3031588 SHA256 79b1b5f3f7bcaa8a615202eb5e176121eeb8336960f70687e536ad78dbc7e641 SHA512 0cf880af21956138e127508f6020fdc10f6ed01b765b0d3364d038c8e104947486c83c157c7b957193b82d59f724e342a6d12900b6a97abe6e2f3dac65d71be0 WHIRLPOOL a56ca2c2f2b73f299cb3c3605eb70ddbd97d9513d26ee11d91608c08589149df97f23490a6513d991c6b552a7b8a71f75463fd6dbf7579943ac859254eb0af3c
 DIST gst-plugins-good-1.6.1.tar.xz 3188188 SHA256 86d4b814099f7b7b16be19d4b94fa41002ac01fdf1525b07c5764d54c0605935 SHA512 6b326d908a6df3af059ee23ff41b10a07ad21a1c88f542eff5223a6e8acc75ae97ddead6adcf455cafc9e93f27f7829f6b7476d1a5d3f1ff123f477f00b4f41f WHIRLPOOL 78bf3a445ec03fde8f6bd8d0c3f774d4b41deedff1d4d45b650d45f25c648ad17d3ab9256a049416594e0d5f2b1e0904e7118af6d1805fb2072d1b461cac0ced
 DIST gst-plugins-good-1.6.2.tar.xz 3176060 SHA256 876e54dfce93274b98e024f353258d35fa4d49d1f9010069e676c530f6eb6a92 SHA512 b63391448cada4a1db6fb2c27f6e913edb339e7ac5bc47cab3ef09ef85c79a7aa01accfc2d9bfe74188b7a744d82988e39f97958e1ad8808765a451b721d6d23 WHIRLPOOL 9f286e09e85969989de561c2939262f77c1ca3ccc2d381ff79cc3b4385b549e49a7fc5adeff51b253c1285658a4e6840aca85c6c4cc803807b22efc14a3fb09a
+DIST gst-plugins-good-1.6.3.tar.xz 3193272 SHA256 24b19db70b2a83461ebddfe20033db432dadfdb5d4b54ffb1dfa0d830134a177 SHA512 33d4e85cd07ea8d6723c7a5f58cefeec15ddc5392693d131f1b88d8fc844cc24e37dc59d4a3cfbda090ebd15a90e1e9a28a0427b1f00e66a69b9ea40447d70b4 WHIRLPOOL 0279764c4ce1cafbb55f839fe045590782910fc79b20679af71731fc6a6ed3d0cfe36e13e4d0121d9587d2e07f7e8ba41849aad4e72b09654591d90e72a546a8
diff --git a/media-plugins/gst-plugins-ximagesrc/gst-plugins-ximagesrc-1.6.3.ebuild b/media-plugins/gst-plugins-ximagesrc/gst-plugins-ximagesrc-1.6.3.ebuild
new file mode 100644 (file)
index 0000000..83eb921
--- /dev/null
@@ -0,0 +1,29 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GST_ORG_MODULE=gst-plugins-good
+
+inherit gstreamer
+
+DESCRIPTION="GStreamer plugin for X11 video capture stream"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND="
+       >=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
+       >=x11-libs/libXdamage-1.1.4-r1[${MULTILIB_USEDEP}]
+       >=x11-libs/libXext-1.3.2[${MULTILIB_USEDEP}]
+       >=x11-libs/libXfixes-5.0.1[${MULTILIB_USEDEP}]
+"
+DEPEND="${RDEPEND}
+       >=x11-proto/damageproto-1.2.1-r1[${MULTILIB_USEDEP}]
+       >=x11-proto/fixesproto-5.0-r1[${MULTILIB_USEDEP}]
+       >=x11-proto/xextproto-7.2.1-r1[${MULTILIB_USEDEP}]
+       >=x11-proto/xproto-7.0.24[${MULTILIB_USEDEP}]
+"
+
+# xshm is a compile time option of ximage
+GST_PLUGINS_BUILD="x xshm"
+GST_PLUGINS_BUILD_DIR="ximage"