games-util/uglygs: Drop old
authorPacho Ramos <pacho@gentoo.org>
Wed, 2 May 2018 19:27:14 +0000 (21:27 +0200)
committerPacho Ramos <pacho@gentoo.org>
Wed, 2 May 2018 19:28:24 +0000 (21:28 +0200)
Package-Manager: Portage-2.3.31, Repoman-2.3.9

games-util/uglygs/uglygs-0_rc11.ebuild [deleted file]

diff --git a/games-util/uglygs/uglygs-0_rc11.ebuild b/games-util/uglygs/uglygs-0_rc11.ebuild
deleted file mode 100644 (file)
index 8ce6738..0000000
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-inherit eutils games
-
-MY_P=${P/0_/}
-DESCRIPTION="quickly searches the network for game servers"
-HOMEPAGE="http://uglygs.uglypunk.com/"
-SRC_URI="ftp://ftp.uglypunk.com/uglygs/current/${MY_P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~hppa ~x86"
-IUSE=""
-
-DEPEND="net-analyzer/rrdtool[graph]
-       dev-lang/perl"
-RDEPEND=${DEPEND}
-
-S=${WORKDIR}/${MY_P}
-
-src_prepare() {
-       epatch "${FILESDIR}"/${PV}-uglygs.conf.patch
-       sed -i \
-               -e "s:GENTOO_DIR:$(games_get_libdir)/${PN}:" uglygs.conf || die
-       epatch "${FILESDIR}"/${PV}-uglygs.pl.patch
-       sed -i \
-               -e "s:GENTOO_DIR:${GAMES_SYSCONFDIR}:" uglygs.pl || die
-       sed -i \
-               -e "s/strndup/${PN}_strndup/" qstat/qstat.c || die
-}
-
-src_compile() {
-       emake -C qstat CFLAGS="${CFLAGS}"
-}
-
-src_install() {
-       insinto "${GAMES_SYSCONFDIR}"
-       doins uglygs.conf qstat/qstat.cfg
-
-       dogamesbin uglygs.pl
-
-       insinto "$(games_get_libdir)"/${PN}
-       doins -r data templates tmp
-       insinto "$(games_get_libdir)"/${PN}/images
-       doins -r images/{avp2,bds,default.gif,hls,j2s,mhs,q3s,rws,sf2s,uns,vcs}
-       dosym bds "$(games_get_libdir)"/${PN}/images/bdl
-       keepdir "$(games_get_libdir)"/${PN}/tmp
-
-       exeinto "$(games_get_libdir)"/${PN}
-       doexe qstat/qstat
-
-       dodoc CHANGES README
-
-       prepgamesdirs
-}
-
-pkg_postinst() {
-       games_pkg_postinst
-       elog "Dont forget to setup ${GAMES_SYSCONFDIR}/uglygs.conf and ${GAMES_SYSCONFDIR}/qstat.cfg"
-}