sys-apps/kexec-tools: Synced live ebuild
authorLars Wendler <polynomial-c@gentoo.org>
Fri, 12 Jul 2019 11:03:25 +0000 (13:03 +0200)
committerLars Wendler <polynomial-c@gentoo.org>
Fri, 12 Jul 2019 15:26:41 +0000 (17:26 +0200)
Package-Manager: Portage-2.3.69, Repoman-2.3.16
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
sys-apps/kexec-tools/kexec-tools-9999.ebuild

index d9c36c6dcf7bf3db813c4ec7a64a408e4aa56df9..a96230eff7951897e2552327aa97416edda2ce89 100644 (file)
@@ -1,7 +1,7 @@
 # Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
+EAPI=7
 
 inherit flag-o-matic libtool linux-info systemd
 
@@ -9,7 +9,8 @@ if [[ ${PV} == "9999" ]] ; then
        inherit git-r3 autotools
        EGIT_REPO_URI="https://git.kernel.org/pub/scm/utils/kernel/kexec/kexec-tools.git"
 else
-       SRC_URI="mirror://kernel/linux/utils/kernel/kexec/${P}.tar.xz"
+       SRC_URI="mirror://kernel/linux/utils/kernel/kexec/${P/_/-}.tar.xz"
+       [[ "${PV}" == *_rc* ]] || \
        KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
 fi
 
@@ -27,6 +28,8 @@ DEPEND="
        zlib? ( sys-libs/zlib )"
 RDEPEND="${DEPEND}"
 
+S="${WORKDIR}/${P/_/-}"
+
 CONFIG_CHECK="~KEXEC"
 
 PATCHES=(
@@ -41,7 +44,7 @@ pkg_setup() {
 
 src_prepare() {
        default
-       if [[ ${PV} == "9999" ]] ; then
+       if [[ "${PV}" == 9999 ]] ; then
                eautoreconf
        else
                elibtoolize