dev-python/mimeparse: Fix pypy3 support
authorJustin Lecher <jlec@gentoo.org>
Sun, 23 Aug 2015 18:10:57 +0000 (20:10 +0200)
committerJustin Lecher <jlec@gentoo.org>
Mon, 24 Aug 2015 10:12:05 +0000 (12:12 +0200)
Package-Manager: portage-2.2.20.1
Signed-off-by: Justin Lecher <jlec@gentoo.org>
dev-python/mimeparse/mimeparse-0.1.4-r1.ebuild

index c4966e859660bbc4107a2a78d98a3361883e3663..3a5b7118b1996f2757acf0066234e5a26af8083c 100644 (file)
@@ -30,8 +30,10 @@ python_test() {
 python_install() {
        distutils-r1_python_install
 
-       if [[ ${EPYTHON} == pypy* ]]; then
+       if [[ ${EPYTHON} == pypy ]]; then
                local pyver=2.7
+       elif [[ ${EPYTHON} == pypy3 ]]; then
+               local pyver=3.2
        else
                local pyver=${EPYTHON#python}
        fi