x11-misc/xcave: Set CFLAGS=-fcommon
authorJeroen Roovers <jer@gentoo.org>
Wed, 29 Jan 2020 11:16:47 +0000 (12:16 +0100)
committerJeroen Roovers <jer@gentoo.org>
Wed, 29 Jan 2020 11:32:06 +0000 (12:32 +0100)
Also fix pkg-config variable prefix in configure.ac:
./configure: line 1425: ac_env_libxml-2.0_CFLAGS_set=2.0_CFLAGS+set:
command not found
(etc.)

Package-Manager: Portage-2.3.86, Repoman-2.3.20
Closes: https://bugs.gentoo.org/show_bug.cgi?id=706928
Signed-off-by: Jeroen Roovers <jer@gentoo.org>
x11-misc/xcave/files/xcave-2.4.0-pkg-config.patch [new file with mode: 0644]
x11-misc/xcave/xcave-2.4.0.ebuild

diff --git a/x11-misc/xcave/files/xcave-2.4.0-pkg-config.patch b/x11-misc/xcave/files/xcave-2.4.0-pkg-config.patch
new file mode 100644 (file)
index 0000000..f0e331d
--- /dev/null
@@ -0,0 +1,13 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -49,10 +49,6 @@
+-PKG_CHECK_MODULES(libxml-2.0, libxml-2.0)
+-AC_SUBST(libxml-2.0_CFLAGS)
+-AC_SUBST(libxml-2.0_LIBS)
+-
+ AC_OUTPUT([
+ Makefile
+ src/Makefile
index 3e6245d4498d5d43070e71d8e5aaa7f1bb7a21a9..96c74893f67f83850c3215d0b232c60c0200c6e3 100644 (file)
@@ -1,7 +1,8 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
+inherit autotools flag-o-matic
 
 DESCRIPTION="View and manage contents of your wine cellar"
 HOMEPAGE="http://xcave.free.fr/index-en.php"
@@ -14,13 +15,30 @@ RESTRICT="test"
 
 RDEPEND="
        x11-libs/gtk+:2
-       dev-libs/libxml2:2"
-DEPEND="${RDEPEND}"
+       dev-libs/libxml2:2
+"
+DEPEND="
+       ${RDEPEND}
+"
 BDEPEND="
        dev-util/intltool
        sys-devel/gettext
-       virtual/pkgconfig"
+       virtual/pkgconfig
+"
+PATCHES=(
+       "${FILESDIR}"/${PN}-2.4.0-pkg-config.patch
+)
 
+src_prepare() {
+       mkdir m4 || die
+       default
+       eautoreconf
+}
+
+src_configure() {
+       append-cflags -fcommon
+       default
+}
 src_install() {
        default