games-rpg/manaplus: Bump to version 1.7.2.18
authorLars Wendler <polynomial-c@gentoo.org>
Fri, 24 Feb 2017 09:45:11 +0000 (10:45 +0100)
committerLars Wendler <polynomial-c@gentoo.org>
Fri, 24 Feb 2017 10:34:50 +0000 (11:34 +0100)
Package-Manager: Portage-2.3.3, Repoman-2.3.1

games-rpg/manaplus/Manifest
games-rpg/manaplus/manaplus-1.7.2.18.ebuild [new file with mode: 0644]

index 9e3a1625d81b8423f60a46b7cc41a43fa3fdc1b7..0cc232200a09e86a923b71da1d873d6fe0278cbd 100644 (file)
@@ -1,2 +1,3 @@
 DIST manaplus-1.7.1.21.tar.xz 14776172 SHA256 bfe25bc284a0aaf566ebad5e39434a666ec5bb53b1a8556b505296ff649a3061 SHA512 d3ebd2c4d00e6998f21a6ae40a7ae6c4988850086f70ae4d41ac894a061b8b398bc6ab54018ee8ca5a9c4c5024b8fd697190d36ba1a3f6d3cdfa19c11af74712 WHIRLPOOL 3075f4a92a8fdd2601fa7afa42889d9ec40aa3764f4ee068b15231497d93f2c6e9f3deff2e78af36f96df71a62c6392124c4712f376662a8774b2535ba3bab0f
+DIST manaplus-1.7.2.18.tar.xz 14768848 SHA256 308bd47abcc0d2d032deb2137766820288b9fff4821f38130dc8d50220234545 SHA512 424375a5e0116650bd0be205f5fe3cf6eb25782b22cef7f6a9caa8fdc4c5bab0e0323cfd8f9f8585729e2995977c1371ddab76af354dc759066d27b672a00eb1 WHIRLPOOL bcb1cffd5b9d8b86b00f5345ee94e18f812f3d54743329d30292335354e06069709b6eb7e976e74381856449b599545dc733712369a4fa4a147ef61b8cd078f4
 DIST manaplus-1.7.2.4.tar.xz 14787184 SHA256 19aea5f7e286d395918ea4bce3d1823efe1178a50e3978668461c880dd9dc105 SHA512 94dd6b5e04b0edaa9cce54c0a23ae23a7d5299b4594efb064eecdc3ed305ec8d622085deac5641f359293b300f8854bd61b693b312d7c8dbc7d124a15108412d WHIRLPOOL 148cb52d6da40b8184f3b6ffc598eba06bce8f670cf9d7e70b94a730fcb23dc5e898ba26177ce1304997fddb08953f3fb4730b5c06daacb3c3ce7171aa61bb39
diff --git a/games-rpg/manaplus/manaplus-1.7.2.18.ebuild b/games-rpg/manaplus/manaplus-1.7.2.18.ebuild
new file mode 100644 (file)
index 0000000..c3fe215
--- /dev/null
@@ -0,0 +1,99 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+[[ ${PV} == 9999 ]] && inherit autotools git-r3
+
+DESCRIPTION="OpenSource 2D MMORPG client for Evol Online and The Mana World"
+HOMEPAGE="http://manaplus.evolonline.org"
+if [[ ${PV} == 9999 ]] ; then
+       EGIT_REPO_URI="https://github.com/ManaPlus/ManaPlus.git"
+else
+       SRC_URI="http://download.evolonline.org/manaplus/download/${PV}/${P}.tar.xz"
+       KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="mumble nls opengl pugixml +sdl2 test"
+
+RDEPEND="
+       >=dev-games/physfs-1.0.0
+       media-fonts/dejavu
+       media-fonts/liberation-fonts
+       media-fonts/mplus-outline-fonts
+       media-fonts/wqy-microhei
+       media-libs/libpng:0=
+       net-misc/curl
+       sys-libs/zlib
+       x11-apps/xmessage
+       x11-libs/libX11
+       x11-misc/xdg-utils
+       mumble? ( media-sound/mumble )
+       nls? ( virtual/libintl )
+       opengl? ( virtual/opengl )
+       pugixml? ( dev-libs/pugixml )
+       !pugixml? ( dev-libs/libxml2 )
+       sdl2? (
+               media-libs/libsdl2[X,opengl?,video]
+               media-libs/sdl2-gfx
+               media-libs/sdl2-image[png]
+               media-libs/sdl2-mixer[vorbis]
+               media-libs/sdl2-net
+               media-libs/sdl2-ttf
+       )
+       !sdl2? (
+               media-libs/libsdl[X,opengl?,video]
+               media-libs/sdl-gfx
+               media-libs/sdl-image[png]
+               media-libs/sdl-mixer[vorbis]
+               media-libs/sdl-net
+               media-libs/sdl-ttf
+       )"
+DEPEND="${RDEPEND}
+       virtual/pkgconfig
+       nls? ( sys-devel/gettext )"
+
+src_prepare() {
+       default
+       if [[ ${PV} == 9999 ]] ; then
+               eautoreconf
+       fi
+}
+
+src_configure() {
+       CONFIG_SHELL=/bin/bash \
+       econf \
+               --localedir=/usr/share/locale \
+               --without-internalsdlgfx \
+               $(use_with mumble) \
+               $(use_enable nls) \
+               $(use_with opengl) \
+               --enable-libxml=$(usex pugixml pugixml libxml) \
+               $(use_with sdl2) \
+               $(use_enable test unittests)
+}
+
+src_install() {
+       default
+
+       local destpath="/usr/share/${PN}"
+       dosym /usr/share/fonts/dejavu/DejaVuSans-Bold.ttf "${destpath}"/data/fonts/dejavusans-bold.ttf
+       dosym /usr/share/fonts/dejavu/DejaVuSans.ttf "${destpath}"/data/fonts/dejavusans.ttf
+       dosym /usr/share/fonts/dejavu/DejaVuSansMono-Bold.ttf "${destpath}"/data/fonts/dejavusansmono-bold.ttf
+       dosym /usr/share/fonts/dejavu/DejaVuSansMono.ttf "${destpath}"/data/fonts/dejavusansmono.ttf
+       dosym /usr/share/fonts/dejavu/DejaVuSerifCondensed-Bold.ttf "${destpath}"/data/fonts/dejavuserifcondensed-bold.ttf
+       dosym /usr/share/fonts/dejavu/DejaVuSerifCondensed.ttf "${destpath}"/data/fonts/dejavuserifcondensed.ttf
+       dosym /usr/share/fonts/liberation-fonts/LiberationMono-Bold.ttf "${destpath}"/data/fonts/liberationsansmono-bold.ttf
+       dosym /usr/share/fonts/liberation-fonts/LiberationMono-Regular.ttf "${destpath}"/data/fonts/liberationsansmono.ttf
+       dosym /usr/share/fonts/liberation-fonts/LiberationSans-Bold.ttf "${destpath}"/data/fonts/liberationsans-bold.ttf
+       dosym /usr/share/fonts/liberation-fonts/LiberationSans-Regular.ttf "${destpath}"/data/fonts/liberationsans.ttf
+       dosym /usr/share/fonts/mplus-outline-fonts/mplus-1p-bold.ttf "${destpath}"/data/fonts/mplus-1p-bold.ttf
+       dosym /usr/share/fonts/mplus-outline-fonts/mplus-1p-regular.ttf "${destpath}"/data/fonts/mplus-1p-regular.ttf
+       dosym /usr/share/fonts/wqy-microhei/wqy-microhei.ttc "${destpath}"/data/fonts/wqy-microhei.ttf
+}
+
+src_test() {
+       make check
+}