closing #24762
authorDaniel Ahlberg <aliz@gentoo.org>
Mon, 13 Oct 2003 15:11:43 +0000 (15:11 +0000)
committerDaniel Ahlberg <aliz@gentoo.org>
Mon, 13 Oct 2003 15:11:43 +0000 (15:11 +0000)
app-shells/bash/Manifest
app-shells/bash/bash-2.05b-r8.ebuild [new file with mode: 0644]
app-shells/bash/files/digest-bash-2.05b-r8 [new file with mode: 0644]

index fa51643f90b1362c0f7c838019e533841a8ab15b..da2ca14586f52a9dc4ff24621bf012a60feaef15 100644 (file)
@@ -1,11 +1,11 @@
-MD5 ce18093e99298be51c737d3ea264dfc3 ChangeLog 5783
+MD5 b91a1cfb3034982be4c1142498bf8f29 ChangeLog 5925
 MD5 7788484f5384e08b5a7fd93fd79bfc58 bash-2.05a-r3.ebuild 1903
 MD5 7a604a7af0a8fa85c591aa394bf5d5df bash-2.05b-r3.ebuild 1743
 MD5 e56d41ca654c42349b80a107aa2525f5 bash-2.05b-r4.ebuild 1851
 MD5 77e35f69ed898e2b8c4981dc8f9feaad bash-2.05b-r5.ebuild 2033
 MD5 1fe3ae8adb7ef006f5b507fa2639ca8f bash-2.05b-r6.ebuild 2028
 MD5 385cd277d2648c490e7da4fc40b4b3ed bash-2.05b-r7.ebuild 2130
-MD5 fa27e5be9a241d17348f626e2f6b9d7e bash-2.05b-r8.ebuild 2180
+MD5 fce018352cad37f263e220489fe140d0 bash-2.05b-r8.ebuild 2182
 MD5 582fb9ed0ca44627978ce6836a5000dc files/config-top.h.diff 487
 MD5 555c6b4000bd9d5557f5627530e13ec4 files/digest-bash-2.05a-r3 63
 MD5 867b3b11e48acac6d09794c8d36cb204 files/digest-bash-2.05b-r3 296
diff --git a/app-shells/bash/bash-2.05b-r8.ebuild b/app-shells/bash/bash-2.05b-r8.ebuild
new file mode 100644 (file)
index 0000000..93bf941
--- /dev/null
@@ -0,0 +1,91 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-2.05b-r8.ebuild,v 1.1 2003/10/13 15:11:39 aliz Exp $
+
+inherit eutils flag-o-matic
+
+# Official patches
+PLEVEL="x002 x003 x004 x005 x006 x007"
+
+DESCRIPTION="The standard GNU Bourne again shell"
+SRC_URI="mirror://gnu/bash/${P}.tar.gz
+       mirror://gentoo/${P}-gentoo.diff.bz2
+       ${PLEVEL//x/mirror://gnu/bash/bash-${PV}-patches/bash${PV/\.}-}"
+HOMEPAGE="http://www.gnu.org/software/bash/bash.html"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~alpha ~ppc ~sparc ~ia64 ~mips"
+IUSE="nls build"
+
+DEPEND=">=sys-libs/ncurses-5.2-r2"
+
+src_unpack() {
+       unpack ${P}.tar.gz
+
+       cd ${S}
+       epatch ${DISTDIR}/${P}-gentoo.diff.bz2
+
+       for x in ${PLEVEL//x}
+       do
+               epatch ${DISTDIR}/${PN}${PV/\.}-${x}
+       done
+
+       # Remove autoconf dependency
+       sed -i -e "/&& autoconf/d" Makefile.in
+
+       # Readline is slow with multibyte locale, bug #19762
+       epatch ${FILESDIR}/${P}-multibyte-locale.patch
+       # Segfault on empty herestring
+       epatch ${FILESDIR}/${P}-empty-herestring.patch
+       # fix broken rbash functionality
+       epatch ${FILESDIR}/${P}-rbash.patch
+
+       # enable SSH_SOURCE_BASHRC (#24762)
+       sed -i "87s:^.*$:#define SSH_SOURCE_BASHRC:g" config-top.h
+}
+
+src_compile() {
+
+       filter-flags -malign-double
+
+       local myconf=""
+
+       # Always use the buildin readline, else if we update readline
+       # bash gets borked as readline is usually not binary compadible
+       # between minor versions.
+       #
+       # Martin Schlemmer <azarah@gentoo.org> (1 Sep 2002)
+       #use readline && myconf="--with-installed-readline"
+       #use static && export LDFLAGS="${LDFLAGS} -static"
+       use nls || myconf="${myconf} --disable-nls"
+
+       econf \
+               --disable-profiling \
+               --with-curses \
+               --without-gnu-malloc \
+               ${myconf} || die
+
+       make || die
+}
+
+src_install() {
+       einstall || die
+
+       dodir /bin
+       mv ${D}/usr/bin/bash ${D}/bin
+       dosym bash /bin/sh
+       dosym bash /bin/rbash
+
+       use build \
+               && rm -rf ${D}/usr \
+               || ( \
+                       doman doc/*.1
+                       dodoc README NEWS AUTHORS CHANGES COMPAT COPYING Y2K
+                       dodoc doc/FAQ doc/INTRO
+
+                       ebegin "creating info symlink"
+                       dosym bash.info.gz /usr/share/info/bashref.info.gz
+                       eend $?
+       )
+}
diff --git a/app-shells/bash/files/digest-bash-2.05b-r8 b/app-shells/bash/files/digest-bash-2.05b-r8
new file mode 100644 (file)
index 0000000..cda4481
--- /dev/null
@@ -0,0 +1,8 @@
+MD5 5238251b4926d778dfe162f6ce729733 bash-2.05b.tar.gz 1956216
+MD5 acac0949285525a5920d80f2aa4668de bash-2.05b-gentoo.diff.bz2 2744
+MD5 2957bbe5f6db1830d649d1071baba63c bash205b-002 755
+MD5 2828e78563927b806246e2b4806ee0f5 bash205b-003 2356
+MD5 6bf89831209ba6d208943d2ebaa7fe3a bash205b-004 1110
+MD5 311b7f0e3dabec51767bfabe6afd4ded bash205b-005 2217
+MD5 f8a86d0a66b51080f3fbc5cc34ef1a06 bash205b-006 3155
+MD5 37d2acecc9146883f9b331c03b274f21 bash205b-007 1072