acct-user/tox: new package
authorJosiah Mullins <jomull01@protonmail.com>
Sat, 19 Oct 2019 01:50:27 +0000 (21:50 -0400)
committerJoonas Niilola <juippis@gentoo.org>
Mon, 4 Nov 2019 06:07:41 +0000 (08:07 +0200)
This commit will add a package that will allow net-libs/tox
to be compliant with GLEP 81.

Signed-off-by: Josiah Mullins <JoMull01@protonmail.com>
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
acct-user/tox/metadata.xml [new file with mode: 0644]
acct-user/tox/tox-0.ebuild [new file with mode: 0644]

diff --git a/acct-user/tox/metadata.xml b/acct-user/tox/metadata.xml
new file mode 100644 (file)
index 0000000..5dbf5fa
--- /dev/null
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="person">
+               <email>JoMull01@protonmail.com</email>
+               <name>Josiah Mullins</name>
+       </maintainer>
+       <maintainer type="project">
+               <email>proxy-maint@gentoo.org</email>
+               <name>Proxy Maintainers</name>
+       </maintainer>
+</pkgmetadata>
diff --git a/acct-user/tox/tox-0.ebuild b/acct-user/tox/tox-0.ebuild
new file mode 100644 (file)
index 0000000..3567858
--- /dev/null
@@ -0,0 +1,13 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit acct-user
+
+DESCRIPTION="User for package net-libs/tox"
+
+ACCT_USER_ID=236 #day-month of first tox commit
+ACCT_USER_GROUPS=( tox )
+
+acct-user_add_deps