dev-perl/Alien-SDL: -r bump for EAPI7
authorKent Fredric <kentnl@gentoo.org>
Thu, 23 Apr 2020 16:23:20 +0000 (04:23 +1200)
committerKent Fredric <kentnl@gentoo.org>
Thu, 23 Apr 2020 16:24:41 +0000 (04:24 +1200)
Also has to fix bug #719074 as EAPI7-ification adds .packlist to
the install, which breaks subsequent reinstalls due to misguided "nuke
existing share dir" logic targeted at CPAN.

And although this issue is fixed for -r1, attempts to downgrade to -r0
will rexperience this bug, even though -r0 didn't typically have the
problem on self-reinstallation ... due to not shipping the .packlist
due to EAPI < 6

A true downgrade requires running some kind of emerge -C operation
to remove the sharedirs, before installing the older version.

Subsequently, this issue can *only* be considered fixed once -r0 is
removed.

Bug: https://bugs.gentoo.org/719074
Package-Manager: Portage-2.3.97, Repoman-2.3.22
Signed-off-by: Kent Fredric <kentnl@gentoo.org>
dev-perl/Alien-SDL/Alien-SDL-1.446.0-r1.ebuild [new file with mode: 0644]
dev-perl/Alien-SDL/files/Alien-SDL-1.444.0-no-sysclean.patch [new file with mode: 0644]

diff --git a/dev-perl/Alien-SDL/Alien-SDL-1.446.0-r1.ebuild b/dev-perl/Alien-SDL/Alien-SDL-1.446.0-r1.ebuild
new file mode 100644 (file)
index 0000000..57808c7
--- /dev/null
@@ -0,0 +1,50 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=FROGGS
+DIST_VERSION=1.446
+inherit perl-module toolchain-funcs
+
+DESCRIPTION="building, finding and using SDL binaries"
+
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86"
+
+# File::Fetch, File::Find, Test::More -> dev-lang/perl
+RDEPEND="
+       dev-perl/Archive-Extract
+       dev-perl/Archive-Zip
+       dev-perl/Capture-Tiny
+       dev-perl/File-ShareDir
+       dev-perl/File-Which
+       dev-perl/Text-Patch
+       media-libs/libsdl
+       virtual/perl-Archive-Tar
+       virtual/perl-Digest-SHA
+       virtual/perl-ExtUtils-CBuilder
+       virtual/perl-ExtUtils-MakeMaker
+       dev-perl/Module-Build
+       virtual/perl-File-Spec
+       virtual/perl-File-Temp
+"
+DEPEND="
+       dev-perl/Module-Build
+       media-libs/libsdl
+"
+BDEPEND="${RDEPEND}"
+
+PERL_RM_FILES=(
+       t/release-pod-{syntax,coverage}.t
+)
+PATCHES=(
+       "${FILESDIR}"/${PN}-1.444.0-fix-build-option.patch
+       "${FILESDIR}"/${PN}-1.444.0-no-sysclean.patch
+)
+src_prepare() {
+       tc-export CC
+       perl-module_src_prepare
+}
+
+myconf='--with-sdl-config'
diff --git a/dev-perl/Alien-SDL/files/Alien-SDL-1.444.0-no-sysclean.patch b/dev-perl/Alien-SDL/files/Alien-SDL-1.444.0-no-sysclean.patch
new file mode 100644 (file)
index 0000000..5c4153f
--- /dev/null
@@ -0,0 +1,33 @@
+From 8d36c877d2528cb8634219949730767b0e6e5150 Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentnl@gentoo.org>
+Date: Fri, 24 Apr 2020 03:44:51 +1200
+Subject: Remove sharedir nuking logic.
+
+This breaks install on Gentoo, as it tries to remove the *system*
+share_dir *before* Gentoo gets around to things.
+
+And this code is basically redundant because Gentoo assurces cruft
+entries in share will get removed, which is not something people using
+CPAN clients can expect.
+
+https://bugs.gentoo.org/719074
+---
+ inc/My/Builder.pm | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/inc/My/Builder.pm b/inc/My/Builder.pm
+index 6f5a97e..f101beb 100644
+--- a/inc/My/Builder.pm
++++ b/inc/My/Builder.pm
+@@ -47,7 +47,7 @@ sub ACTION_install
+  $sharedir = eval {File::ShareDir::dist_dir('Alien-SDL')} || '';
+- if ( -d $sharedir )
++ if ( 0 )
+  {
+    print "Removing the old $sharedir \n";
+    remove_tree($sharedir);
+-- 
+2.26.2
+