dev-java/classmate: Remove a buggy test.
authorPatrice Clement <monsieurp@gentoo.org>
Fri, 21 Aug 2015 13:11:50 +0000 (13:11 +0000)
committerPatrice Clement <monsieurp@gentoo.org>
Fri, 21 Aug 2015 13:22:39 +0000 (13:22 +0000)
Package-Manager: portage-2.2.18
Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
dev-java/classmate/classmate-0.9.0-r1.ebuild [new file with mode: 0644]

diff --git a/dev-java/classmate/classmate-0.9.0-r1.ebuild b/dev-java/classmate/classmate-0.9.0-r1.ebuild
new file mode 100644 (file)
index 0000000..60a636f
--- /dev/null
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+JAVA_PKG_IUSE="doc source test"
+
+inherit java-pkg-2 java-pkg-simple vcs-snapshot
+
+DESCRIPTION="Library for introspecting generic type information of types, member/static methods, fields"
+HOMEPAGE="https://github.com/cowtowncoder/java-classmate/"
+SRC_URI="https://github.com/cowtowncoder/java-classmate/archive/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE=""
+
+RDEPEND=">=virtual/jre-1.6"
+DEPEND=">=virtual/jdk-1.6
+       test? ( dev-java/junit:4 )"
+
+S="${WORKDIR}/${P}"
+
+JAVA_SRC_DIR="src/main/java"
+
+# This one test is buggy.
+JAVA_RM_FILES=(
+       src/test/java/com/fasterxml/classmate/AnnotationsTest.java
+)
+
+java_prepare() {
+       rm pom.xml || die
+}
+
+src_test() {
+       testcp="${S}/${PN}.jar:$(java-pkg_getjars junit-4):target/tests"
+
+       mkdir target/tests || die
+       ejavac -cp "${testcp}" -d target/tests $(find src/test/java -name "*.java")
+
+       tests=$(find target/tests -name "*Test.class" -not -name "BaseTest.class" \
+                       | sed -e 's/target\/tests\///g' -e "s/\.class//" -e "s/\//./g" \
+                       | grep -vP '\$');
+       ejunit4 -cp "${testcp}" ${tests}
+}