dev-util/catalyst: Version bump to 3.0.10
authorMatt Turner <mattst88@gentoo.org>
Sun, 17 May 2020 18:30:38 +0000 (11:30 -0700)
committerMatt Turner <mattst88@gentoo.org>
Sun, 17 May 2020 18:34:21 +0000 (11:34 -0700)
Signed-off-by: Matt Turner <mattst88@gentoo.org>
dev-util/catalyst/Manifest
dev-util/catalyst/catalyst-3.0.10.ebuild [new file with mode: 0644]

index df39280f7ad555bee10126fbb5fb3715142232c4..5d0be8ceac235e8c017fa6fd19164649c2cebf4c 100644 (file)
@@ -1 +1,2 @@
+DIST catalyst-3.0.10.tar.bz2 621118 BLAKE2B 07c7d79400aad81db60034685bed31c4e3d13bb45cd89689e4e3328c14573a1b824fd13310a14bdef8e638df2374c967520ae919d347e8a8a89059038436e28a SHA512 480377ff8e774484bfbcc223b2bcf3b80641772363c08f80431db9840129a83abb2a69228d681c71dad7395462733ab3c15542bc456d7b92bbf68bb3c97f999a
 DIST catalyst-3.0.9.tar.bz2 873866 BLAKE2B 293a4d52c57e73269f1f82fed8ea72934a0f939b3b9d4fb9943f4971fd4155edecc6cf0170b917eba16f0125aac9861041b7e10f85f6110a35659a2f85fd3665 SHA512 c8c25ad1c76b0040bd84b491909d364306746c660afbbb8c6a074911779aabe89b60a12cc3ac5b9cd3398bdf8986b50d24d9979c3d12d2fa9de66ebf62ded309
diff --git a/dev-util/catalyst/catalyst-3.0.10.ebuild b/dev-util/catalyst/catalyst-3.0.10.ebuild
new file mode 100644 (file)
index 0000000..644bdda
--- /dev/null
@@ -0,0 +1,69 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+if [[ ${PV} == *9999* ]]; then
+       SRC_ECLASS="git-r3"
+       EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/catalyst.git"
+       EGIT_BRANCH="master"
+else
+       SRC_URI="https://gitweb.gentoo.org/proj/catalyst.git/snapshot/${P}.tar.bz2"
+       KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+fi
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=no
+
+inherit distutils-r1 ${SRC_ECLASS}
+
+DESCRIPTION="Release metatool used for creating releases based on Gentoo Linux"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Catalyst"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="ccache doc +iso kernel_linux system-bootloader"
+
+DEPEND="
+       app-text/asciidoc
+       >=dev-python/snakeoil-0.6.5[${PYTHON_USEDEP}]
+"
+RDEPEND="
+       >=dev-python/snakeoil-0.6.5[${PYTHON_USEDEP}]
+       >=dev-python/pydecomp-0.3[${PYTHON_USEDEP}]
+       app-arch/lbzip2
+       app-crypt/shash
+       sys-fs/dosfstools
+       !kernel_FreeBSD? ( || ( app-arch/tar[xattr] app-arch/libarchive[xattr] ) )
+       kernel_FreeBSD? ( app-arch/libarchive[xattr] )
+       amd64? ( >=sys-boot/syslinux-3.72 )
+       x86? ( >=sys-boot/syslinux-3.72 )
+       ccache? ( dev-util/ccache )
+       iso? ( virtual/cdrtools )
+       kernel_linux? ( app-misc/zisofs-tools >=sys-fs/squashfs-tools-2.1 )
+"
+PDEPEND="system-bootloader? ( >=sys-apps/memtest86+-5.01-r4
+                               sys-boot/grub:2
+                               amd64? ( sys-boot/grub[grub_platforms_efi-32,grub_platforms_efi-64] )
+                               x86? ( sys-boot/grub[grub_platforms_efi-32] )
+                               sys-boot/syslinux
+                               sys-boot/shim )"
+
+python_prepare_all() {
+       python_setup
+       echo VERSION="${PV}" "${PYTHON}" setup.py set_version
+       VERSION="${PV}" "${PYTHON}" setup.py set_version || die
+       distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+       # build the man pages and docs
+       emake
+}
+
+python_install_all() {
+       distutils-r1_python_install_all
+       if use doc; then
+               dodoc files/HOWTO.html files/docbook-xsl.css
+       fi
+}