dev-python/pyserial: Enable py3.8
authorMichał Górny <mgorny@gentoo.org>
Fri, 22 Nov 2019 09:03:43 +0000 (10:03 +0100)
committerMichał Górny <mgorny@gentoo.org>
Fri, 22 Nov 2019 09:35:05 +0000 (10:35 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/pyserial/pyserial-3.4.ebuild

index 42b285e7b1785c0d791a2e9824ef38123b81b335..789422e120235d6c13bbd072bc71ea43f2283f7c 100644 (file)
@@ -2,7 +2,7 @@
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy )
+PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} pypy )
 
 inherit distutils-r1
 
@@ -17,7 +17,7 @@ IUSE="doc examples"
 
 DEPEND="
        dev-python/setuptools[${PYTHON_USEDEP}]
-       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+       doc? ( dev-python/sphinx )
 "
 
 # Usual avoid d'loading un-needed objects.inv file
@@ -30,15 +30,14 @@ python_compile_all() {
 }
 
 python_test() {
-       ${EPYTHON} test/run_all_tests.py || die "Testing failed with ${EPYTHON}"
+       "${EPYTHON}" test/run_all_tests.py loop:// -v || die "Testing failed with ${EPYTHON}"
 }
 
 python_install_all() {
        use doc && local HTML_DOCS=( documentation/_build/html/. )
        distutils-r1_python_install_all
        if use examples; then
-               insinto /usr/share/doc/${PF}
-               doins -r examples
+               dodoc -r examples
                docompress -x /usr/share/doc/${PF}/examples
        fi
 }