Update snapshots.
authorMike Frysinger <vapier@gentoo.org>
Tue, 12 Dec 2006 03:46:22 +0000 (03:46 +0000)
committerMike Frysinger <vapier@gentoo.org>
Tue, 12 Dec 2006 03:46:22 +0000 (03:46 +0000)
Package-Manager: portage-2.1.2_rc3

sys-devel/gcc/ChangeLog
sys-devel/gcc/files/digest-gcc-4.1.0_alpha20061208 [new file with mode: 0644]
sys-devel/gcc/files/digest-gcc-4.2.0_alpha20061205 [new file with mode: 0644]
sys-devel/gcc/files/digest-gcc-4.3.0_alpha20061209 [new file with mode: 0644]
sys-devel/gcc/gcc-4.1.0_alpha20061208.ebuild [new file with mode: 0644]
sys-devel/gcc/gcc-4.2.0_alpha20061205.ebuild [new file with mode: 0644]
sys-devel/gcc/gcc-4.3.0_alpha20061209.ebuild [new file with mode: 0644]

index 8b82adbfd7d169d3a2cc9c331ba7cac5383fb5da..f9b9ffeb1effe921d0f1b2da3c030e247d117057 100644 (file)
@@ -1,6 +1,16 @@
 # ChangeLog for sys-devel/gcc
 # Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.590 2006/12/10 21:27:50 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.591 2006/12/12 03:46:21 vapier Exp $
+
+*gcc-4.3.0_alpha20061209 (11 Dec 2006)
+*gcc-4.2.0_alpha20061205 (11 Dec 2006)
+*gcc-4.1.0_alpha20061208 (11 Dec 2006)
+
+  11 Dec 2006; Mike Frysinger <vapier@gentoo.org>
+  -gcc-4.1.0_alpha20061110.ebuild, +gcc-4.1.0_alpha20061208.ebuild,
+  -gcc-4.2.0_alpha20061107.ebuild, +gcc-4.2.0_alpha20061205.ebuild,
+  -gcc-4.3.0_alpha20061111.ebuild, +gcc-4.3.0_alpha20061209.ebuild:
+  Update snapshots.
 
   10 Dec 2006; Bryan Ã˜stergaard <kloeri@gentoo.org> gcc-4.1.1-r1.ebuild,
   gcc-4.1.1-r3.ebuild:
diff --git a/sys-devel/gcc/files/digest-gcc-4.1.0_alpha20061208 b/sys-devel/gcc/files/digest-gcc-4.1.0_alpha20061208
new file mode 100644 (file)
index 0000000..6d60cf2
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 262a3a0a31e2c172fbc22afd09dcaf30 gcc-4.1-20061208.tar.bz2 37282125
+RMD160 d5ee2f8728031380c4ae4967022c7861b6a4b99b gcc-4.1-20061208.tar.bz2 37282125
+SHA256 73880b99e3c245d7953fd72988397c2c6a53be16ef798a75bd62c7ded818bee5 gcc-4.1-20061208.tar.bz2 37282125
diff --git a/sys-devel/gcc/files/digest-gcc-4.2.0_alpha20061205 b/sys-devel/gcc/files/digest-gcc-4.2.0_alpha20061205
new file mode 100644 (file)
index 0000000..17417f9
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 048a21fc644ab9e9e7a21fc84f2c694d gcc-4.2-20061205.tar.bz2 40697459
+RMD160 a3b0a12abeaadd4dc9693a418a7f6630f1a53b46 gcc-4.2-20061205.tar.bz2 40697459
+SHA256 6dc3d92e4949c878b4e821612b558befb1d848367d525528551217c5b3eaccad gcc-4.2-20061205.tar.bz2 40697459
diff --git a/sys-devel/gcc/files/digest-gcc-4.3.0_alpha20061209 b/sys-devel/gcc/files/digest-gcc-4.3.0_alpha20061209
new file mode 100644 (file)
index 0000000..ee30242
--- /dev/null
@@ -0,0 +1,6 @@
+MD5 013625763694f2401761e1c1361359ed gcc-4.3-20061209.tar.bz2 41209354
+RMD160 cc3459d1672b0265a71c99673d1bb03b119b439a gcc-4.3-20061209.tar.bz2 41209354
+SHA256 35da3f52fb9c2a0a7e657c5209daea6b6f87d5c03a5cb44de67414a34d7fd338 gcc-4.3-20061209.tar.bz2 41209354
+MD5 b3499208a59a7e18e72a88506d2fa862 gcc-4.3.0-patches-0.2.tar.bz2 92870
+RMD160 4f6d6fea589eb87939ca51cc2f361c7eae9ec357 gcc-4.3.0-patches-0.2.tar.bz2 92870
+SHA256 27b88363fd803c985c6c2b3d259781b98f47713757cc220a734e9d477fd72782 gcc-4.3.0-patches-0.2.tar.bz2 92870
diff --git a/sys-devel/gcc/gcc-4.1.0_alpha20061208.ebuild b/sys-devel/gcc/gcc-4.1.0_alpha20061208.ebuild
new file mode 100644 (file)
index 0000000..5e9ac64
--- /dev/null
@@ -0,0 +1,64 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.1.0_alpha20061208.ebuild,v 1.1 2006/12/12 03:46:21 vapier Exp $
+
+ETYPE="gcc-compiler"
+
+inherit toolchain
+
+DESCRIPTION="The GNU Compiler Collection.  Includes C/C++, java compilers, pie+ssp extensions, Haj Ten Brugge runtime bounds checking"
+
+LICENSE="GPL-2 LGPL-2.1"
+KEYWORDS="-*"
+
+RDEPEND=">=sys-libs/zlib-1.1.4
+       || ( >=sys-devel/gcc-config-1.3.12-r4 app-admin/eselect-compiler )
+       virtual/libiconv
+       fortran? (
+               >=dev-libs/gmp-4.2.1
+               >=dev-libs/mpfr-2.2.0_p10
+       )
+       !build? (
+               gcj? (
+                       gtk? (
+                               || ( ( x11-libs/libXt x11-libs/libX11 x11-libs/libXtst x11-proto/xproto x11-proto/xextproto ) virtual/x11 )
+                               >=x11-libs/gtk+-2.2
+                               x11-libs/pango
+                       )
+                       >=media-libs/libart_lgpl-2.1
+               )
+               >=sys-libs/ncurses-5.2-r2
+               nls? ( sys-devel/gettext )
+       )"
+DEPEND="${RDEPEND}
+       >=sys-apps/texinfo-4.2-r4
+       >=sys-devel/bison-1.875
+       >=${CATEGORY}/binutils-2.16.1"
+PDEPEND="|| ( sys-devel/gcc-config app-admin/eselect-compiler )"
+if [[ ${CATEGORY} != cross-* ]] ; then
+       PDEPEND="${PDEPEND} elibc_glibc? ( >=sys-libs/glibc-2.3.6 )"
+fi
+
+pkg_setup() {
+       if [[ -z ${I_PROMISE_TO_SUPPLY_PATCHES_WITH_BUGS} ]] ; then
+               die "Please \`export I_PROMISE_TO_SUPPLY_PATCHES_WITH_BUGS=1\` or define it in your make.conf if you want to use this ebuild.  This is to try and cut down on people filing bugs for a compiler we do not currently support."
+       fi
+}
+
+src_unpack() {
+       gcc_src_unpack
+
+       use vanilla && return 0
+
+       # Fix cross-compiling
+       epatch "${FILESDIR}"/4.1.0/gcc-4.1.0-cross-compile.patch
+}
+
+pkg_postinst() {
+       toolchain_pkg_postinst
+
+       einfo "This gcc-4 ebuild is provided for your convenience, and the use"
+       einfo "of this compiler is not supported by the Gentoo Developers."
+       einfo "Please file bugs related to gcc-4 with upstream developers."
+       einfo "Compiler bugs should be filed at http://gcc.gnu.org/bugzilla/"
+}
diff --git a/sys-devel/gcc/gcc-4.2.0_alpha20061205.ebuild b/sys-devel/gcc/gcc-4.2.0_alpha20061205.ebuild
new file mode 100644 (file)
index 0000000..b51b109
--- /dev/null
@@ -0,0 +1,64 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.2.0_alpha20061205.ebuild,v 1.1 2006/12/12 03:46:21 vapier Exp $
+
+ETYPE="gcc-compiler"
+
+inherit toolchain
+
+DESCRIPTION="The GNU Compiler Collection.  Includes C/C++, java compilers, pie+ssp extensions, Haj Ten Brugge runtime bounds checking"
+
+LICENSE="GPL-2 LGPL-2.1"
+KEYWORDS="-*"
+
+RDEPEND=">=sys-libs/zlib-1.1.4
+       || ( >=sys-devel/gcc-config-1.3.12-r4 app-admin/eselect-compiler )
+       virtual/libiconv
+       fortran? (
+               >=dev-libs/gmp-4.2.1
+               >=dev-libs/mpfr-2.2.0_p10
+       )
+       !build? (
+               gcj? (
+                       gtk? (
+                               || ( ( x11-libs/libXt x11-libs/libX11 x11-libs/libXtst x11-proto/xproto x11-proto/xextproto ) virtual/x11 )
+                               >=x11-libs/gtk+-2.2
+                               x11-libs/pango
+                       )
+                       >=media-libs/libart_lgpl-2.1
+               )
+               >=sys-libs/ncurses-5.2-r2
+               nls? ( sys-devel/gettext )
+       )"
+DEPEND="${RDEPEND}
+       >=sys-apps/texinfo-4.2-r4
+       >=sys-devel/bison-1.875
+       >=${CATEGORY}/binutils-2.16.1"
+PDEPEND="|| ( sys-devel/gcc-config app-admin/eselect-compiler )"
+if [[ ${CATEGORY} != cross-* ]] ; then
+       PDEPEND="${PDEPEND} elibc_glibc? ( >=sys-libs/glibc-2.3.6 )"
+fi
+
+pkg_setup() {
+       if [[ -z ${I_PROMISE_TO_SUPPLY_PATCHES_WITH_BUGS} ]] ; then
+               die "Please \`export I_PROMISE_TO_SUPPLY_PATCHES_WITH_BUGS=1\` or define it in your make.conf if you want to use this ebuild.  This is to try and cut down on people filing bugs for a compiler we do not currently support."
+       fi
+}
+
+src_unpack() {
+       gcc_src_unpack
+
+       use vanilla && return 0
+
+       # Fix cross-compiling
+       epatch "${FILESDIR}"/4.1.0/gcc-4.1.0-cross-compile.patch
+}
+
+pkg_postinst() {
+       toolchain_pkg_postinst
+
+       einfo "This gcc-4 ebuild is provided for your convenience, and the use"
+       einfo "of this compiler is not supported by the Gentoo Developers."
+       einfo "Please file bugs related to gcc-4 with upstream developers."
+       einfo "Compiler bugs should be filed at http://gcc.gnu.org/bugzilla/"
+}
diff --git a/sys-devel/gcc/gcc-4.3.0_alpha20061209.ebuild b/sys-devel/gcc/gcc-4.3.0_alpha20061209.ebuild
new file mode 100644 (file)
index 0000000..5bafcb0
--- /dev/null
@@ -0,0 +1,62 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.3.0_alpha20061209.ebuild,v 1.1 2006/12/12 03:46:21 vapier Exp $
+
+ETYPE="gcc-compiler"
+PATCH_VER="0.2"
+inherit toolchain
+
+DESCRIPTION="The GNU Compiler Collection.  Includes C/C++, java compilers, pie+ssp extensions, Haj Ten Brugge runtime bounds checking"
+
+LICENSE="GPL-2 LGPL-2.1"
+KEYWORDS="-*"
+
+RDEPEND=">=sys-libs/zlib-1.1.4
+       || ( >=sys-devel/gcc-config-1.3.12-r4 app-admin/eselect-compiler )
+       virtual/libiconv
+       >=dev-libs/gmp-4.2.1
+       >=dev-libs/mpfr-2.2.0_p10
+       !build? (
+               gcj? (
+                       gtk? (
+                               || ( ( x11-libs/libXt x11-libs/libX11 x11-libs/libXtst x11-proto/xproto x11-proto/xextproto ) virtual/x11 )
+                               >=x11-libs/gtk+-2.2
+                               x11-libs/pango
+                       )
+                       >=media-libs/libart_lgpl-2.1
+               )
+               >=sys-libs/ncurses-5.2-r2
+               nls? ( sys-devel/gettext )
+       )"
+DEPEND="${RDEPEND}
+       >=sys-apps/texinfo-4.2-r4
+       >=sys-devel/bison-1.875
+       >=${CATEGORY}/binutils-2.16.1"
+PDEPEND="|| ( sys-devel/gcc-config app-admin/eselect-compiler )"
+if [[ ${CATEGORY} != cross-* ]] ; then
+       PDEPEND="${PDEPEND} elibc_glibc? ( >=sys-libs/glibc-2.3.6 )"
+fi
+
+pkg_setup() {
+       if [[ -z ${I_PROMISE_TO_SUPPLY_PATCHES_WITH_BUGS} ]] ; then
+               die "Please \`export I_PROMISE_TO_SUPPLY_PATCHES_WITH_BUGS=1\` or define it in your make.conf if you want to use this ebuild.  This is to try and cut down on people filing bugs for a compiler we do not currently support."
+       fi
+}
+
+src_unpack() {
+       gcc_src_unpack
+
+       use vanilla && return 0
+
+       # Fix cross-compiling
+       epatch "${FILESDIR}"/4.1.0/gcc-4.1.0-cross-compile.patch
+}
+
+pkg_postinst() {
+       toolchain_pkg_postinst
+
+       einfo "This gcc-4 ebuild is provided for your convenience, and the use"
+       einfo "of this compiler is not supported by the Gentoo Developers."
+       einfo "Please file bugs related to gcc-4 with upstream developers."
+       einfo "Compiler bugs should be filed at http://gcc.gnu.org/bugzilla/"
+}