dev-python/flask-login: Remove redundant versions
authorMichał Górny <mgorny@gentoo.org>
Fri, 27 Mar 2020 09:09:20 +0000 (10:09 +0100)
committerMichał Górny <mgorny@gentoo.org>
Fri, 27 Mar 2020 09:16:12 +0000 (10:16 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/flask-login/Manifest
dev-python/flask-login/flask-login-0.3.2-r1.ebuild [deleted file]

index a4e53a25ebdbbea4a190cb1813b7bb16220ba551..73cb1233ee6a2e254dd6295db8de93bbd901c358 100644 (file)
@@ -1,2 +1 @@
-DIST flask-login-0.3.2.tar.gz 38626 BLAKE2B fbcac55e4a8dc5fe78b4b5b3cb8acbe7293bfcc30ce5323ebe992c92407238198d34724179ac12e688875356e54f85f21a2870249ccafb48499df3880a6c2062 SHA512 c42af6ed7902145cc4778815f247ed88de6df7c929abe0a1f22aca0515495a54d298b2af2b74ba7d5e0ce9b453eee4c4ce03802a3e9ab531137e117e9dcdfc1b
 DIST flask-login-0.4.1.tar.gz 43679 BLAKE2B f30df1cc84289bc2dd1e59a30284d7152cee0731daf8b6e58b8203007c0ba74eb512bf9f2e41608d9656138038f5b5c752509ef5a203ef1e8bdba9182912b133 SHA512 c87a2948ac37439ddd76f3f11584bdd5910cb00e96a7400343cf4dadc5a0f9bc84d40bdc068d2e8c05bd5a510046e18473e9ad71502c5039a5f05b371ce9bb4c
diff --git a/dev-python/flask-login/flask-login-0.3.2-r1.ebuild b/dev-python/flask-login/flask-login-0.3.2-r1.ebuild
deleted file mode 100644 (file)
index 25d605f..0000000
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="Login session support for Flask"
-HOMEPAGE="https://pypi.org/project/Flask-Login/"
-SRC_URI="https://github.com/maxcountryman/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-# pypi tarball is missing tests
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND=">=dev-python/flask-0.10[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       test? (
-               dev-python/nose[${PYTHON_USEDEP}]
-               dev-python/mock[${PYTHON_USEDEP}]
-               dev-python/blinker[${PYTHON_USEDEP}]
-       )"
-
-PATCHES=( "${FILESDIR}/${P}-fix-tests-python2.patch" )
-
-python_test() {
-       nosetests -v || die "Tests fail with ${EPYTHON}"
-}