dev-python/lxml: pull cython[pypy3]
authorJan Ziak <0xe2.0x9a.0x9b@gmail.com>
Wed, 29 Jan 2020 13:45:12 +0000 (14:45 +0100)
committerMichał Górny <mgorny@gentoo.org>
Wed, 29 Jan 2020 14:58:46 +0000 (15:58 +0100)
Building lxml with pypy3 compatibility requires the pypy3 version of cython.

Signed-off-by: Jan Ziak <0xe2.0x9a.0x9b@gmail.com>
Closes: https://github.com/gentoo/gentoo/pull/14497
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/lxml/lxml-4.4.2.ebuild
dev-python/lxml/lxml-4.4.3.ebuild

index 494b32823d6a2d1149b43044ac0acdd37a8fd639..a1977b72205aaee57217219483fd6d057cab7a68 100644 (file)
@@ -24,7 +24,7 @@ RDEPEND="
 DEPEND="${RDEPEND}"
 BDEPEND="
        virtual/pkgconfig
-       $(python_gen_cond_dep 'dev-python/cython[${PYTHON_USEDEP}]' python2_7 'python3*')
+       dev-python/cython[${PYTHON_USEDEP}]
        dev-python/setuptools[${PYTHON_USEDEP}]
        test? ( dev-python/cssselect[${PYTHON_USEDEP}] )
        "
index 831078984924edc8aca8bebca712d72d1b9b7fab..8e5f5c5c54825960b0f25b3a00b642f20cb506ed 100644 (file)
@@ -25,7 +25,7 @@ RDEPEND="
 DEPEND="${RDEPEND}"
 BDEPEND="
        virtual/pkgconfig
-       $(python_gen_cond_dep 'dev-python/cython[${PYTHON_USEDEP}]' python2_7 'python3*')
+       dev-python/cython[${PYTHON_USEDEP}]
        dev-python/setuptools[${PYTHON_USEDEP}]
        test? ( dev-python/cssselect[${PYTHON_USEDEP}] )
        "