sys-apps/osinfo-db-tools: bump to 1.6.0
authorMart Raudsepp <leio@gentoo.org>
Sun, 23 Feb 2020 18:02:56 +0000 (20:02 +0200)
committerMart Raudsepp <leio@gentoo.org>
Sun, 23 Feb 2020 18:09:36 +0000 (20:09 +0200)
There's a 1.7.0 out, but we were so behind that this is just a quick
bump to move us forward, with the meson port in 1.7 to be done later
with more effort.

Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Mart Raudsepp <leio@gentoo.org>
sys-apps/osinfo-db-tools/Manifest
sys-apps/osinfo-db-tools/osinfo-db-tools-1.6.0.ebuild [new file with mode: 0644]

index c00dcd60952d12adb140adc6969b015bfb0f3cb5..11b28ff50ffaae878ce5c58942c6d092f3266cbc 100644 (file)
@@ -1 +1,2 @@
 DIST osinfo-db-tools-1.4.0.tar.gz 519089 BLAKE2B 2c2e0cdbcd0a795f8deb09727b8b971748f5d0ecc08449238d3054cbd947a0f6059456d4e9feadded47cd0e0aaa87132f1bec7524a3183115dd459eca989d1b0 SHA512 f4813f948551f630cc9936986abc3ef4455647ec529b353dc4fee71f8071beeebac0a2ee1988cede92ea3635bca9bedd400ac9f275e3f5592ff50236d97cfb91
+DIST osinfo-db-tools-1.6.0.tar.gz 547189 BLAKE2B 38db3118d618d620a137b12021fbcf9caffe1e0f67252d2eb7c514d4f25969b152679f55b493bb64abc0925ff07ccea897acfd809d17d7257db2b33a690f4878 SHA512 a3bdf9d913b388b0f567a14245f57c4f1da9dae40d723f8e76096ffdae9d7a8e587ed4832e3e59c820bc01bbb2b74815b3fefd8e1f47cebd903091457fdee951
diff --git a/sys-apps/osinfo-db-tools/osinfo-db-tools-1.6.0.ebuild b/sys-apps/osinfo-db-tools/osinfo-db-tools-1.6.0.ebuild
new file mode 100644 (file)
index 0000000..e3002f6
--- /dev/null
@@ -0,0 +1,48 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit python-single-r1 gnome2
+
+DESCRIPTION="Tools for managing the osinfo database"
+HOMEPAGE="https://libosinfo.org/"
+SRC_URI="https://releases.pagure.org/libosinfo/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+REQUIRED_USE="test? ( ${PYTHON_REQUIRED_USE} )"
+RESTRICT="!test? ( test )"
+
+# Blocker on old libosinfo as osinfo-db-validate was part of it before
+RDEPEND="
+       >=dev-libs/glib-2.44:2
+       >=dev-libs/libxml2-2.6.0
+       >=app-arch/libarchive-3.0.0:=
+       dev-libs/json-glib
+       net-libs/libsoup:2.4
+       !<sys-libs/libosinfo-1.0.0
+"
+# perl dep is for pod2man (and syntax check but only in git, but configure check exists in release)
+# libxslt is checked for in configure.ac, but never used in 1.1.0
+DEPEND="${RDEPEND}
+       >=dev-libs/libxslt-1.0.0
+       virtual/pkgconfig
+       >=sys-devel/gettext-0.19.8
+       dev-lang/perl
+       test? ( ${PYTHON_DEPS}
+               $(python_gen_cond_dep '
+                       dev-python/pytest[${PYTHON_MULTI_USEDEP}]
+                       dev-python/requests[${PYTHON_MULTI_USEDEP}]
+               ')
+       )
+"
+
+pkg_setup() {
+       use test && python-single-r1_pkg_setup
+}