www-apps/mirmon: revbump with getopt fixes
authorRobin H. Johnson <robbat2@gentoo.org>
Thu, 30 Apr 2020 21:03:43 +0000 (14:03 -0700)
committerRobin H. Johnson <robbat2@gentoo.org>
Sat, 2 May 2020 22:11:14 +0000 (15:11 -0700)
Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
www-apps/mirmon/files/2.11-Fix-options.patch [new file with mode: 0644]
www-apps/mirmon/mirmon-2.11-r2.ebuild [moved from www-apps/mirmon/mirmon-2.11-r1.ebuild with 96% similarity]

diff --git a/www-apps/mirmon/files/2.11-Fix-options.patch b/www-apps/mirmon/files/2.11-Fix-options.patch
new file mode 100644 (file)
index 0000000..0e0924e
--- /dev/null
@@ -0,0 +1,34 @@
+Fix option handling.
+
+Add debug option to getopt inputs.
+Add debug option to usage output.
+Add version option to usage output.
+
+Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
+
+--- mirmon-2.11.orig/mirmon    2020-04-30 13:32:52.803951845 -0700
++++ mirmon-2.11/mirmon 2020-04-30 13:33:58.051641169 -0700
+@@ -1900,12 +1900,14 @@
+ Usage: $prog [-v] [-q] [-t timeout] [-c conf] [-get all|update|url <url>]
+ option v   : be verbose
+ option q   : be quiet
++option d   : debug output
+ option t   : set timeout ; default $TIMEOUT
+ option get : get all       : probe all sites
+            : get update    : probe a selection of the sites (see doc)
+            : get url <url> : probe some <url> (in the mirror-list).
+ option c   : configuration file ; default search :
+              ( $DEF_CNF )
++option version : display version
+ -------------------------------------------------------------------
+ Mirmon normally only reports errors and changes in the mirror list.
+ This is $VERSION.
+@@ -1924,7 +1926,7 @@
+ use Getopt::Long ;
+ Getopt::Long::config ( 'no_ignore_case' ) ;
+ my %opt = () ;
+-Usage '' unless GetOptions ( \%opt, qw(v q t=i get=s c=s version) ) ;
++Usage '' unless GetOptions ( \%opt, qw(d v q t=i get=s c=s version) ) ;
+ Usage "Arg count\n" if @ARGV > 1 ;
+ Usage "Arg count\n" if $opt{get} and $opt{get} eq 'url' and ! @ARGV ;
similarity index 96%
rename from www-apps/mirmon/mirmon-2.11-r1.ebuild
rename to www-apps/mirmon/mirmon-2.11-r2.ebuild
index 861191e74705efc11ff8bf95067cd9b98bee88e2..0d6ce1561b0e0fc786fea65fcfb4387b54df4dac 100644 (file)
@@ -23,6 +23,7 @@ RDEPEND="${DEPEND}
 
 PATCHES=(
        "${FILESDIR}/2.11-Add-ipv6-monitor-support-to-mirmon.patch"
+       "${FILESDIR}/2.11-Fix-options.patch"
 )
 
 src_install() {