net-dns/dnscrypt-proxy: version bump to 1.9.4.
authorsoredake <fdsfgs@krutt.org>
Tue, 28 Mar 2017 19:57:12 +0000 (22:57 +0300)
committerPatrice Clement <monsieurp@gentoo.org>
Sat, 8 Apr 2017 21:24:01 +0000 (23:24 +0200)
Closes: https://github.com/gentoo/gentoo/pull/4320

net-dns/dnscrypt-proxy/Manifest
net-dns/dnscrypt-proxy/dnscrypt-proxy-1.9.4.ebuild [new file with mode: 0644]
net-dns/dnscrypt-proxy/files/dnscrypt-proxy.service

index ae23f926c2ed6792916aa09263e9bdedad6077bf..abfc5a7fef276bbf77f2506acb52333390f3f77b 100644 (file)
@@ -3,3 +3,4 @@ DIST dnscrypt-proxy-1.4.3.tar.gz 1560345 SHA256 f10f10c18e25ced3c5ec5d0c4145d332
 DIST dnscrypt-proxy-1.6.0.tar.gz 1579293 SHA256 7703a41a1040fc30b19fdfbbaba36b411e66d998584b0e2fa5088f734f4f86be SHA512 1937a80ab0e6e5786b0d004fef1c007d9d8a4df335542ae6f96c1eac7739920f2ff4b469d30abac774c12a41d275c2a8bf31b5514d7af446028cedeeb3efcf02 WHIRLPOOL b24eb58bca1ff8fa55fec3836399a3ee5c66823d8b459e5f8ce7aa653454407dc3b80d7dc050b76e5c0595fc0e2d854478a6f949ef859b149f6b20e127c98274
 DIST dnscrypt-proxy-1.6.1.tar.gz 1721006 SHA256 c519012a66f3ee30be02113d1e0139be08ccd2ec45ca4102eac35be731a65340 SHA512 8d49be73e4b2fe1131349846191f54c7f212ff301a6a6c2a77505225f81b0615e968c945013e732c4fce3b6090606245ec7343fb0d6145bb10b67dd4112d2367 WHIRLPOOL ca5a1c3792728ff54ee5e3c5a8815deb1ce2e1bdd016438ad0b84d89458064e0178df3c1dee77c8a685894092e48a305b521dc8e4bfc3cb40a0d7ac7e7e66d18
 DIST dnscrypt-proxy-1.7.0.tar.gz 1714401 SHA256 be9827f66401f38fd4bdb372046eff9b5802ab5f3d188878a0dcd7bd20074c09 SHA512 611d9cd9d9c086ec8e2b60f6c574451eae71ea07de85973049be7090cfbd8bf790d41f8a4a2b39d74091fba7091551967b93b85a8661c03ecad43d868df597a3 WHIRLPOOL 0c3902bfcc3571175f0f8638327cbaf5eada512565f214232732d14dc6a83f55a0babedd68007cbaeec1b584bcb1d3cc621df8b07638bacfe5893c6222d12997
+DIST dnscrypt-proxy-1.9.4.tar.gz 1660333 SHA256 40543efbcd56033ac03a1edf4581305e8c9bed4579ac55e6279644f07c315307 SHA512 b19103dc39655f199c85ec69daab949d07adc12e64411d2323308afb398e6ac6563bbc17f2e317bfe1e6c95c810487d8d62da3f4c7f7257bdcf837cd0390bfb0 WHIRLPOOL 4e9494c2765ecf9d625f7b44c0f58c40e491e1334a58552111730ecd3b95cba10667b2bfa2b29e291ccfa97a5678bbbc398dd14e888914bfddc6f7e61bac4a3a
diff --git a/net-dns/dnscrypt-proxy/dnscrypt-proxy-1.9.4.ebuild b/net-dns/dnscrypt-proxy/dnscrypt-proxy-1.9.4.ebuild
new file mode 100644 (file)
index 0000000..b8069db
--- /dev/null
@@ -0,0 +1,62 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit systemd user
+
+DESCRIPTION="A tool for securing communications between a client and a DNS resolver"
+HOMEPAGE="https://dnscrypt.org"
+SRC_URI="https://download.dnscrypt.org/${PN}/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="hardened libressl +plugins ssl systemd"
+
+RDEPEND="
+       dev-libs/libsodium
+       net-libs/ldns
+       ssl? (
+               !libressl? ( dev-libs/openssl:0= )
+               libressl? ( dev-libs/libressl:0= )
+       )
+       systemd? ( sys-apps/systemd )"
+DEPEND="${RDEPEND}
+       virtual/pkgconfig"
+
+DOCS="AUTHORS ChangeLog NEWS README* THANKS *txt"
+
+pkg_setup() {
+       enewgroup dnscrypt
+       enewuser dnscrypt -1 -1 /var/empty dnscrypt
+}
+
+src_configure() {
+       econf \
+               $(use_enable hardened pie) \
+               $(use_enable plugins) \
+               $(use_enable ssl openssl) \
+               $(use_with systemd)
+}
+
+src_install() {
+       default
+
+       newinitd "${FILESDIR}"/${PN}.initd ${PN}
+       newconfd "${FILESDIR}"/${PN}.confd ${PN}
+       systemd_dounit "${FILESDIR}"/${PN}.service
+}
+
+pkg_postinst() {
+       elog "After starting the service you will need to update your"
+       elog "/etc/resolv.conf and replace your current set of resolvers"
+       elog "with:"
+       elog
+       elog "nameserver <DNSCRYPT_LOCALIP>"
+       elog
+       elog "where <DNSCRYPT_LOCALIP> is what you supplied in"
+       elog "/etc/conf.d/dnscrypt-proxy, default is \"127.0.0.1\"."
+       elog
+       elog "Also see https://github.com/jedisct1/dnscrypt-proxy#usage."
+}
index 414c0b498c5e6d88666f9585302397b7762472d4..1363ac8f8fcd26a986459e65e430615ea8279596 100644 (file)
@@ -2,7 +2,7 @@
 Description=A tool for securing communications between a client and a DNS resolver
 
 [Service]
-Type=forking
+Type=simple
 PIDFile=/var/run/dnscrypt-proxy.pid
 EnvironmentFile=/etc/conf.d/dnscrypt-proxy
 ExecStartPre=/bin/rm -f /var/run/dnscrypt-proxy.pid