app-i18n/ibus-m17n: new upstream release
authorAkinori Hattori <hattya@gentoo.org>
Mon, 18 May 2020 14:27:23 +0000 (23:27 +0900)
committerAkinori Hattori <hattya@gentoo.org>
Mon, 18 May 2020 14:27:49 +0000 (23:27 +0900)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Akinori Hattori <hattya@gentoo.org>
app-i18n/ibus-m17n/Manifest
app-i18n/ibus-m17n/ibus-m17n-1.4.2.ebuild [new file with mode: 0644]

index 334f3aa18baaa6e1ccf904fd6fc021552366f1ef..cac532bba15be965c7e0565ec9906d90ff72d8b9 100644 (file)
@@ -1 +1,2 @@
 DIST ibus-m17n-1.3.4.tar.gz 436687 BLAKE2B 66c1138101b1c3634ebeef4657ef9d4accb30e9db0047d7232d1c25a5d061e705fb1f1bd2800c951baadeddf999a4eb24a581d59e261df4fd68d23b29ef3c530 SHA512 9e9bc290b0f0d68558d408f6e69aa3bd9bb767db827a95839b576b58c7a5056dedcbd9b0bf1aab5e26ab21e601acd67a53404a5fd54b436efaf2a706489f25c4
+DIST ibus-m17n-1.4.2.tar.gz 488603 BLAKE2B b916e1cc799eca2f042a0496a1184ccf32174eef1399f9ef7e3b7f3fc6ef2177514159706f1f4a4d696df136e7a5e7967af90ce0e1b4a021ac84e44973fe446c SHA512 5f865bd5d6dcd29828b14ea991effa6e883777173c48dd88cf676890dd2a980f95b3859b90fb44fb8cfe84df6da14335d3060605c4ce517f5eb179497a7b146b
diff --git a/app-i18n/ibus-m17n/ibus-m17n-1.4.2.ebuild b/app-i18n/ibus-m17n/ibus-m17n-1.4.2.ebuild
new file mode 100644 (file)
index 0000000..ed8610c
--- /dev/null
@@ -0,0 +1,49 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit gnome2-utils xdg
+
+DESCRIPTION="M17N engine for IBus"
+HOMEPAGE="https://github.com/ibus/ibus/wiki"
+SRC_URI="https://github.com/ibus/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gtk gtk2 nls"
+REQUIRED_USE="gtk2? ( gtk )"
+
+DEPEND="app-i18n/ibus
+       dev-libs/m17n-lib
+       gtk? (
+               gtk2? ( x11-libs/gtk+:2 )
+               !gtk2? ( x11-libs/gtk+:3 )
+       )
+       nls? ( virtual/libintl )"
+RDEPEND="${DEPEND}
+       >=dev-db/m17n-db-1.7"
+BDEPEND="sys-devel/gettext
+       virtual/pkgconfig"
+
+src_configure() {
+       econf \
+               $(use_enable nls) \
+               $(use_with gtk gtk $(usex gtk2 2.0 3.0))
+}
+
+pkg_preinst() {
+       xdg_pkg_preinst
+       gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+       xdg_pkg_postinst
+       gnome2_schemas_update
+}
+
+pkg_postrm() {
+       xdg_pkg_postrm
+       gnome2_schemas_update
+}