dev-python/scandir: version bump.
authorPatrice Clement <monsieurp@gentoo.org>
Sat, 4 Aug 2018 16:07:58 +0000 (18:07 +0200)
committerPatrice Clement <monsieurp@gentoo.org>
Sun, 5 Aug 2018 13:52:58 +0000 (15:52 +0200)
Package-Manager: Portage-2.3.40, Repoman-2.3.9

dev-python/scandir/Manifest
dev-python/scandir/scandir-1.8.ebuild [new file with mode: 0644]

index b9f6a616c8797281d984fc77c550d8596b9691bf..bef789c764469950320e2f930a04aae20cff8dc8 100644 (file)
@@ -1,2 +1,3 @@
 DIST scandir-1.6.tar.gz 29670 BLAKE2B ad8c231783c14246341cd23bd79185ee10894bb29107ba7c0bfdf51982bda99fd8ce45ea52ff42687371d56b3e6d43cf1d6cc65bdaecf43da9059e524a801e6d SHA512 d01e0551696787caded787a430eea787a69a27c725505277420fd607b3fcc892218377bb340651fd906bdeb3a57e99879df3c86aeadd2399fcbe45cb2118b9db
 DIST scandir-1.7.tar.gz 32812 BLAKE2B ed80775b5acca85d8829e2fb46df33fdda08d9dad6cc0e175d1270dc51b6eb4d381a5bd813e2dfd2072ac0af0d642d20ae818e569688ffbe5decaf4421f5e979 SHA512 47c6d9642938f374eb03228cdb6c8d77aa2af01a84b7efc518d223851562a615b616e92100bbeb38c4fa7455ef5f7ae4af8d406f5148d1a26a403708b4a27023
+DIST scandir-1.8.tar.gz 33065 BLAKE2B 020789b939f347de49dba6eb35cf53733a34b283a4226d91746dca4f26b0fdcbe708cb48a795085c8887921bdad77c3fd054c15dcf83b1f4624ee81f1735f2da SHA512 9c2c578cc736887e7d1ebe51f62569599e386deeac55363a84cd1abe4f73c60a43ae9849b3570ed99079016908ceab5e3755b014256d1cab535c1677255690f3
diff --git a/dev-python/scandir/scandir-1.8.ebuild b/dev-python/scandir/scandir-1.8.ebuild
new file mode 100644 (file)
index 0000000..f355a30
--- /dev/null
@@ -0,0 +1,23 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="A better directory iterator and faster os.walk()"
+HOMEPAGE="https://github.com/benhoyt/scandir"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+       ${EPYTHON} test/run_tests.py -v || die "tests failed under ${EPYTHON}"
+}