dev-python/sphinxcontrib-jsmath: Add missing ns dep & tests
authorMichał Górny <mgorny@gentoo.org>
Mon, 2 Mar 2020 14:49:39 +0000 (15:49 +0100)
committerMichał Górny <mgorny@gentoo.org>
Mon, 2 Mar 2020 15:16:35 +0000 (16:16 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/sphinxcontrib-jsmath/sphinxcontrib-jsmath-1.0.1-r1.ebuild [new file with mode: 0644]

diff --git a/dev-python/sphinxcontrib-jsmath/sphinxcontrib-jsmath-1.0.1-r1.ebuild b/dev-python/sphinxcontrib-jsmath/sphinxcontrib-jsmath-1.0.1-r1.ebuild
new file mode 100644 (file)
index 0000000..cde57a0
--- /dev/null
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Sphinx extension which renders display math in HTML via JavaScript"
+HOMEPAGE="https://www.sphinx-doc.org
+       https://github.com/sphinx-doc/sphinxcontrib-jsmath"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris"
+
+RDEPEND="dev-python/namespace-sphinxcontrib[${PYTHON_USEDEP}]"
+PDEPEND="
+       >=dev-python/sphinx-2.0[${PYTHON_USEDEP}]"
+DEPEND="
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       test? ( ${PDEPEND} )"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+       distutils-r1_python_install_all
+       find "${ED}" -name '*.pth' -delete || die
+}