dev-python/keystoneauth: 4.0.0 bump
authorMatthew Thode <prometheanfire@gentoo.org>
Sat, 16 May 2020 21:06:19 +0000 (16:06 -0500)
committerMatthew Thode <prometheanfire@gentoo.org>
Sat, 16 May 2020 21:21:26 +0000 (16:21 -0500)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
dev-python/keystoneauth/Manifest
dev-python/keystoneauth/keystoneauth-4.0.0.ebuild [new file with mode: 0644]

index 4a939817a375288328e4f6afd31e221127658d9e..e45194a1892810146a1a9e29471b0fc7e539924f 100644 (file)
@@ -1 +1,2 @@
 DIST keystoneauth1-3.17.2.tar.gz 253877 BLAKE2B 9a8f10a5a535ee6ee02859f6a7da38777af250303d0be0feed266c677fea3f6bd465e3e14309c38f67dc5886c846a6aa9a9a7438f5e511f7a80782e29ce88b52 SHA512 6ead83db401d9bb31df87da5c9eff576f621d0b0964c9423de6cdd45777b9a2e3cef27fc20d91fc01b82c64b9b0ffcb83f270b4df7b740319809207ed0b2cb2a
+DIST keystoneauth1-4.0.0.tar.gz 256925 BLAKE2B 3ba149f9333a42c8fc2f876cf3ee4533633ed881a90f2fd944ee1c245d94dab548ea1c363f2085bc995dd588d8d355d779d9357885ecd0ee9c73115216010388 SHA512 c24d10b2ae6318c22bd62596dda952a36ec8ede8a6436aa111657a984b2b3be72e55895c009317b2ad652979701d4dca6f2c3e1764ada20d1c7b676f072f5614
diff --git a/dev-python/keystoneauth/keystoneauth-4.0.0.ebuild b/dev-python/keystoneauth/keystoneauth-4.0.0.ebuild
new file mode 100644 (file)
index 0000000..84a1f46
--- /dev/null
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="This package contains tools for authenticating to an OpenStack-based cloud."
+HOMEPAGE="https://github.com/openstack/keystoneauth"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}1/${PN}1-${PV}.tar.gz"
+S="${WORKDIR}/${PN}1-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+       !~dev-python/pbr-2.1.0"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+       ${CDEPEND}"
+RDEPEND="${CDEPEND}
+       >=dev-python/iso8601-0.1.11[${PYTHON_USEDEP}]
+       >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
+       >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+       >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+       >=dev-python/os-service-types-1.2.0[${PYTHON_USEDEP}]"