app-misc/anki: Switch to PYTHON_MULTI_USEDEP API
authorMichał Górny <mgorny@gentoo.org>
Fri, 7 Feb 2020 09:38:56 +0000 (10:38 +0100)
committerMichał Górny <mgorny@gentoo.org>
Sun, 9 Feb 2020 16:10:47 +0000 (17:10 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
app-misc/anki/anki-2.1.0_beta25.ebuild
app-misc/anki/anki-2.1.0_beta27.ebuild
app-misc/anki/anki-2.1.13-r1.ebuild [moved from app-misc/anki/anki-2.1.13.ebuild with 71% similarity]

index 7a709e1e39e374fc0df29f9719ba926e2bc8e1e1..7e5c0bc5b29079d6d95adcbbbbec48a593c52601 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -23,17 +23,19 @@ RESTRICT="!test? ( test )"
 REQUIRED_USE="${PYTHON_REQUIRED_USE}"
 
 RDEPEND="${PYTHON_DEPS}
-       dev-python/PyQt5[gui,svg,webkit,${PYTHON_USEDEP}]
-       >=dev-python/httplib2-0.7.4[${PYTHON_USEDEP}]
-       dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
-       dev-python/decorator[${PYTHON_USEDEP}]
-       dev-python/markdown[${PYTHON_USEDEP}]
-       dev-python/requests[${PYTHON_USEDEP}]
-       dev-python/send2trash[${PYTHON_USEDEP}]
-       recording? (
-               media-sound/lame
-               >=dev-python/pyaudio-0.2.4[${PYTHON_USEDEP}]
-       )
+       $(python_gen_cond_dep '
+               dev-python/PyQt5[gui,svg,webkit,${PYTHON_MULTI_USEDEP}]
+               >=dev-python/httplib2-0.7.4[${PYTHON_MULTI_USEDEP}]
+               dev-python/beautifulsoup:4[${PYTHON_MULTI_USEDEP}]
+               dev-python/decorator[${PYTHON_MULTI_USEDEP}]
+               dev-python/markdown[${PYTHON_MULTI_USEDEP}]
+               dev-python/requests[${PYTHON_MULTI_USEDEP}]
+               dev-python/send2trash[${PYTHON_MULTI_USEDEP}]
+               recording? (
+                       media-sound/lame
+                       >=dev-python/pyaudio-0.2.4[${PYTHON_MULTI_USEDEP}]
+               )
+       ')
        sound? ( media-video/mplayer )
        latex? (
                app-text/texlive
@@ -41,7 +43,11 @@ RDEPEND="${PYTHON_DEPS}
        )
 "
 DEPEND="${RDEPEND}
-       test? ( dev-python/nose[${PYTHON_USEDEP}] )
+       test? (
+               $(python_gen_cond_dep '
+                       dev-python/nose[${PYTHON_MULTI_USEDEP}]
+               ')
+       )
 "
 
 PATCHES=( "${FILESDIR}"/${P}-web-folder.patch )
index 341c641fe86e3b4aef28c06fe12390034a9b1c30..9b0a46164d62a389d183410082c58db5f0c24023 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -23,23 +23,25 @@ RESTRICT="!test? ( test )"
 REQUIRED_USE="${PYTHON_REQUIRED_USE}"
 
 RDEPEND="${PYTHON_DEPS}
-       || (
-               (
-                       >=dev-python/PyQt5-5.12[gui,svg,widgets,${PYTHON_USEDEP}]
-                       dev-python/PyQtWebEngine[${PYTHON_USEDEP}]
+       $(python_gen_cond_dep '
+               || (
+                       (
+                               >=dev-python/PyQt5-5.12[gui,svg,widgets,${PYTHON_MULTI_USEDEP}]
+                               dev-python/PyQtWebEngine[${PYTHON_MULTI_USEDEP}]
+                       )
+                       <dev-python/PyQt5-5.12[gui,svg,webengine,widgets,${PYTHON_MULTI_USEDEP}]
                )
-               <dev-python/PyQt5-5.12[gui,svg,webengine,widgets,${PYTHON_USEDEP}]
-       )
-       >=dev-python/httplib2-0.7.4[${PYTHON_USEDEP}]
-       dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
-       dev-python/decorator[${PYTHON_USEDEP}]
-       dev-python/markdown[${PYTHON_USEDEP}]
-       dev-python/requests[${PYTHON_USEDEP}]
-       dev-python/send2trash[${PYTHON_USEDEP}]
-       recording? (
-               media-sound/lame
-               >=dev-python/pyaudio-0.2.4[${PYTHON_USEDEP}]
-       )
+               >=dev-python/httplib2-0.7.4[${PYTHON_MULTI_USEDEP}]
+               dev-python/beautifulsoup:4[${PYTHON_MULTI_USEDEP}]
+               dev-python/decorator[${PYTHON_MULTI_USEDEP}]
+               dev-python/markdown[${PYTHON_MULTI_USEDEP}]
+               dev-python/requests[${PYTHON_MULTI_USEDEP}]
+               dev-python/send2trash[${PYTHON_MULTI_USEDEP}]
+               recording? (
+                       media-sound/lame
+                       >=dev-python/pyaudio-0.2.4[${PYTHON_MULTI_USEDEP}]
+               )
+       ')
        sound? ( media-video/mplayer )
        latex? (
                app-text/texlive
@@ -47,7 +49,11 @@ RDEPEND="${PYTHON_DEPS}
        )
 "
 DEPEND="${RDEPEND}
-       test? ( dev-python/nose[${PYTHON_USEDEP}] )
+       test? (
+               $(python_gen_cond_dep '
+                       dev-python/nose[${PYTHON_MULTI_USEDEP}]
+               ')
+       )
 "
 
 PATCHES=( "${FILESDIR}"/${PN}-2.1.0_beta25-web-folder.patch )
similarity index 71%
rename from app-misc/anki/anki-2.1.13.ebuild
rename to app-misc/anki/anki-2.1.13-r1.ebuild
index 15c2f2cdf07518bc617ecdf29e75b66023e7b5bb..9c1a33eea458ba42283e085a1a2fbfc05f3a85a9 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -22,19 +22,21 @@ RESTRICT="!test? ( test )"
 REQUIRED_USE="${PYTHON_REQUIRED_USE}"
 
 RDEPEND="${PYTHON_DEPS}
-       || (
-               (
-                       >=dev-python/PyQt5-5.12[gui,svg,widgets,${PYTHON_USEDEP}]
-                       dev-python/PyQtWebEngine[${PYTHON_USEDEP}]
+       $(python_gen_cond_dep '
+               || (
+                       (
+                               >=dev-python/PyQt5-5.12[gui,svg,widgets,${PYTHON_MULTI_USEDEP}]
+                               dev-python/PyQtWebEngine[${PYTHON_MULTI_USEDEP}]
+                       )
+                       <dev-python/PyQt5-5.12[gui,svg,webengine,widgets,${PYTHON_MULTI_USEDEP}]
                )
-               <dev-python/PyQt5-5.12[gui,svg,webengine,widgets,${PYTHON_USEDEP}]
-       )
-       >=dev-python/httplib2-0.7.4[${PYTHON_USEDEP}]
-       dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
-       dev-python/decorator[${PYTHON_USEDEP}]
-       dev-python/markdown[${PYTHON_USEDEP}]
-       dev-python/requests[${PYTHON_USEDEP}]
-       dev-python/send2trash[${PYTHON_USEDEP}]
+               >=dev-python/httplib2-0.7.4[${PYTHON_MULTI_USEDEP}]
+               dev-python/beautifulsoup:4[${PYTHON_MULTI_USEDEP}]
+               dev-python/decorator[${PYTHON_MULTI_USEDEP}]
+               dev-python/markdown[${PYTHON_MULTI_USEDEP}]
+               dev-python/requests[${PYTHON_MULTI_USEDEP}]
+               dev-python/send2trash[${PYTHON_MULTI_USEDEP}]
+       ')
        recording? ( media-sound/lame )
        sound? ( media-video/mpv )
        latex? (
@@ -43,7 +45,11 @@ RDEPEND="${PYTHON_DEPS}
        )
 "
 DEPEND="${RDEPEND}
-       test? ( dev-python/nose[${PYTHON_USEDEP}] )
+       test? (
+               $(python_gen_cond_dep '
+                       dev-python/nose[${PYTHON_MULTI_USEDEP}]
+               ')
+       )
 "
 
 PATCHES=( "${FILESDIR}"/${PN}-2.1.0_beta25-web-folder.patch )