app-emacs/with-editor: add 2.7.3
authorHans de Graaff <graaff@gentoo.org>
Sun, 3 Jun 2018 05:21:25 +0000 (07:21 +0200)
committerHans de Graaff <graaff@gentoo.org>
Sun, 3 Jun 2018 05:21:25 +0000 (07:21 +0200)
Package-Manager: Portage-2.3.40, Repoman-2.3.9

app-emacs/with-editor/Manifest
app-emacs/with-editor/with-editor-2.7.3.ebuild [new file with mode: 0644]

index 8e0343249c873d32cd150108a4006513553dcbf2..3dcdd707f5c56da8fafaee91658b5f3596cedeba 100644 (file)
@@ -1,2 +1,3 @@
 DIST with-editor-2.6.0.tar.gz 28124 BLAKE2B b727fc645cba8c85e0ff688ffbb7fd165feeb3e2fe5033475d9f9b333435cdbb4bc6e0c05f862021c1cd32dcdf1c813a0d3a8fb6221a757c7cf4ee4853d40272 SHA512 454af6222f54b6695aedb085b6f9a4e60d4ebd9dd6047d67cba13087d3966670aa63358dff45633f3492152f6a15c4c1e92efbaaa787867fef9edcf8b14f690c
 DIST with-editor-2.7.2.tar.gz 30121 BLAKE2B a610348a3a2b26059bf58b4b26fdb4e2edddcf70604db7c9d69d2050f4ed1ac745cf94638656339a915ac11a2abe0e8eee5fcb73c768747a8d14078931106332 SHA512 9d412928ce5234d3541d717b5b800312c82495f937088cb8308ff64ab92d2639ce078cdc8eb86d34b775a0e6567409249d58d94eb61183b82b5c19e2465905a7
+DIST with-editor-2.7.3.tar.gz 30133 BLAKE2B af4455f06f5aa867fa7b57222b62a060dd325bea8ef4b408177666914cb97a4f614f13daaf281fe9ca65b90e94dbda33fcb845e822e025ed8b415c4d0d01d3a9 SHA512 1c613e49bfe4a9812e69ec62d6518b29e59bfde84c83097323dfa3274da7fe4ff6431c0ebcbbc889c2237bc535d7cdb2ab7ab1dd171b26e553f03dcf71efd09c
diff --git a/app-emacs/with-editor/with-editor-2.7.3.ebuild b/app-emacs/with-editor/with-editor-2.7.3.ebuild
new file mode 100644 (file)
index 0000000..e967a12
--- /dev/null
@@ -0,0 +1,24 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+NEED_EMACS=24
+
+inherit elisp
+
+DESCRIPTION="Use the Emacsclient as the \$EDITOR of child processes"
+HOMEPAGE="https://magit.vc/manual/with-editor"
+SRC_URI="https://github.com/magit/with-editor/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+SITEFILE="50${PN}-gentoo.el"
+ELISP_TEXINFO="*.texi"
+DOCS="README.md with-editor.org"
+
+DEPEND=""
+# Versions of magit before 2.5.0 bundled with-editor
+RDEPEND="!!<app-emacs/magit-2.5.0 ${DEPEND}"
+DEPEND="${DEPEND} sys-apps/texinfo"