dev-python/tempora: Remove redundant versions
authorMichał Górny <mgorny@gentoo.org>
Wed, 25 Mar 2020 13:37:36 +0000 (14:37 +0100)
committerMichał Górny <mgorny@gentoo.org>
Wed, 25 Mar 2020 13:59:13 +0000 (14:59 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/tempora/Manifest
dev-python/tempora/tempora-1.7.ebuild [deleted file]
dev-python/tempora/tempora-2.0.0.ebuild [deleted file]
dev-python/tempora/tempora-2.1.0.ebuild [deleted file]

index d70e219e739facba699a7990867a9c651f6f67cd..4195a5472f09763c9dab6a23912019b967c7e686 100644 (file)
@@ -1,5 +1,2 @@
 DIST tempora-1.14.1.tar.gz 19383 BLAKE2B f65896391e839c3da43bb42715459b9ab870a724722bfc83c129f18032e731d69b2d12635a519226ef4ce99e77a3418e7e1a05a116a80c222b4e8138f9966f9e SHA512 4ecd5430d4d90959b0985908a1e4f239a56ce0026cd315ef6b8c204b645caccb135db76bb2ca9cb95bc65bdf337b61e7c31514eb9c85036771469b6a058edfbb
-DIST tempora-1.7.tar.gz 11645 BLAKE2B d354fb863a8d30bd9e603ad942d7c7f61a70c24e7f1fe94fffd59982431190e2807c2dc577ff83eb90ffc5fd2b2f8415965de1d77e4dca0dd02291733bfbb97c SHA512 2420e32a9b8c990609d8f09225004e0b1c445cad1fe3c3c74625cb8317b552469acf2d3b28aa56633a87260a93c77d73b02178cb662016c514bc740aa01399e5
-DIST tempora-2.0.0.tar.gz 19828 BLAKE2B af06f7cfd6742c41fa08333da30bd2b6173affe4d368024122d0464856fa3e2264c85d34505cae023167b4266ed0e927a5a8d620101c02c352cf08b269c8c6b4 SHA512 9f488ecca0673a0071503475378bc8f5ddcfabb32fcc548392434df45767fbeb8b914117622ec6f9dc6a8de90e5bfe6e5571a9a18ddecf7c25e94fc1f7fff102
-DIST tempora-2.1.0.tar.gz 21329 BLAKE2B a157a6b9bcb21aac08693ec72e60d011c29d4e6320706186b8a656f096ce19140731e41ca0b7b8b98110a2eed8cee2bfce5ca303b3a7526bbfaec8aafaffff3d SHA512 f66ebf03d5c6d71f1316e3ac9b2c16a96eb622e553917f7e52fe8881cbd5f4651174130e70d2212cad78811859dfb4fe248e6f81a5bb6c928a0c43e9363d2c4e
 DIST tempora-3.0.0.tar.gz 21500 BLAKE2B 7bf241d5ab60c78c0ea56df6b28e33504200eb5427cdffaf9d5f34da202c3ba4550fa4dcc48874ee870345fa5a10f2b874687fe7de2bbe049b1c14d05161b0e0 SHA512 2d397c1d17bb4c502817ad0278090137fb8ca00273c63a7336200ed7e621a99cd5c954cdc2da00d06eba34ed4f079429f5ddc68b928cc83feacb2335f995e1b7
diff --git a/dev-python/tempora/tempora-1.7.ebuild b/dev-python/tempora/tempora-1.7.ebuild
deleted file mode 100644 (file)
index 0bd03e5..0000000
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_6 pypy3 )
-
-inherit distutils-r1
-
-MY_PN="${PN/-/.}"
-DESCRIPTION="Objects and routines pertaining to date and time"
-HOMEPAGE="https://github.com/jaraco/tempora"
-SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
-       dev-python/pytz[${PYTHON_USEDEP}]
-       dev-python/six[${PYTHON_USEDEP}]
-"
-DEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       >=dev-python/setuptools_scm-1.15.0[${PYTHON_USEDEP}]
-       doc? (
-               >=dev-python/jaraco-packaging-3.2[${PYTHON_USEDEP}]
-               dev-python/sphinx[${PYTHON_USEDEP}]
-               >=dev-python/rst-linker-1.9[${PYTHON_USEDEP}]
-       )
-       test? (
-               >=dev-python/pytest-2.8[${PYTHON_USEDEP}]
-               dev-python/backports-unittest-mock[${PYTHON_USEDEP}]
-       )
-"
-
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-python_compile_all() {
-       use doc && esetup.py build_sphinx
-}
-
-python_test() {
-       PYTHONPATH=. py.test || die "tests failed with ${EPYTHON}"
-}
-
-python_install_all() {
-       use doc && local HTML_DOCS=( "${BUILD_DIR}"/sphinx/html/. )
-       distutils-r1_python_install_all
-}
diff --git a/dev-python/tempora/tempora-2.0.0.ebuild b/dev-python/tempora/tempora-2.0.0.ebuild
deleted file mode 100644 (file)
index b34ea9f..0000000
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( pypy3 python3_{6,7,8} )
-
-inherit distutils-r1
-
-MY_PN="${PN/-/.}"
-DESCRIPTION="Objects and routines pertaining to date and time"
-HOMEPAGE="https://github.com/jaraco/tempora"
-SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
-       >=dev-python/jaraco-functools-1.20[${PYTHON_USEDEP}]
-       dev-python/pytz[${PYTHON_USEDEP}]
-"
-BDEPEND="
-       test? (
-               ${RDEPEND}
-               >=dev-python/pytest-2.8[${PYTHON_USEDEP}]
-               dev-python/backports-unittest-mock[${PYTHON_USEDEP}]
-               dev-python/freezegun[${PYTHON_USEDEP}]
-       )
-"
-
-distutils_enable_sphinx docs \
-       ">=dev-python/jaraco-packaging-3.2" \
-       ">=dev-python/rst-linker-1.9"
-
-python_prepare_all() {
-       # avoid a setuptools_scm dependency
-       sed -i "s:use_scm_version=True:version='${PV}',name='${PN//-/.}':" setup.py || die
-       sed -r -i "s:setuptools_scm[[:space:]]*([><=]{1,2}[[:space:]]*[0-9.a-zA-Z]+)[[:space:]]*::" \
-               setup.cfg || die
-
-       distutils-r1_python_prepare_all
-}
-
-python_test() {
-       # Override pytest options to skip flake8
-       # Skip a test that requires pytest-freezegun
-       # because it seems to be poorly maintained
-       PYTHONPATH=. pytest -vv --override-ini="addopts=--doctest-modules" \
-               --deselect tempora/__init__.py::tempora.get_nearest_year_for_day \
-               || die "tests failed with ${EPYTHON}"
-}
diff --git a/dev-python/tempora/tempora-2.1.0.ebuild b/dev-python/tempora/tempora-2.1.0.ebuild
deleted file mode 100644 (file)
index 5f1a40b..0000000
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( pypy3 python3_{6,7,8} )
-
-inherit distutils-r1
-
-MY_PN="${PN/-/.}"
-DESCRIPTION="Objects and routines pertaining to date and time"
-HOMEPAGE="https://github.com/jaraco/tempora"
-SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
-       >=dev-python/jaraco-functools-1.20[${PYTHON_USEDEP}]
-       dev-python/pytz[${PYTHON_USEDEP}]
-"
-BDEPEND="
-       test? (
-               ${RDEPEND}
-               >=dev-python/pytest-2.8[${PYTHON_USEDEP}]
-               dev-python/backports-unittest-mock[${PYTHON_USEDEP}]
-               dev-python/freezegun[${PYTHON_USEDEP}]
-       )
-"
-
-distutils_enable_sphinx docs \
-       ">=dev-python/jaraco-packaging-3.2" \
-       ">=dev-python/rst-linker-1.9"
-
-python_prepare_all() {
-       # avoid a setuptools_scm dependency
-       sed -i "s:use_scm_version=True:version='${PV}',name='${PN//-/.}':" setup.py || die
-       sed -r -i "s:setuptools_scm[[:space:]]*([><=]{1,2}[[:space:]]*[0-9.a-zA-Z]+)[[:space:]]*::" \
-               setup.cfg || die
-
-       distutils-r1_python_prepare_all
-}
-
-python_test() {
-       # Override pytest options to skip flake8
-       # Skip a test that requires pytest-freezegun
-       # because it seems to be poorly maintained
-       PYTHONPATH=. pytest -vv --override-ini="addopts=--doctest-modules" \
-               --deselect tempora/__init__.py::tempora.get_nearest_year_for_day \
-               || die "tests failed with ${EPYTHON}"
-}