dev-embedded/pista: Bump to EAPI 7
authorMichał Górny <mgorny@gentoo.org>
Sun, 10 Nov 2019 11:49:24 +0000 (12:49 +0100)
committerMichał Górny <mgorny@gentoo.org>
Sun, 10 Nov 2019 12:05:46 +0000 (13:05 +0100)
Closes: https://bugs.gentoo.org/697362
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-embedded/pista/pista-0.70.ebuild

index f9431fbdcf3109de76b00963ae3db2a0a298d646..5c585c7fc9785e7ff5e105bc2de92bdb871b0660 100644 (file)
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=0
+EAPI=7
 
 DESCRIPTION="Commandline-driven interface to PICSTART+ PIC programmer"
 HOMEPAGE="http://gatling.ikk.sztaki.hu/~kissg/pd/pista/pista.html"
@@ -15,13 +15,10 @@ IUSE=""
 
 RDEPEND="dev-lang/perl
        dev-perl/TermReadKey"
+DEPEND="dev-lang/perl"
 
-src_compile() {
-       perl Makefile.PL PREFIX=/usr || die "Running Makefile.PL failed"
-       emake || die "make failed"
-}
+DOCS=( README Changes Copyright doc/pista.html )
 
-src_install() {
-       emake install DESTDIR=${D} || die
-       dodoc README Changes Copyright doc/pista.html
+src_configure() {
+       perl Makefile.PL PREFIX=/usr || die "Running Makefile.PL failed"
 }