games-fps/openarena: support building only a server
authorAlexey Sokolov <sokolov@google.com>
Fri, 18 Oct 2019 23:51:16 +0000 (00:51 +0100)
committerJames Le Cuirot <chewi@gentoo.org>
Sat, 19 Oct 2019 22:22:09 +0000 (23:22 +0100)
Package-Manager: Portage-2.3.76, Repoman-2.3.16
Signed-off-by: Alexey Sokolov <sokolov@google.com>
Closes: https://github.com/gentoo/gentoo/pull/13336
Signed-off-by: James Le Cuirot <chewi@gentoo.org>
games-fps/openarena/metadata.xml
games-fps/openarena/openarena-0.8.8-r1.ebuild

index fb6c4d02068e4357b2396d2fea61d0729e63149f..ec45d585b91b037d1a42aca2faf1a0b7218949b2 100644 (file)
@@ -5,6 +5,9 @@
                <email>games@gentoo.org</email>
                <name>Gentoo Games Project</name>
        </maintainer>
+       <use>
+               <flag name="client">Build OpenArena client</flag>
+       </use>
        <upstream>
                <remote-id type="sourceforge">oarena</remote-id>
        </upstream>
index 7440f19e8ec026308db27e033fec0e7614232a2e..f9a04f80a0b255a85e70654f6ae5bf9084b2152e 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -12,21 +12,23 @@ SRC_URI="mirror://sourceforge/oarena/${P}.zip
 LICENSE="GPL-2"
 SLOT="0"
 KEYWORDS="~amd64 ~x86"
-IUSE="+curl +openal +vorbis"
+IUSE="+client +curl +openal +vorbis"
 
 RDEPEND="
-       media-libs/libsdl[joystick,opengl,video]
-       media-libs/speex
-       media-libs/speexdsp
-       virtual/jpeg:0
-       virtual/opengl
-       x11-libs/libXext
-       x11-libs/libX11
-       x11-libs/libXau
-       x11-libs/libXdmcp
-       curl? ( net-misc/curl )
-       openal? ( media-libs/openal )
-       vorbis? ( media-libs/libvorbis )
+       client? (
+               media-libs/libsdl[joystick,opengl,video]
+               media-libs/speex
+               media-libs/speexdsp
+               virtual/jpeg:0
+               virtual/opengl
+               x11-libs/libXext
+               x11-libs/libX11
+               x11-libs/libXau
+               x11-libs/libXdmcp
+               curl? ( net-misc/curl )
+               openal? ( media-libs/openal )
+               vorbis? ( media-libs/libvorbis )
+       )
 "
 DEPEND="${RDEPEND}
        app-arch/unzip
@@ -52,6 +54,7 @@ src_compile() {
        # also build always server and use smp by default
        myopts="USE_INTERNAL_SPEEX=0 USE_VOIP=1 USE_MUMBLE=0
                BUILD_SERVER=1 BUILD_CLIENT_SMP=1 USE_LOCAL_HEADERS=0"
+       use client || myopts="${myopts} BUILD_CLIENT=0"
        use curl || myopts="${myopts} USE_CURL=0"
        use openal || myopts="${myopts} USE_OPENAL=0"
        use vorbis || myopts="${myopts} USE_CODEC_VORBIS=0"
@@ -67,7 +70,7 @@ src_compile() {
 
 src_install() {
        cd "${MY_S}"/"${BUILD_DIR}"
-       newbin openarena-smp.* "${PN}"
+       use client && newbin openarena-smp.* "${PN}"
        newbin oa_ded.* "${PN}-ded"
        cd "${S}"
 
@@ -75,6 +78,8 @@ src_install() {
        doins -r baseoa missionpack
 
        dodoc CHANGES CREDITS LINUXNOTES README
-       newicon "${MY_S}"/misc/quake3.png ${PN}.png
-       make_desktop_entry ${PN} "OpenArena"
+       if use client; then
+               newicon "${MY_S}"/misc/quake3.png ${PN}.png
+               make_desktop_entry ${PN} "OpenArena"
+       fi
 }