dev-ros/visp_hand2eye_calibration: Bump to kinetic version and 0.9.3.
authorAlexis Ballier <aballier@gentoo.org>
Sat, 28 Jan 2017 15:52:23 +0000 (16:52 +0100)
committerAlexis Ballier <aballier@gentoo.org>
Sat, 28 Jan 2017 15:53:39 +0000 (16:53 +0100)
Package-Manager: Portage-2.3.3, Repoman-2.3.1

dev-ros/visp_hand2eye_calibration/Manifest
dev-ros/visp_hand2eye_calibration/visp_hand2eye_calibration-0.9.3.ebuild [new file with mode: 0644]
dev-ros/visp_hand2eye_calibration/visp_hand2eye_calibration-9999.ebuild

index bff3bdf7a8800d4aef0abb73d5066af26738343f..14f6b62e98825d4f0a695c4023cdb238ac020186 100644 (file)
@@ -1,2 +1,3 @@
 DIST vision_visp-0.8.0.tar.gz 1010996 SHA256 5166e1f17601328d09716879ceb66135e07bdb71a375765a937e3b78a12b0e54 SHA512 2bf2d69b6e19de21b34869858672662162703ff8b2aea85fdb9a6dafa88d8fe1f97d18587e863f3f7c088697e931a1b6e4e2e37f31fc7caff0906e98debbad1a WHIRLPOOL 015778e4cff63a9dbb5bf5812e38f7564b68cb71886e472062be15ec31a87a7299bff7ef9df50124294e22906420f60075cf6cc69f77df1cd29267b401f655e5
 DIST vision_visp-0.9.1.tar.gz 1014625 SHA256 918bf731a2fab8bd9fa082c0d0f86800710c79eeb9ec5e8b0c8d5baaffb7988d SHA512 f9ce23286fd9c7706364e9d63e6fb3881bad759aeea72313e5d2a24347f152ba90aab1c73d1b468ed3319e99f0a2bcb81208302825c83be686b9528f3b07469e WHIRLPOOL 8af772091c1c3fec475f32ff0d7232b728b3154491c4ed56300221c0ca96661c63c19baa50d6cdf010d1ffc304049f0ea1e7f5c403f15fb028b1417e41ed88b4
+DIST vision_visp-0.9.3.tar.gz 1014883 SHA256 bf51470d167b1ee202dc55348ad54f6398f0f951b3af06fd32d0689b2fa98347 SHA512 e5775e410efefaaac00cdfaf07b65f9f77ade0e7d6f40b3d8345d7b594520f46741f56039c1eb0193c57287bafbddf8e755e10d6f85cc12ddefb2b997681f44a WHIRLPOOL 9163c1aa27f405213aa7290d9e7ecb4b4f6d0daf79879708bd9246fac9eeb3c6b816de3505729b17cb72357e684bb7af9db6688441c42b279089fbdd8116acc0
diff --git a/dev-ros/visp_hand2eye_calibration/visp_hand2eye_calibration-0.9.3.ebuild b/dev-ros/visp_hand2eye_calibration/visp_hand2eye_calibration-0.9.3.ebuild
new file mode 100644 (file)
index 0000000..039406c
--- /dev/null
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/lagadic/vision_visp"
+KEYWORDS="~amd64 ~arm"
+VER_PREFIX="kinetic-"
+ROS_SUBDIR=${PN}
+CATKIN_HAS_MESSAGES=yes
+PYTHON_COMPAT=( python{2_7,3_4} )
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs dev-ros/geometry_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Estimates the camera position with respect to its effector using the ViSP library"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+       dev-ros/image_proc
+       dev-ros/roscpp
+       dev-ros/sensor_msgs
+       dev-ros/visp_bridge
+       dev-ros/visp_tracker
+       sci-libs/ViSP:=
+"
+DEPEND="${RDEPEND}"
+if [ "${PV#9999}" = "${PV}" ] ; then
+       S="${WORKDIR}/vision_visp-kinetic-${PV}/${ROS_SUBDIR}"
+fi
index 40b5398c28810a266efc88d35b2b7fe86b4c28e6..039406cf6585a5a9b7f99853e6c3a9196ead1592 100644 (file)
@@ -1,11 +1,11 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
 EAPI=5
 ROS_REPO_URI="https://github.com/lagadic/vision_visp"
 KEYWORDS="~amd64 ~arm"
-VER_PREFIX="jade-"
+VER_PREFIX="kinetic-"
 ROS_SUBDIR=${PN}
 CATKIN_HAS_MESSAGES=yes
 PYTHON_COMPAT=( python{2_7,3_4} )
@@ -28,5 +28,5 @@ RDEPEND="
 "
 DEPEND="${RDEPEND}"
 if [ "${PV#9999}" = "${PV}" ] ; then
-       S="${WORKDIR}/vision_visp-jade-${PV}/${ROS_SUBDIR}"
+       S="${WORKDIR}/vision_visp-kinetic-${PV}/${ROS_SUBDIR}"
 fi