x11-libs/gtksourceview: version bump 3.24.4 → 3.24.6
authorGilles Dartiguelongue <eva@gentoo.org>
Sun, 17 Dec 2017 18:28:10 +0000 (19:28 +0100)
committerGilles Dartiguelongue <eva@gentoo.org>
Sun, 17 Dec 2017 18:29:04 +0000 (19:29 +0100)
Package-Manager: Portage-2.3.19, Repoman-2.3.6

x11-libs/gtksourceview/Manifest
x11-libs/gtksourceview/gtksourceview-3.24.6.ebuild [new file with mode: 0644]

index 8f3c74b43cf4bd511f32e5d7d0acf516cf7ff0e3..161ed7d8b7e63b58a36ba68a986843d577d65b4f 100644 (file)
@@ -2,3 +2,4 @@ DIST gtksourceview-2.10.5.tar.bz2 1253321 BLAKE2B 810a3eeca69bab4356b21c64129bb8
 DIST gtksourceview-3.22.2.tar.xz 1596384 BLAKE2B d638cdec2aaa510c0039d9cbda3105e0c6ca6586cbf6e542370efafcf52f01aaf59b163a44f93544dbcfa1535f3d6d2f84206e5a912d2101319b553b53b5e6d1 SHA512 1d51a975471172835cd9af64828ba93eb1b45e26fae91b1778c5963a8578404bbbdf1fe7f2c92953dff436bf2dac2d9e01a5188216d2a60a705e4635f0c91b81
 DIST gtksourceview-3.24.3.tar.xz 1625584 BLAKE2B ec040a91d8c98a28bd488a91652b3a8a17b1d3d88fe85e58fc2c68743f4136b435fcfdb64d7b072d077d29386acc33f1d29d50d98933a192b37ef8d350f793fb SHA512 354a06502d55d7b237d5cbec5a35102225ae3d7e80e53d1ba42e506fc9c75470c4548b4ab8e9e6b2813d732617a2f13b978194240556b8d810066c94ec13de44
 DIST gtksourceview-3.24.4.tar.xz 1619860 BLAKE2B 4d402bf96be9a52d88f974314e165946bcad49ab70474cf3528c8ca924a4f49c2dfdb3f8c9797a41e962f9e53be9ac040f386f17719cbd560b4b65cbe434ea71 SHA512 fef2008dccae6bca859f99b7171851b84f30e7b4cdb00500972039bf111ab5901498820c91926374a7b446491330c55f7179e8522b90279d0169371981bc90fd
+DIST gtksourceview-3.24.6.tar.xz 1623288 BLAKE2B 2332b31534f4fb7e4115e3827c3d57fe4d465eda67c977d238521fc68e0390809e1f0fc46e75adec2b966c83fe5ce0caa3cf312eba97bba76b9b7719b94ca42b SHA512 1b7621dbc1effc979fe08af8e6683ef43cc25563aab37a87abce15a0aa74bd0698bf10377a3fc2539b0cba1ad2f4bce2bb3981ef2dd4245bfe2fcba866d72f5d
diff --git a/x11-libs/gtksourceview/gtksourceview-3.24.6.ebuild b/x11-libs/gtksourceview/gtksourceview-3.24.6.ebuild
new file mode 100644 (file)
index 0000000..1e25a75
--- /dev/null
@@ -0,0 +1,58 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+VALA_MIN_API_VERSION="0.24"
+VALA_USE_DEPEND="vapigen"
+
+inherit gnome2 vala virtualx
+
+DESCRIPTION="A text widget implementing syntax highlighting and other features"
+HOMEPAGE="https://wiki.gnome.org/Projects/GtkSourceView"
+
+LICENSE="GPL-2+ LGPL-2.1+"
+SLOT="3.0/3"
+
+IUSE="glade +introspection vala"
+REQUIRED_USE="vala? ( introspection )"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
+
+RDEPEND="
+       >=dev-libs/glib-2.48:2
+       >=dev-libs/libxml2-2.6:2
+       >=x11-libs/gtk+-3.20:3[introspection?]
+       glade? ( >=dev-util/glade-3.9:3.10 )
+       introspection? ( >=dev-libs/gobject-introspection-1.42:= )
+"
+DEPEND="${RDEPEND}
+       >=dev-util/gtk-doc-am-1.25
+       >=sys-devel/gettext-0.19.4
+       dev-util/itstool
+       virtual/pkgconfig
+       vala? ( $(vala_depend) )
+"
+
+src_prepare() {
+       use vala && vala_src_prepare
+       gnome2_src_prepare
+}
+
+src_configure() {
+       gnome2_src_configure \
+               --disable-deprecations \
+               $(use_enable glade glade-catalog) \
+               $(use_enable introspection) \
+               $(use_enable vala)
+}
+
+src_test() {
+       virtx emake check
+}
+
+src_install() {
+       gnome2_src_install
+
+       insinto /usr/share/${PN}-3.0/language-specs
+       doins "${FILESDIR}"/2.0/gentoo.lang
+}