app-benchmarks/stress-ng: bump to version 0.09.42
authorConrad Kostecki <conrad@kostecki.com>
Fri, 5 Oct 2018 15:33:30 +0000 (17:33 +0200)
committerAndreas Sturmlechner <asturm@gentoo.org>
Fri, 5 Oct 2018 21:39:28 +0000 (23:39 +0200)
Closes: https://bugs.gentoo.org/667824
Signed-off-by: Conrad Kostecki <conrad@kostecki.com>
Package-Manager: Portage-2.3.50, Repoman-2.3.11
Closes: https://github.com/gentoo/gentoo/pull/10079
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
app-benchmarks/stress-ng/Manifest
app-benchmarks/stress-ng/files/stress-ng-0.09.42-makefile.patch [new file with mode: 0644]
app-benchmarks/stress-ng/stress-ng-0.09.42.ebuild [new file with mode: 0644]

index e63724e2a461b78741cdf5c09221c433a1102120..b9bca146eb23b1636a2b186c2922ef3b04cabaa8 100644 (file)
@@ -1 +1,2 @@
 DIST stress-ng-0.09.41.tar.xz 359760 BLAKE2B d57d9350744db29d3e61201f146cd6569efae599743cf3e5971d645beba5de99b4162ec735e0f143c1c3cd8cc9e318441bfd97dfcf5db1b26cd7e4543bfcc918 SHA512 d1e2a6442c208d5d32ab688460475a59a2edd73220e44402632650eee022faf5728d282a374f22bcb86ce83662122823a7ba72f9824058d86d9b22a3c1791524
+DIST stress-ng-0.09.42.tar.xz 360452 BLAKE2B fa5ad15f066d8e762fb08cdcd4fe58ea6604890edf2384e0676e6c35645a6fd84c568369dc966d23527820630a0b44ab9b8969f3e170c876b03a194ea72384af SHA512 e209a8777331f91b3ec5fca9f6f664513498b21b5b31338e0882cc6c79674524906e8d0d4a8931ab5b382feac65e15639989fc0672e408aaa2eb84c72a059258
diff --git a/app-benchmarks/stress-ng/files/stress-ng-0.09.42-makefile.patch b/app-benchmarks/stress-ng/files/stress-ng-0.09.42-makefile.patch
new file mode 100644 (file)
index 0000000..66c07ac
--- /dev/null
@@ -0,0 +1,64 @@
+--- a/Makefile 2018-10-05 11:49:55.000000000 +0200
++++ b/Makefile 2018-10-05 17:28:38.000000000 +0200
+@@ -21,7 +21,7 @@
+ # Codename "portable pressure producer"
+ #
+-CFLAGS += -Wall -Wextra -DVERSION='"$(VERSION)"' -O2 -std=gnu99 -pipe
++CFLAGS += -Wall -Wextra -DVERSION='"$(VERSION)"' -std=gnu99
+ #
+ # Pedantic flags
+@@ -339,12 +339,10 @@
+ .o: stress-ng.h Makefile
+ .c.o: stress-ng.h Makefile $(SRC)
+-      @echo "CC $<"
+-      @$(CC) $(CFLAGS) -c -o $@ $<
++      $(CC) $(CFLAGS) -c -o $@ $<
+ stress-ng: $(OBJS)
+-      @echo "LD $@"
+-      @$(CC) $(CPPFLAGS) $(CFLAGS) $(OBJS) -lm $(LDFLAGS) -o $@
++      $(CC) $(CPPFLAGS) $(CFLAGS) $(OBJS) -lm $(LDFLAGS) -o $@
+       @sync
+ makeconfig:
+@@ -365,8 +363,7 @@
+               sed '$$ s/.$$//' >> apparmor-data.c
+       @echo "};" >> apparmor-data.c
+       @echo "const size_t g_apparmor_data_len = sizeof(g_apparmor_data);" >> apparmor-data.c
+-      @echo "CC $<"
+-      @$(CC) -c apparmor-data.c -o apparmor-data.o
++      $(CC) -c apparmor-data.c -o apparmor-data.o
+       @rm -rf apparmor-data.c apparmor-data.bin
+ #
+@@ -381,12 +378,10 @@
+ perf.o: perf.c perf-event.c
+       @$(CC) $(CFLAGS) -E perf-event.c | grep "PERF_COUNT" | sed 's/,/ /' | \
+       awk {'print "#define _SNG_" $$1 " (1)"'} > perf-event.h
+-      @echo CC $<
+-      @$(CC) $(CFLAGS) -c -o $@ $<
++      $(CC) $(CFLAGS) -c -o $@ $<
+ stress-vecmath.o: stress-vecmath.c
+-      @echo CC $<
+-      @$(CC) $(CFLAGS) -fno-builtin -c -o $@ $<
++      $(CC) $(CFLAGS) -fno-builtin -c -o $@ $<
+       @touch stress-ng.c
+ $(OBJS): stress-ng.h Makefile
+@@ -430,10 +425,10 @@
+       ./stress-ng --seq 0 -t 15 --pathological --verbose --times --tz --metrics
+ .PHONY: install
+-install: stress-ng stress-ng.1.gz
++install: stress-ng
+       mkdir -p ${DESTDIR}${BINDIR}
+       cp stress-ng ${DESTDIR}${BINDIR}
+       mkdir -p ${DESTDIR}${MANDIR}
+-      cp stress-ng.1.gz ${DESTDIR}${MANDIR}
++      cp stress-ng.1 ${DESTDIR}${MANDIR}
+       mkdir -p ${DESTDIR}${JOBDIR}
+       cp -rp example-jobs/*.job ${DESTDIR}${JOBDIR}
diff --git a/app-benchmarks/stress-ng/stress-ng-0.09.42.ebuild b/app-benchmarks/stress-ng/stress-ng-0.09.42.ebuild
new file mode 100644 (file)
index 0000000..59b29c7
--- /dev/null
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+DESCRIPTION="Stress test for a computer system with various selectable ways"
+HOMEPAGE="http://kernel.ubuntu.com/~cking/stress-ng/"
+SRC_URI="http://kernel.ubuntu.com/~cking/tarballs/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-libs/libaio
+       dev-libs/libbsd
+       dev-libs/libgcrypt:0=
+       net-misc/lksctp-tools
+       sys-apps/attr
+       sys-apps/keyutils
+       sys-libs/libapparmor
+       sys-libs/libcap
+       sys-libs/zlib:="
+
+RDEPEND="${DEPEND}"
+
+DOCS=( "README" "README.Android" "TODO" "syscalls.txt" )
+
+PATCHES=( "${FILESDIR}/${P}-makefile.patch" )