net-libs/openpgm: Make compatible with py2
authorJustin Lecher <jlec@gentoo.org>
Mon, 24 Aug 2015 10:29:47 +0000 (12:29 +0200)
committerJustin Lecher <jlec@gentoo.org>
Mon, 24 Aug 2015 10:29:51 +0000 (12:29 +0200)
Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=492974

Package-Manager: portage-2.2.20.1
Signed-off-by: Justin Lecher <jlec@gentoo.org>
net-libs/openpgm/openpgm-5.1.118-r1.ebuild [new file with mode: 0644]
net-libs/openpgm/openpgm-5.2.122.ebuild

diff --git a/net-libs/openpgm/openpgm-5.1.118-r1.ebuild b/net-libs/openpgm/openpgm-5.1.118-r1.ebuild
new file mode 100644 (file)
index 0000000..f27d877
--- /dev/null
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=true
+PYTHON_COMPAT=( python2_7 )
+
+inherit autotools-utils python-any-r1
+
+DESCRIPTION="Open source implementation of the Pragmatic General Multicast specification"
+HOMEPAGE="http://code.google.com/p/openpgm"
+SRC_URI="http://openpgm.googlecode.com/files/libpgm-${PV}~dfsg.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE="static-libs"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}"
+
+S="${WORKDIR}/libpgm-${PV}~dfsg/${PN}/pgm"
+
+src_install() {
+       DOCS=( "${S}"/../doc/. "${S}"/README )
+
+       autotools-utils_src_install
+}
index 023987ac04423df44c409dd349a50e32026b2834..cc42dc99bc8270291fbc45c02fdbb1ae0425e4e2 100644 (file)
@@ -18,6 +18,8 @@ SLOT="0"
 KEYWORDS="amd64 arm hppa ppc ppc64 x86 ~x86-fbsd"
 IUSE="static-libs"
 
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
 DEPEND="${PYTHON_DEPS}"
 
 S="${WORKDIR}/libpgm-${PV}~dfsg/${PN}/pgm"