dev-libs/libxslt: Fix QA issues
authorJustin Lecher <jlec@gentoo.org>
Fri, 25 Sep 2015 06:53:36 +0000 (08:53 +0200)
committerJustin Lecher <jlec@gentoo.org>
Fri, 25 Sep 2015 07:11:23 +0000 (09:11 +0200)
Parallel functions in python eclasses are deprecated
configure.in is deprecated

Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=555212

Package-Manager: portage-2.2.21
Signed-off-by: Justin Lecher <jlec@gentoo.org>
dev-libs/libxslt/libxslt-1.1.28-r4.ebuild

index a2af700a8b8af88e1a874dd52b5e1328cb9babf9..a9578e3efa93c36dc72e49b66e818f22a4f29538 100644 (file)
@@ -50,6 +50,8 @@ src_prepare() {
        # https://bugs.gentoo.org/show_bug.cgi?id=518728
        epatch "${FILESDIR}"/${PN}-1.1.28-AC_PATH_TOOL.patch
 
+       mv configure.{in,ac} || die
+
        eautoreconf
        # If eautoreconf'd with new autoconf, then epunt_cxx is not necessary
        # and it is propably otherwise too if upstream generated with new
@@ -79,7 +81,7 @@ multilib_src_configure() {
        libxslt_configure --without-python # build python bindings separately
 
        if multilib_is_native_abi && use python; then
-               python_parallel_foreach_impl libxslt_py_configure
+               python_foreach_impl libxslt_py_configure
        fi
 }