dev-python/python_orocos_kdl: bump to 1.4.0
authorAlexis Ballier <aballier@gentoo.org>
Sat, 7 Apr 2018 13:37:42 +0000 (15:37 +0200)
committerAlexis Ballier <aballier@gentoo.org>
Sat, 7 Apr 2018 14:08:16 +0000 (16:08 +0200)
Package-Manager: Portage-2.3.28, Repoman-2.3.9

dev-python/python_orocos_kdl/Manifest
dev-python/python_orocos_kdl/python_orocos_kdl-1.4.0.ebuild [new file with mode: 0644]
dev-python/python_orocos_kdl/python_orocos_kdl-9999.ebuild

index 79956d17a9abca43a0e1c850d1677395b9035644..40912926d3439af9adaf7ccbda020b727a79f9ab 100644 (file)
@@ -1 +1,2 @@
 DIST orocos_kinematics_dynamics-1.3.1.tar.gz 202471 BLAKE2B 46b7bdb62c09e9077b84d914b4d780995f27d486d9c734ef2ee1f8b8c2219265cdba5e63830225e2435b5760b79f00d478670e95b71666959afa773f8bcfe5ce SHA512 93abd9dd5aef3710f784f9db8eea4738458bffa5295923993e2d77656c18f7354559412fb7eb5f1e9da7112de19aa36d3f0f68f149852f955bce960fd3b719e7
+DIST orocos_kinematics_dynamics-1.4.0.tar.gz 215004 BLAKE2B 02ca44195af2ae2bd5c2293869893c56846501e2055ca1cacef602ffdd44824fc618ed528d351ee2212b7c087ff5e69438ab87e9fb8813d8a4eb4c143fdbfd27 SHA512 7156465e2aff02f472933617512069355836a03a02d4587cfe03c1b1d667a9762a4e3ed6e055b2a44f1fce1b6746179203c7204389626a7b458dcab1b28930d8
diff --git a/dev-python/python_orocos_kdl/python_orocos_kdl-1.4.0.ebuild b/dev-python/python_orocos_kdl/python_orocos_kdl-1.4.0.ebuild
new file mode 100644 (file)
index 0000000..2e5a5dc
--- /dev/null
@@ -0,0 +1,60 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+SCM=""
+if [ "${PV#9999}" != "${PV}" ] ; then
+       SCM="git-r3"
+       EGIT_REPO_URI="https://github.com/orocos/orocos_kinematics_dynamics"
+fi
+
+inherit ${SCM} python-r1 cmake-utils
+
+if [ "${PV#9999}" != "${PV}" ] ; then
+       KEYWORDS=""
+       SRC_URI=""
+else
+       KEYWORDS="~amd64 ~arm"
+       SRC_URI="https://github.com/orocos/orocos_kinematics_dynamics/archive/v${PV}.tar.gz -> orocos_kinematics_dynamics-${PV}.tar.gz"
+fi
+
+DESCRIPTION="Python bindings for KDL"
+HOMEPAGE="http://www.orocos.org/kdl"
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+       ${PYTHON_DEPS}
+       sci-libs/orocos_kdl
+       dev-python/sip[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+if [ "${PV#9999}" != "${PV}" ] ; then
+       S=${WORKDIR}/${P}/python_orocos_kdl
+else
+       S=${WORKDIR}/orocos_kinematics_dynamics-${PV}/python_orocos_kdl
+fi
+
+src_configure() {
+       python_foreach_impl cmake-utils_src_configure
+}
+
+src_compile() {
+       python_foreach_impl cmake-utils_src_compile
+}
+
+src_test() {
+       python_foreach_impl cmake-utils_src_test
+}
+
+src_install() {
+       python_foreach_impl cmake-utils_src_install
+
+       # Need to have package.xml in our custom gentoo path
+       insinto /usr/share/ros_packages/${PN}
+       doins "${ED}/usr/share/${PN}/package.xml"
+}
index b251ab8dc3bbc1e2e6376744e79e9f7f6efe50d2..2e5a5dca48ee7a46fd5efaed62b39b88a7fc1d26 100644 (file)
@@ -1,8 +1,8 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=5
-PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
 
 SCM=""
 if [ "${PV#9999}" != "${PV}" ] ; then