app-crypt/certbot: 0.34.0 bump
authorMatthew Thode <prometheanfire@gentoo.org>
Fri, 3 May 2019 16:57:15 +0000 (11:57 -0500)
committerMatthew Thode <prometheanfire@gentoo.org>
Fri, 3 May 2019 16:57:15 +0000 (11:57 -0500)
Package-Manager: Portage-2.3.62, Repoman-2.3.12
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
app-crypt/certbot/Manifest
app-crypt/certbot/certbot-0.34.0.ebuild [new file with mode: 0644]

index 6b792e7d0436f516e85ecef15fa358aa972aa14c..f729567660bd0236bed8b5edc442c1b50fab3067 100644 (file)
@@ -1,2 +1,3 @@
 DIST certbot-0.32.0.tar.gz 1284873 BLAKE2B c3fa538de87b67680a7bc7465d77ab2947606aec4def3717b5d942c83254ff758d751e137bfe33cb6f9362a11a9bad7fba0337927b638f3af7ddf304d408c447 SHA512 fa61e975d2ce09efa3570118f220cd9f9d2fc8d5ab408feb4c4e50bfa795cb28be6c7a78497fb10bc91e577e908126988197ae5d016be4823c5c4ddb68cbf5a4
 DIST certbot-0.33.1.tar.gz 1304071 BLAKE2B 400c12ce254780fc0f336bbcff7917ba1ef4c6a0a708fb9607b79f8e966720a77adea9e56dc110c9424978d18eff15bd372141a0fc79edfb9f8fcc41f5f09f2b SHA512 055030e1ab1d3eb57b980c44732c8ec623d99de2d797a2b825bd2b816fce5b4c4d63d09178eb0a79fb83d991d63f00a149cc043067a2ae42a0ddcaa4fd329979
+DIST certbot-0.34.0.tar.gz 1346939 BLAKE2B db0d7bc716206ff9bebcf953b72e29f46e335209d70e518eeb11d944bab26e2fbe15c6bbe448861cbd71c744dfc22aa8cb54b96dfc5d15d497af8a91cfbc6e45 SHA512 24d4a58bcc220451532b1b7d1ddaa90ef773935ff65c2b06e121f044b5575d159555a757660abebd72ff4134a257394dbc99c981729d846d565c75f692317a30
diff --git a/app-crypt/certbot/certbot-0.34.0.ebuild b/app-crypt/certbot/certbot-0.34.0.ebuild
new file mode 100644 (file)
index 0000000..261fd82
--- /dev/null
@@ -0,0 +1,48 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=(python{2_7,3_5,3_6})
+
+if [[ ${PV} == 9999* ]]; then
+       EGIT_REPO_URI="https://github.com/certbot/certbot.git"
+       inherit git-r3
+else
+       SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+       KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+fi
+
+inherit distutils-r1
+
+DESCRIPTION="Let's encrypt client to automate deployment of X.509 certificates"
+HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="test"
+
+CDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="
+       ${CDEPEND}
+       >=app-crypt/acme-0.29.0[${PYTHON_USEDEP}]
+       >=dev-python/configargparse-0.9.3[${PYTHON_USEDEP}]
+       dev-python/configobj[${PYTHON_USEDEP}]
+       >=dev-python/cryptography-1.2[${PYTHON_USEDEP}]
+       >=dev-python/josepy-1.1.0[${PYTHON_USEDEP}]
+       dev-python/mock[${PYTHON_USEDEP}]
+       >=dev-python/parsedatetime-1.3[${PYTHON_USEDEP}]
+       dev-python/pyrfc3339[${PYTHON_USEDEP}]
+       dev-python/pytz[${PYTHON_USEDEP}]
+       dev-python/zope-component[${PYTHON_USEDEP}]
+       dev-python/zope-interface[${PYTHON_USEDEP}]"
+DEPEND="
+       ${CDEPEND}
+       test? (
+               dev-python/pytest[${PYTHON_USEDEP}]
+       )"
+
+python_test() {
+       # acme is not installed, removing it here is fine, the dir just confuses tests
+       rm -R acme
+       pytest -vv ${PN} || die
+}