Added patch to compile also with vdr-1.4.4_p1
authorMatthias Schwarzott <zzam@gentoo.org>
Sun, 3 Dec 2006 14:50:11 +0000 (14:50 +0000)
committerMatthias Schwarzott <zzam@gentoo.org>
Sun, 3 Dec 2006 14:50:11 +0000 (14:50 +0000)
Package-Manager: portage-2.1.2_rc2-r4

media-plugins/vdr-taste/ChangeLog
media-plugins/vdr-taste/files/vdr-taste-0.0.2d-uint64.diff [new file with mode: 0644]
media-plugins/vdr-taste/vdr-taste-0.0.2d.ebuild

index 9a51488b5361803ca875685c4ee1a0662cc34177..339bc14128084bfcd879026b1224bd5203f524c4 100644 (file)
@@ -1,6 +1,10 @@
 # ChangeLog for media-plugins/vdr-taste
 # Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-taste/ChangeLog,v 1.2 2006/08/15 09:59:25 zzam Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-taste/ChangeLog,v 1.3 2006/12/03 14:50:11 zzam Exp $
+
+  03 Dec 2006; Matthias Schwarzott <zzam@gentoo.org>
+  +files/vdr-taste-0.0.2d-uint64.diff, vdr-taste-0.0.2d.ebuild:
+  Added patch to compile also with vdr-1.4.4_p1
 
   15 Aug 2006; Matthias Schwarzott <zzam@gentoo.org> metadata.xml:
   Assigned to Gentoo VDR Project.
diff --git a/media-plugins/vdr-taste/files/vdr-taste-0.0.2d-uint64.diff b/media-plugins/vdr-taste/files/vdr-taste-0.0.2d-uint64.diff
new file mode 100644 (file)
index 0000000..8648f93
--- /dev/null
@@ -0,0 +1,12 @@
+diff -ru taste-0.0.2d-orig/control.h taste-0.0.2d/control.h
+--- taste-0.0.2d-orig/control.h        2006-12-03 15:48:00.521763680 +0100
++++ taste-0.0.2d/control.h     2006-12-03 15:48:15.469333968 +0100
+@@ -15,7 +15,7 @@
+       const cChannel       *mChannel;
+       const cEvent         *mPresent;
+       const cEvent         *mFollowing;
+-      uint64                mStart;
++      uint64_t              mStart;
+       bool                  mSwitch;
+   cSkinDisplayChannel  *mOsd;
index 4d8d1d5a30cc9cb52a58ee70bd659e70d63c617d..2188355028e5700750f2ea3ce921b2439e8b17f6 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 2004-2006 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-taste/vdr-taste-0.0.2d.ebuild,v 1.1 2006/03/05 11:25:00 zzam Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-taste/vdr-taste-0.0.2d.ebuild,v 1.2 2006/12/03 14:50:11 zzam Exp $
 
 IUSE=""
 inherit vdr-plugin
@@ -15,5 +15,6 @@ LICENSE="GPL-2"
 
 DEPEND=">=media-video/vdr-1.3.7"
 
-PATCHES="${DISTDIR}/${VDRPLUGIN}-${PV}.patch"
+PATCHES="${DISTDIR}/${VDRPLUGIN}-${PV}.patch
+       ${FILESDIR}/${P}-uint64.diff"