dev-ruby/facter: 3.11.4 bump
authorMatthew Thode <prometheanfire@gentoo.org>
Wed, 22 Aug 2018 05:16:59 +0000 (00:16 -0500)
committerMatthew Thode <prometheanfire@gentoo.org>
Wed, 22 Aug 2018 05:17:17 +0000 (00:17 -0500)
Package-Manager: Portage-2.3.48, Repoman-2.3.10

dev-ruby/facter/Manifest
dev-ruby/facter/facter-3.11.4.ebuild [new file with mode: 0644]

index df92cf0d07045e688e36c2bf2ffdba478fb6af33..868765f4765ff9490ce1f50ec933e2980c329a15 100644 (file)
@@ -2,4 +2,5 @@ DIST facter-2.4.6.gem 246272 BLAKE2B 105a43b2697cde0a48d4fcf87e221cfcb348695f817
 DIST facter-3.11.1.tar.gz 384201 BLAKE2B 349493f0046239ed900cb22df6cac2f5c1f748503e057a68e9be34c2f24f134a280ab9292d7f4e754a5974818a1fd01bc55634905d84706b47686a9e7a1ccc39 SHA512 295c91817912fb43fe259ede4b51ecf4ae5efd500d64b2682c700583bfdf694a8849a4bd4cb3a16a8046d563f487225957a49b760cc03d8bf86ac8487e37a756
 DIST facter-3.11.2.tar.gz 384784 BLAKE2B f280772231a9105e5924cdb777411861a76a67c15b4d7f3cc73fb9c089752a4e5fa43c4d84b8525917fae71ae34c770925161cc94882e74a704d6609b1c1778a SHA512 aaeee7449813590ac8bc8d3b1b2a654e75bcdaabbb19f91f8b282f747e0f8af05ef71bc872b99c226f0db4d06b67549551f62c365853f5829c6b26c931c0b582
 DIST facter-3.11.3.tar.gz 384882 BLAKE2B ad6103df38efb6abd68d9f831e53dba2767401e129d55bb94adee4dc3f8bc48c7a969050cc52d395a196883d561317ccb72bfaba2775e003171fd6941935feb8 SHA512 6b2dbc5a0bc1c70739a4c0987311ef0891a27f64ed1b45a46cc20a37e6d1d24fda0481976fbf743f83f10d2014f6e0df0e2b5cc9eba19924e831652e1a8417ef
+DIST facter-3.11.4.tar.gz 388074 BLAKE2B c3105376ba8d74df08e7e19ca7b5291d241d57aebb43a77d0dabe96668a07a62bf70fb18aa3bc3d85011e22f935a711daade17cf60ad867a7503e1b731647c88 SHA512 af58d0592a4b220d8f1d9a6d065da71136b58b7a474587c140021fd2915d920d328bad52178566f26292bd932ca1ac1371a631f88a567876265c7494bb01c518
 DIST facter-3.9.2.tar.gz 380883 BLAKE2B d2804664e0499715230e5696c5a9ebae933f5b43dfb37154251d47763c2c7f78cfa8d1413dd836e5a0c76ed67300d066fa5bb390f17f85cd4cb7a444eaf0d133 SHA512 bc040826311bbff40f5a151ade315d9d47ef1e0f3faa570805e48ca55405265e66308230118b9cd59f701ecd76a7b0fd4d9200dd4ace838521223a162b105374
diff --git a/dev-ruby/facter/facter-3.11.4.ebuild b/dev-ruby/facter/facter-3.11.4.ebuild
new file mode 100644 (file)
index 0000000..683775e
--- /dev/null
@@ -0,0 +1,110 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby23 ruby24 ruby25"
+
+# git-r3 goes after ruby-ng so that it overrides src_unpack properly
+inherit cmake-utils eutils multilib ruby-ng
+
+DESCRIPTION="A cross-platform ruby library for retrieving facts from operating systems"
+HOMEPAGE="http://www.puppetlabs.com/puppet/related-projects/facter/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="debug test"
+if [[ ${PV} == 9999 ]] ; then
+       inherit git-r3
+       EGIT_REPO_URI="https://github.com/puppetlabs/facter.git"
+       EGIT_BRANCH="master"
+else
+       [[ "${PV}" = *_rc* ]] || \
+       KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
+       SRC_URI="https://github.com/puppetlabs/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+BDEPEND="
+       >=sys-devel/gcc-4.8:*
+       dev-cpp/cpp-hocon"
+COMMON_DEPEND="
+       >=dev-libs/leatherman-1.0.0:=
+       dev-libs/openssl:*
+       sys-apps/util-linux
+       app-emulation/virt-what
+       net-misc/curl
+       >=dev-libs/boost-1.54:=[nls]
+       >=dev-cpp/yaml-cpp-0.5.1
+       !<app-admin/puppet-4.0.0"
+
+ruby_add_bdepend "test? ( dev-ruby/rake dev-ruby/rspec:2 dev-ruby/mocha:0.14 )"
+
+RDEPEND="${COMMON_DEPEND}"
+DEPEND="${BDEPEND}
+       ${COMMON_DEPEND}"
+
+# restore ${S} and override all phases exported by ruby-ng.eclass
+S="${WORKDIR}/${P}"
+
+pkg_setup() {
+       ruby-ng_pkg_setup
+}
+
+src_unpack() {
+       default
+
+       if [[ ${PV} == 9999 ]] ; then
+               git-r3_src_unpack
+       fi
+}
+
+src_prepare() {
+       # be explicit about the version of rspec we test with
+       sed -i -e '/libfacter.*specs/ s/rspec/rspec-2/' \
+               CMakeLists.txt || die
+       # be more lenient for software versions for tests
+       sed -i -e '/rake/ s/~> 10.1.0/>= 10/' \
+               -e '/rspec/ s/2.11.0/2.11/' \
+               -e '/mocha/ s/0.10.5/0.14.0/' lib/Gemfile || die
+       # patches
+       default
+       cmake-utils_src_prepare
+}
+
+each_ruby_configure() {
+       # hack for correct calculation of relative path from facter.rb to
+       # libfacter.so
+       my_ruby_sitelibdir=$(ruby_rbconfig_value 'sitelibdir')
+}
+
+src_configure() {
+       ruby-ng_src_configure
+
+       local mycmakeargs=(
+               -DCMAKE_VERBOSE_MAKEFILE=ON
+               -DRUBY_LIB_INSTALL=${my_ruby_sitelibdir}
+               -DBLKID_LIBRARYDIR="${EPREFIX}/$(get_libdir)"
+       )
+       if use debug; then
+               mycmakeargs+=(
+                 -DCMAKE_BUILD_TYPE=Debug
+               )
+       fi
+       cmake-utils_src_configure
+}
+
+src_compile() {
+       cmake-utils_src_compile
+}
+
+src_test() {
+       cmake-utils_src_test
+}
+
+each_ruby_install() {
+       doruby "${BUILD_DIR}"/lib/facter.rb
+}
+
+src_install() {
+       cmake-utils_src_install
+       ruby-ng_src_install
+}